ERR_SSL_VERSION_INTERFERENCE

ERR_SSL_VERSION_INTERFERENCE

The ERR_SSL_VERSION_INTERFERENCE is an SSL related error that usually appears in Google Chrome and Firefox when a site (server) uses TLS1.3. The err_ssl_version_interference error can be solved in a number of ways. Some guides suggest to disable TLS1.3 entirely in your browser, however that isn’t the preferred solution als TLS1.3 offers major security and performance benefits over TLS1.2 and lower TLS versions.

A possible cause of this error can be a mismatch in TLS1.3 versions supported by the webserver and browser. Since TLS1.3 is still in development, having an older version of TLS1.3 on your webserver while using a browser that only supports the latest TLS1.3 release can result in issues. Major webbrowsers are aware of potential issues and are constantly working to fix them. Therefore, the first thing you should try when you encounter this error is to update your browser. Having an up-to-date browser is always recommended since the latest version contains the newest security- and bugfixes and is considered the most secure.

While this error often seems to be related to webbrowsers, sometimes this error can occur even when your browser is up-to-date. In these cases, there’s often a misconfiguration on the webserver of an issue with the SSL certificate that’s causing the err_ssl_version_interference error.

Check your server configuration

If your browser is up-to-date, it’s possible that the webserver still uses and older/development version of TLS. As explained above this can result in the err_ssl_version_interference error.

Check your SSL certificate

While this issue often occurs locally in specific browsers, it’s very well possible that there is an error in the server configuration/certificate configuration of the website you are trying to visit. We have come across this error on sites that don’t use TLS1.3. One thing you can do when you see this error is do a scan of your SSL certificate. This can be easily done with the Qualys SSL Labs SSL test. Any issues with your certificate will appear in this test. If you do see any SSL related errors, contact your hosting provider to fix them.

Update your Antivirus/Firewall

There have been issues with Kaspersky and Google Chrome in the past where the ‘Inspect SSL traffic’ option in Kaspersky was causing the err_ssl_version_interference error in Chrome. Some antivirus products allow SSL traffic to be inspected. This done by adding their own SSL certificate to sites so traffic can be intercepted and analysed. For a detailed explanation of how this works check out this blog by Avast. There are other antivirus products that also use a man-in-the-middle approach for SSL certificates when the ‘Enable HTTPS scanning’ option has been enabled. Keeping your antivirus up-to-date can solve the err_ssl_version_interference error.

 

 

 

Related Articles

    Leave a Comment