SSL

Complianz GDPR free WordPress plugin

The last months we have been working hard on our full service GDPR plugin for WordPress, and yesterday we have released the free version of the Complianz GDPR WordPress plugin. This plugin is meant for website owners with visitors in the European Union, who want to comply with the new GDPR privacy regulations.

There are a lot of cookie warning plugins around, and a lot GDPR tools available, but Complianz GDPR provides the website owner not only with a cookie warning (only if needed), but also with a legally validated set of documents as required by these new laws, like a privacy policy, cookie policy etc.

I also notice a lot of these plugins do not actively block cookies when a users declines, or does not accept. In my opinion, this is the point of the cookie warning: that you can accept the cookies, or not. If the cookies are placed anyway, there’s no point in warning.

The plugin includes a wizard,, which can tell you if you need a cookie warning, and if so will add it to your website (style configurable). To do this you need to answer some questions, and the plugin will scan your site foor cookies and social services.

The cookie warning will also actively block the placing of cookies on the front-end, also from third party services like Facebook, Linkedin, Google, etc.

A unique feature of this plugin is that it can generate a legally validated cookie policy, customised for your site. Check out our new plugin, and let us know what you think!

Complianz GDPR

Related Articles

  • Version 2.2 released

    Yesterday the new version was released. With support for per site activation on WordPress multisite, easy uninstall option, and even less overhead on the front-end, which was pretty good already...
  • Next step in Google’s push for an all SSL internet

    Since this january, many of you may have received a notification from Google Search Console about non-secure pages where passwords or creditcard data are being submitted. Beginning in January 2017,...
  • Really Simple SSL 2.5.24 – minor multisite fix

    Today Really Simple SSL 2.5.24 was released. Apart from the renaming of a css class, there was only one important change, and this one affecting only sites which: are multisite...
  • SSL only on a few pages?

    If you need to exclude certain pages from SSL, or if you want to have just a few pages on SSL, than the latest plugin I’veĀ  release might just be...

Leave a Comment