Tag Archives: redirect

404 pages Redirect rules

Redirection to subfolder domains redirects to https://www.domain.com/domain.com

If you are running multiple single site WordPress websites in one hosting account, where you redirect to the correct domain using htaccess code like the example this: RewriteEngine on RewriteCond %{REQUEST_URI} !domain/ RewriteCond %{HTTP_HOST} ^domain.com$ [NC,OR] RewriteCond %{HTTP_HOST} ^www.domain.com$ RewriteRule (.*) /domain/$1 [L] the default Really Simple SSL redirect in combination with this code might …

Redirect Loops

My website is in a redirect loop

When you experience a redirect loop, this can be caused by several things. On activation, Really Simple SSL adds a WordPress 301 redirect (as of 2.5.9). You can prevent this redirect from being used either by disabling it in the settings, or, if you can’t access the settings, adding define(“rsssl_no_wp_redirect”, true); to your wp-config.php. Another …

404 pages Redirect rules

www not redirecting to non-www on cloudflare

Recently I encountered an interesting issue with redirection from www to non-www. The non www site worked perfectly after migration to SSL, but the www site gave a 404 not found error, or a SSL server error. The issue was solved in the end by the hosting company. If a user has connected a site …

Excluding/including SSL on specific pages Redirect rules SSL certificate

Preventing subdomains or add on domains from getting forced to https

If you have several subdomains, or add-on domains, but do not use WordPress Multisite, you’ll need a way to prevent Really Simple SSL from forwarding all subdomains to https. That is, if these subdomains do not have an SSL certificate of course. 1. Go to Really simple ssl settings and check Stop editing the .htaccess …

Plugin conflicts

Troubleshooting with Really Simple SSL

If you are experiencing problems which you don’t have when Really Simple SSL is deactivated, there are some steps you can do to track down the cause. Clear your browser history Most issues are caused by the cache in the browser. Try using a different browser, or on a different device to check if you …