Forum | Really Simple SSL

Your site is not yet configured for the HSTS preload list.

Home Forums General issues Your site is not yet configured for the HSTS preload list.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #93129
    Scott Miller
    Participant

    Just installed the plugin. It said something about the HSTS preload list and that I have to get Premium.
    So I paid $25 and there is no green check mark by
    “- Your site is not yet configured for the HSTS preload list. Read the documentation carefully before you do! Enable the preload list”

    No green check mark by this either
    “- The mixed content fixer is not active on the admin panel. Enable this feature only when you have mixed content on the admin panel. ”

    And when people go to my site they get this nice message

    “This connection is not private. This website may be impersonating “my website” to steal your personal or financial information. You should close this page.”

    I’m on Hostgator if that helps. Would somebody please tell me how to fix this mess?

    #93149
    Rogier
    Keymaster

    Hi Scott,

    This message in your browser means your SSL certificate is not valid. This is also the reason the plugin tells you the mixed content fixer is not detected. You can check what the problem is with your SSL certificate by running a scan on https://ssllabs.com/ssltest

    Let me know if you have any questions.

    #93397
    Scott Miller
    Guest

    I ran the test as you suggested and received all A’s.

    Looks like everything is working with one exception.

    When people go to my site it does not redirect them from http to https
    all the other pages of the site are https.

    What do I need to do to get the auto redirect from http to https?

    Thanks,
    Scott

    #93403
    Rogier
    Keymaster

    If the default wp redirect does not redirect the homepage to https, I would recommend to enable the .htaccess redirect in settings/ssl. For more info on this see:
    https://really-simple-ssl.com/knowledge-base/redirect-https-not-working/

    #93406
    Scott Miller
    Guest

    You said ” I would recommend to enable the .htaccess redirect in settings/ssl.”

    I do not see any such thing in settings.

    I do see Enable WordPress 301 redirection to SSL which is checked

    I also see “Enable 301 .htaccess redirect” which is not checked
    “Enable Javascript redirection to SSL” which is not checked

    Also not checked
    Debug
    Stop editing the .htaccess file
    Switch mixed content fixer hook
    Configure your site for the HSTS preload list

    I feel like I’m so close!

    Thanks for your help,
    Scott Miller

    #93523
    Rogier
    Keymaster

    Yes, you’re very close 😉

    If you check “Enable 301 .htaccess redirect”, the redirect should be forced.

    #337670
    Chantel
    Guest

    Mine is not configured for HSTS Preload either after purchasing Really Simple SSL that is the only thing left unchecked? How do we resolve this issue?

    #337769
    Rogier
    Keymaster

    Hi Chantel, did you enable the HSTS option in settings/ssl/settings? If you enable it, then enable the preload option, you can submit your site to hstspreload.org.

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘Your site is not yet configured for the HSTS preload list.’ is closed to new replies.

Subscribe