wptexturize replaced quotes incorrectly with [en] ones instead of [de-DE]

Home Forums General issues wptexturize replaced quotes incorrectly with [en] ones instead of [de-DE]

This topic contains 18 replies, has 4 voices, and was last updated by  Mark Wolters 3 months, 1 week ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #57901 Reply

    kosmar

    hi, wptexturize doesnt replace “foo” to typographically german quotes, but to english ones – as soon as i activate the Really Simple SSL plugin in WP 4.8.2–de_DE . what’s the deal with it?

    #57903 Reply

    Really Simple SSL does only do three things:
    – redirect to https
    – Change your site url to https
    – Replace all http url’s that are not external hyperlinks to https.

    Possibly wptexturize is not closing the output buffer correctly, or in another way conflicts with the mixed content fixer. You can test this by disabling the mixed content fixer in settings/ssl.

    #57911 Reply

    kosmar

    disabled the “Auto replace mixed content” option – same result.

    #57912 Reply

    Then the issue is probably caused by the fact that your site is on SSL now, not by Really Simple SSL.

    Possibly the wptexturize plugin is not working properly on SSL. You could try deactivating wptexturize, and reactivating. Or re-saving the settings. If that doesn’t help, I would contact the wptexturize support, as I don’t really know what it is their code is doing that breaks on SSL.

    #57924 Reply

    kosmar

    i think wptexturize is a standard wordpress function, sorry i hadnt mentioned that:
    https://codex.wordpress.org/Function_Reference/wptexturize

    #57925 Reply

    kosmar
    #57926 Reply

    If you rename the plugin folder “really-simple-ssl” to “really-simple-ssl-bkp” (using FTP), do you still have the issue?

    #57928 Reply

    If renaming the plugin fixes it, and it is purely a front-end issue, there is a limited number of things that could cause this. An easy way to check this is to use safe mode:
    https://really-simple-ssl.com/knowledge-base/using-safe-mode/

    and add
    define(‘rsssl_no_rest_api_redirect’, true);
    to your wp-config.php

    That would effectively stop the plugin from doing anything. You can then activate it step by step. That could tell us what the cause is.

    #57932 Reply

    kosmar

    yes renaming the folder to “really-simple-ssl-bkp” actually fixed it. i’ll check your link.

    #57941 Reply

    kosmar

    so i have added to wp-config:
    define(“rsssl_safe_mode”, true);
    define(‘rsssl_no_rest_api_redirect’, true);

    plugin is active
    ‘Auto replace mixed content’ is unchecked

    so everything is off i guess?
    but the bug is still happening.

    we do run the pro plugin here, so anything else to turn off or learn from the debug tab?

    #57957 Reply

    Strange. As renaming the core plugin fixed it, I’ll go from the assumption that there’s a feature in the core version that has this effect, so I don’t think pro has anything to do with it.

    Another approach: deactivate all redirects: javascript, .htaccess and wp redirect in the settings.

    If that doesn’t help, we can comment out the code step by step until we find the code:

    When only the front-end is loaded, the plugin only fires rsssl_front_end->force_ssl();

    What happens when you comment out this line, on line 112 of rlrsssl-really-simple-ssl.php, like this:
    //add_action( ‘wp_loaded’, array( self::$instance->rsssl_front_end, ‘force_ssl’ ), 20 );

    If that helps, we can narrow it down some more.
    In this class, the redirects are handled. Disabling the mixed content fixer does not have any effect, so it has to be either the redirects or the wp_rest_api_force_ssl.

    If you comment out in class-front-end.php the contents of the function force_ssl(), does that solve the issue as well?

    Hope we can track down the cause!

    #58074 Reply

    By the way, how can we reproduce this effect? That way we can do some tests ourselves.

    #58078 Reply

    kosmar

    we decided to do the rewriting manually, so cant help you now, but it seems to be reproducable with just a german wordpress installation https://de.wordpress.org/ , make sure frontend language is german too: <html lang=”de-DE”

    without rsssl: “foo” gets replaced to „foo“ (german)
    with rsssl: “foo” gets replaced to “foo” (english)

    #58080 Reply

    kosmar

    darn, this rich editor dows his own replacement. i try with code tags

    without rsssl: “foo” gets replaced to „foo“ (german)
    with rsssl: “foo” gets replaced to “foo” (english)
    
    #58082 Reply

    kosmar

    lol, here you go:

    without rsssl: "foo" gets replaced to „foo“ (german)
    with rsssl: "foo" gets replaced to “foo” (english)
    
    #58083 Reply

    Strange issue. Based on your input, I suspect it’s either the .htaccess or php redirect to https, or the javascript redirect script to https that are causing this, which can be disabled in the settings.

    #59697 Reply

    Mark Wolters
    Keymaster

    Hi,

    we have tried reproducing this issue using WordPress 4.8.2–de_DE using the German quote style but are unable to reproduce this issue. On a fresh install with only Really Simple SSL enabled the quotes remain the same.

    Mark

    #83279 Reply

    Mirko Baschetti
    Participant

    We’ve the same issue with a german installation (WP 4.9.1.) and “Really Simple RSS Pro”. Deactivated all other plugins with same result.

    Can I deactivate the plugin after use it once?

    #83360 Reply

    Mark Wolters
    Keymaster

    Hi Mirko,

    disabling Really Simple SSL via the plugins overview will revert the site back to http://. It is possible to deactivate/remove the plugin and stay on SSL. For that see the following article: https://really-simple-ssl.com/knowledge-base/can-deactivate-really-simple-ssl-activating-ssl/

    Mark

Viewing 19 posts - 1 through 19 (of 19 total)
Reply To: wptexturize replaced quotes incorrectly with [en] ones instead of [de-DE]
Your information: