[Resolved] Website is slow and Google Analytics is not picking up traffic

Home Forums General issues Website is slow and Google Analytics is not picking up traffic

This topic contains 2 replies, has 2 voices, and was last updated by  Rogier Lankhorst 8 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #76336 Reply

    Matt & Char

    Hi there! Thank you for this excellent plugin.

    I have activated Really Simple SSL and under “Settings” checked
    – Auto replace mixed content
    – Enable 301 .htaccess redirect
    – Debug

    I have also forced HTTPS using the .htaccess. This is what shows up in my htaccess file:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^exoticwinetravel\.com [NC]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://exoticwinetravel.com/$1 [R,L]
    # BEGIN WpFastestCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^www.exoticwinetravel.com [NC]
    RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$

    Since transferring to https on 1 Feb, my Google Analytics registered less than 10 visits a day. Also, some of the pages are still loading very slowly.

    Is there something I need to fix for the Google Analytics to work and to speed up the website?

    #76343 Reply

    Matt & Char
    #76344 Reply

    The .htaccess lines you show, do not contain the .htaccess redirect Really Simple SSL will try to insert. Do you see any errors in the debug regarding the redirect?

    The redirect you have inserted yourself contains a major issue: it is a 302 redirect, which Google does not like at all. I suspect this is your main issue.
    The redirect should have [R=301,L] instead of [R, L]

    As for the load time: I notice you have a lot of third party scripts loaded. I’ve noticed that third party scripts can significantly increase load time when on SSL.

    When checking here
    https://tools.pingdom.com/#!/dmYynZ/https://exoticwinetravel.com/

    I see a very long server reponse time. I see you are using a caching plugin, so the site should load from the cache. When the site is loaded from the cache, it doesn’t execute any PHP in the plugins, so that would suggest the server itself is responding slowly over https. Maybe the 301 redirect will help as well.

    If you want to know if Really Simple SSL is causing any delay you can deactivate the mixed content fixer in settings/ssl. I’ve run some tests with this:
    https://really-simple-ssl.com/knowledge-base/really-simple-ssl-make-site-slower/

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Website is slow and Google Analytics is not picking up traffic
Your information: