Forum | Really Simple SSL

Website became Really Slow after SSL

Home Forums General issues Website became Really Slow after SSL

Tagged: 

  • This topic has 113 replies, 3 voices, and was last updated 3 months ago by CLEMENT GRANDJEAN.
Viewing 24 posts - 91 through 114 (of 114 total)
  • Author
    Posts
  • #119545
    Alana
    Guest

    Hi,
    MY site also slowed down after installing the plugin. When I ran a speed test on my website, it said that I need to remove the following redirect chain:
    http://pulledfromhercarriage.com/
    https://pulledfromhercarriage.com/

    I read the thread above and I noticed that you said to enable .htaccess redirect. so, I went to my admin section, then to settings > SSL >settings and I saw an unchecked option called “enable 301 .htaaccess redirect.” Is this the option I should be enabling?

    Also, before I do so, is there any other option that I should be checking or unchecking along with that?
    I’m not tech savvy at all so I’m trying to avoid any resulting issues, otherwise i’ll be lost on how to go about fixing it.

    looking forward to hearing from you.

    #119607
    Mark
    Keymaster

    Hi Alana,

    the .htaccess 301 redirect is the fastest redirect option, so I’d suggest to enable the option. Make sure you have FTP access to your site before enabling the .htaccess redirect option so you can create a backup of the current .htaccess file first.

    In regards to site speed, check out the following article which details why and how sites can become slower after moving to SSL and what you can do about it: https://really-simple-ssl.com/knowledge-base/really-simple-ssl-make-site-slower/.

    The http:// to https:// redirect isn’t an issue, that’s necessary to take your visitors to the secure site. After a while most traffic will come in on https:// and so the redirect isn’t executed, that’s why site speed without the redirect is the most important.

    Mark

    #119741
    Alana
    Guest

    Oh wow! It worked like a charm. My site is so much faster now. Thanks a lot for your help. I really appreciate it.

    #122882
    devop
    Guest

    Hello,

    Website becomes slow when I set SSL. Not sure what the reason is. Can you please have a look?

    Thanks,

    #122886
    devop
    Guest

    echographie-sans-frontieres.com

    #122913
    Rogier
    Keymaster

    Hi,

    Did you enable the .htaccess redirect? This usually helps in speeding up the redirect. Besides that, you could try if deactivating the mixed content fixer in settings/ssl makes a difference. Caching plugins like wp-rocket or fastest cache can often help when the server responds slowly.

    #146306
    edd_user_9760292
    Participant

    Hello everyone,

    I have tried to fix my website loading following many suggestions but my website loads slower and now about 13 mins. Could you all help me please? my website is http://www.antisnoringthailand.com

    #146329
    Mark
    Keymaster

    Hi,

    your website has a long waiting time before the site starts to load, this usually indicates a slow webserver. What you can try is to disable the ‘Mixed content fixer’ option in the plugin settings to see if that increases the speed. The mixed content fixer is the only thing Really Simple SSL runs on the frontend of your site that might have an impact on the sites speed. See https://tools.pingdom.com/#59cd4efa7ec00000 for more information about your sites loading times and what can be done to improve it.

    Mark

    #151369
    D Messina
    Guest

    Same thing happened to me. I purchased the SSL, had an exclamation point next to the URL (the site was currently still fast at this point). I installed the plugin in hopes to resolve the incomplete SSL. Installed the plugin my site came down and I had to delete the plugin manually to get the site back up, this is when I noticed it had suddenly become very slow. Is there somewhere else I should look other than the plugin folder to delete the plugin in its entirety?

    #151371
    Rogier
    Keymaster

    What you are experiencing is not due to Really Simple SSL, as the fact that you already removed the plugin proves. Your site is now on SSL. This will often slow down the site, especially if you are using third party scripts which fail to load over https, or are very slow on https.

    Your site probably had a memory shortage, due to the fact that the plugin will flush the permalinks and caching plugins. As caching plugins and WordPress will then rebuild the cache, this will cause some temporary memory load.

    If you want to have your former speed without any further optimizations, you’ll need to revert to http entirely. You can do this by changing your site_url back to http, or running the deactivation script.
    https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    #151388
    Rogier
    Keymaster

    Just edited a typo: of course I meant “revert to http”, and not “revert to https”, as you were on https on the time of writing.

    #225904
    Magzoso
    Guest

    Hey.
    Please can you see why website loading time is so slow after ssl.
    It takes about 4 seconds to redirect

    #225906
    Mark
    Keymaster

    Hi,

    have you enabled the .htaccess redirect option? That is often the fastest redirect option. Having your site on a shared hosting plan can also cause slower loading times.

    #314327
    sailesh
    Guest

    I am facing same issue with my site https://silvertreeonline.in as per Pingdom site with http load time is 270.8ms and with https 7918.3ms and at slow internet connection its never get loaded. Its open cart 3.0.2.0 version site.

    #315590
    Mark
    Keymaster

    Hi Sailesh,

    your site has a very long initial load time, this can be caused by a number of things. For example a slow webserver, plugin or theme. Really Simple SSL shouldn’t have such an impact on your site. I’d suggest to disable other plugins one by one to see which one causes the long load time. You can also contact your hosting provider about this issue so they can check if they can find anything that causes the long wait time.

    #355267
    michael
    Guest

    Good evening,

    my webpage become very very slow after changing from http to https after using your Really Simple SSL (at leave 100 seconds to load)…..may I know how can we speed out the webpage? thank you~

    #355303
    Rogier
    Keymaster

    Hi Michael,

    In my experience, when a site is extremely slow when on SSL, there is probably a resource (image, js file, or css file) that the website is trying to load over https, but which is not available over https.

    I recommend to check your developer console for timeout errors, then removing that third party from your site.

    #356696
    andrew jebaraj
    Participant

    Greetings.

    I have a similar problem but I’ve tried quite a few solutions. From http I went to https and the load time was quite high. I also run a CDN service (Stackpath), use a caching plugin W3 cache, used the SSL redirect free and pro. I’ve found after SSL the header request takes a while.

    The site is on a VPS as well.

    Here’s my image https://ibb.co/PzHfWr4
    Any ideas, suggestions?

    #356875
    Mark
    Keymaster

    Hi Andrew,

    your site is indeed quite slow. This is usually caused by a slow webserver. I’d suggest to contact your hosting provider about this issue.

    Mark

    #373179
    Vieck Rao
    Guest

    Your RSS sucks. It has completely ruined my site…can’t delete media..can’t add media…I think you made this plugin for the dark ages…

    #373181
    Vieck Rao
    Guest

    In fact it has so screwed things up that even I can’t see log stats. GUYS UNINSTALL this shit.

    #373309
    Rogier
    Keymaster

    Hi Vieck,

    Can you share a domain so we can take a look. As there are over 4 million users without issues, there must be something off on your setup. We’re happy to help.

    #386490
    Joep
    Guest

    Hi There,

    First of all, I love your plugin. Great work!

    I hope someone can help me out on this forum. I have a problem on one of my websites. The website https://topframe.nl has always been fast, but suddenly it is very slow.
    I contacted the hosting provider and they came to the conclusion that the slowness is due to the combination of the WP Enfold theme and https.
    As soon as the website is back on http in combination with Enfold, the site is fast.
    If the default theme Twenty twenty is active on the website and https then the website is also fast.

    I already deactivate all the plugins, but still no succes.

    Hopefully someone can help me out.

    Thank you very much in advance.

    WordPress version 5.4.1
    Enfold version 4.7.4

    #386598
    Rogier
    Keymaster

    Hi Joep,

    In my experience, when this happens, there is a third party resource in included in the website, or maybe a hot linked image, that is loading very slow over https. It’s also possible the PHP code from the theme calls an API which doesn’t respond with this new URL.

    As it seems to be theme specific, I would contact the theme developers about this.

Viewing 24 posts - 91 through 114 (of 114 total)
  • The topic ‘Website became Really Slow after SSL’ is closed to new replies.

Subscribe