Website became Really Slow after SSL

Home Forums General issues Website became Really Slow after SSL

This topic contains 100 replies, has 7 voices, and was last updated by  Rogier Lankhorst 1 day, 21 hours ago.

Viewing 11 posts - 91 through 101 (of 101 total)
  • Author
    Posts
  • #119545 Reply

    Alana

    Hi,
    MY site also slowed down after installing the plugin. When I ran a speed test on my website, it said that I need to remove the following redirect chain:
    http://pulledfromhercarriage.com/
    https://pulledfromhercarriage.com/

    I read the thread above and I noticed that you said to enable .htaccess redirect. so, I went to my admin section, then to settings > SSL >settings and I saw an unchecked option called “enable 301 .htaaccess redirect.” Is this the option I should be enabling?

    Also, before I do so, is there any other option that I should be checking or unchecking along with that?
    I’m not tech savvy at all so I’m trying to avoid any resulting issues, otherwise i’ll be lost on how to go about fixing it.

    looking forward to hearing from you.

    #119607 Reply

    Mark Wolters
    Keymaster

    Hi Alana,

    the .htaccess 301 redirect is the fastest redirect option, so I’d suggest to enable the option. Make sure you have FTP access to your site before enabling the .htaccess redirect option so you can create a backup of the current .htaccess file first.

    In regards to site speed, check out the following article which details why and how sites can become slower after moving to SSL and what you can do about it: https://really-simple-ssl.com/knowledge-base/really-simple-ssl-make-site-slower/.

    The http:// to https:// redirect isn’t an issue, that’s necessary to take your visitors to the secure site. After a while most traffic will come in on https:// and so the redirect isn’t executed, that’s why site speed without the redirect is the most important.

    Mark

    #119741 Reply

    Alana

    Oh wow! It worked like a charm. My site is so much faster now. Thanks a lot for your help. I really appreciate it.

    #122882 Reply

    devop

    Hello,

    Website becomes slow when I set SSL. Not sure what the reason is. Can you please have a look?

    Thanks,

    #122886 Reply

    devop

    echographie-sans-frontieres.com

    #122913 Reply

    Hi,

    Did you enable the .htaccess redirect? This usually helps in speeding up the redirect. Besides that, you could try if deactivating the mixed content fixer in settings/ssl makes a difference. Caching plugins like wp-rocket or fastest cache can often help when the server responds slowly.

    #146306 Reply

    edd_user_9760292
    Participant

    Hello everyone,

    I have tried to fix my website loading following many suggestions but my website loads slower and now about 13 mins. Could you all help me please? my website is http://www.antisnoringthailand.com

    #146329 Reply

    Mark Wolters
    Keymaster

    Hi,

    your website has a long waiting time before the site starts to load, this usually indicates a slow webserver. What you can try is to disable the ‘Mixed content fixer’ option in the plugin settings to see if that increases the speed. The mixed content fixer is the only thing Really Simple SSL runs on the frontend of your site that might have an impact on the sites speed. See https://tools.pingdom.com/#59cd4efa7ec00000 for more information about your sites loading times and what can be done to improve it.

    Mark

    #151369 Reply

    D Messina

    Same thing happened to me. I purchased the SSL, had an exclamation point next to the URL (the site was currently still fast at this point). I installed the plugin in hopes to resolve the incomplete SSL. Installed the plugin my site came down and I had to delete the plugin manually to get the site back up, this is when I noticed it had suddenly become very slow. Is there somewhere else I should look other than the plugin folder to delete the plugin in its entirety?

    #151371 Reply

    What you are experiencing is not due to Really Simple SSL, as the fact that you already removed the plugin proves. Your site is now on SSL. This will often slow down the site, especially if you are using third party scripts which fail to load over https, or are very slow on https.

    Your site probably had a memory shortage, due to the fact that the plugin will flush the permalinks and caching plugins. As caching plugins and WordPress will then rebuild the cache, this will cause some temporary memory load.

    If you want to have your former speed without any further optimizations, you’ll need to revert to http entirely. You can do this by changing your site_url back to http, or running the deactivation script.
    https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    #151388 Reply

    Just edited a typo: of course I meant “revert to http”, and not “revert to https”, as you were on https on the time of writing.

Viewing 11 posts - 91 through 101 (of 101 total)
Reply To: Website became Really Slow after SSL
Your information: