Website became Really Slow after SSL

Home Forums General issues Website became Really Slow after SSL

This topic contains 97 replies, has 7 voices, and was last updated by  Mark Wolters 2 weeks, 6 days ago.

Viewing 30 posts - 61 through 90 (of 98 total)
  • Author
    Posts
  • #95145 Reply

    Mark Wolters
    Keymaster

    Hi Chris,

    the free version of Really Simple SSL can also add a .htaccess redirect. You can select the .htaccess redirect option in the plugin settings (Settings->SSL->Settings).

    Mark

    #95278 Reply

    Christian Öhrn
    Participant

    Hi again Mark,

    Ok well which setting would that be in the settings tab?
    I think we have most of the enabled, but the troubleshooting feature still says it is not active…

    #95316 Reply

    Mark Wolters
    Keymaster

    It’s the ‘Enable .htaccess redirect’ option, that should add the redirect to the .htaccess file.

    Mark

    #95352 Reply

    Christian Öhrn
    Participant

    Ok thanks!

    but we have this option on and in the troubleshooting section it says: (so i guess it aint right?)

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER:
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #95415 Reply

    You didn’t enable “stop editing the .htaccess file”? Because that will prevent this insertion.

    If the plugin somehow cannot insert the .htaccess redirect, you can also do this manually:
    https://really-simple-ssl.com/knowledge-base/manually-insert-htaccess-redirect-http-to-https/

    #95665 Reply

    Christian Öhrn
    Participant

    Hm not to my knowledge! which option in the settings is this?

    The site we are talking about is wallox.se if you wanna check in pingdom..

    thanks for the link, we will check that

    #95679 Reply

    Mark Wolters
    Keymaster

    The ‘stop editing the .htaccess file’ option.

    Your site seems to be working fine over SSL. It also redirects http:// to https:// so there seems to be a redirect active currently. The .htaccess redirect option is not required, we do recommend to enable it when possible because it’s the fastest redirect.

    Mark

    #96130 Reply

    Christian Öhrn
    Participant

    hmm i we dont have one of those options i think..

    i checked on another site and seems the options in the plugins varies…
    The other site had much more options and as well the .htacess option you mention while the other sites dont!
    Do you know why this is?

    #96134 Reply

    The options are visible depending on your server. Depending on your server (NGINX, apache, litespeed or IIS), if you disabled file writing permissions on the .htacces, if the server generates a loop on the suggested redirect etc, the plugin will show different options.

    In your case I would insert the redirect rules manually.

    #96135 Reply

    Christian Öhrn
    Participant

    Ok great then i know where we should check!

    maybe easiest to just enable the permissions on the server, as we have many sites on it… and to do the htacess edit on all might take time and give a bigger chance of errors! or what you think?

    #96136 Reply

    What type of server are you using? (apache/Nginx/litespeed/IIS)?

    #96137 Reply

    Christian Öhrn
    Participant

    it should be apache as we use cpanel

    #96293 Reply

    Mark Wolters
    Keymaster

    Apache uses an .htaccess file so you should be able to add the redirect rules manually. You can always create a backup of the current .htaccess file so you can quickly restore it if anything goes wrong.

    Mark

    #96307 Reply

    Christian Öhrn
    Participant

    but there must be some form of setting for this so we get the options in the plugin?

    as we have about 20 sites on this server to edit all the htacess will take sometime…

    I really appriciate all the help thanks!

    #96553 Reply

    Apparently your server is not recognised as apache. You could test what it outputs by putting in some logging at the file class-server.php, line 52.
    error_log(print_r($server_raw, true));

    If you add to your wp-config.php (replace the current wp_debug:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_DISPLAY’, false); //prevents from showing errors on the front-end
    define(‘WP_DEBUG_LOG’, true);

    The server output will get written to wp-content/debug.log

    I’m interested what that is. Possibly we can adjust the code somewhat so the plugin recognises your server setup as well.

    #99538 Reply

    Christian Öhrn
    Participant

    Sorry i thought i replied to this!

    We are doing a debug file now, and will send it to you guys, but where do we share the info?

    As for the htaccess file, i see we can edit it in Yoast SEO , but where do we put those lines you guyes mentioned? (first time t edit this so would like to be sure!;) )

    as well we get an red mark on this, which is linked to this:
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    thanks againi !

    #99563 Reply

    Mark Wolters
    Keymaster

    You can send the debug info to support@really-simple-ssl.com or via https://really-simple-ssl.com/support. The .htaccess redirect lines can be added beneath the #END WORDPRESS line. The red cross can be caused by the plugin failing to detect the mixed content fixer. The plugin adds a ‘data-rsssl=1’ marker to the page source. If the plugin can detect this it will show a checkmark that the mixed content fixer is working. Sometimes the plugin fails to detect this. If the site doesn’t have any mixed content this isn’t a problem. If the site does, it’s possible the mixed content fixer is blocked by a security setting or another plugin. The plugin does have an option to ‘switch the mixed content fixer hook’ in the plugin options. You can try to enable this and see if the mixed content fixer is detected then.

    Mark

    #99646 Reply

    Christian Öhrn
    Participant

    Ok, under the #end wordpress we have # begin cpanel , but in between this i assume we can put it?
    And which part of the if you .. statements? or all of them?

    mixed content im not sure what it is even, and i dont think there is on the site..

    thanks again

    #99691 Reply

    Mark Wolters
    Keymaster

    Yes you can put in inbetween the #end wordpress and #begin cpanel. What you can enter depends on your setup, see: https://really-simple-ssl.com/knowledge-base/manually-insert-htaccess-redirect-http-to-https/

    Mark

    #99698 Reply

    Christian Öhrn
    Participant

    Ok great, but we just want the redirect part, which part is that?

    WE read that article, but didn’t make things clear..

    #99730 Reply

    Mark Wolters
    Keymaster

    You can add the following lines to your .htaccess file:


    RewriteEngine on RewriteCond %{ENV:HTTPS} !=on
    RewriteRule (.*) https://%{HTTP_HOST}%/$1 [R=301,L]

    #99733 Reply

    Christian Öhrn
    Participant

    ok , only this? no more lines? or # ?

    #99739 Reply

    Mark Wolters
    Keymaster

    # stands for a comment and thus doesn’t have to be added. I will put the code in the WordPress code tags to make it more clear and included the :

    <IfModule mod_rewrite.c>
    RewriteEngine on   RewriteCond %{ENV:HTTPS} !=on
    RewriteRule (.*) https://%{HTTP_HOST}%/$1 [R=301,L]
    </IfModule>

    That is all that has to be added for the .htaccess redirect to take effect on your site.

    #99742 Reply

    Christian Öhrn
    Participant

    Great thanks , trying it now!

    #99745 Reply

    Christian Öhrn
    Participant

    Ok that didn’t work and site crached, now we can’t enter…

    #99756 Reply

    Mark Wolters
    Keymaster

    Hi Christian,

    you can remove those lines from the .htaccess file and the site should become accesible again.

    #99761 Reply

    Christian Öhrn
    Participant

    yes we did via the http://FTP... scary moment though..

    #100151 Reply

    Christian Öhrn
    Participant

    So we managed to do the Htaccess redirect so it now works, with this code:

    <IfModule mod_rewrite.c>
    # BEGIN Force http to https
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*) https://%{HTTP_HOST}/$1 [R=301,L]
    # END Force http to https
    </IfModule>

    Maybe it helps someone else! 🙂

    #105714 Reply

    George

    Mark,

    thank you for such a wonderful plugin, and second to none support!

    Apart from implementing CDN, is there any other way to speed up SSL sites, to get under 2 seconds, like amazon ? We have a Woo site with over 8,000 products, fast UK server with lots of server resources, but still with all image and content optimizations we cannot get below 3 seconds using tools.pingdom.com for New York City & San Jose location (Melbourne pings at 7 secs !! ah disaster).

    We are based in Canada.

    Thx in advance for any tip or information.

    George,

    https://TopPhoneStuff.com

    #105911 Reply

    Mark Wolters
    Keymaster

    Hi George,

    I don’t see any obvious things that can be done to decrease the load time. Have you enabled the .htaccess redirect option in the plugin settings? If possible, we recommend to enable it since it’s the fastest redirect option.

    The site is already very slim (634kb). The initial request to the site seems to be taking the longest, up to 1.5 seconds. This initial request is processed by the webserver, to speed this up you have to reduce the time the server takes to process this request.

    Mark

Viewing 30 posts - 61 through 90 (of 98 total)
Reply To: Website became Really Slow after SSL
Your information: