Website became Really Slow after SSL

Home Forums General issues Website became Really Slow after SSL

This topic contains 17 replies, has 4 voices, and was last updated by  Rogier Lankhorst 2 weeks, 4 days ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #16281 Reply

    CLEMENT GRANDJEAN
    Participant

    Hello ! I have a big problem with my website : https://entrepreneurz.fr/

    Since I installed the ssl using your plugin, my website became really slow… 30 to 60 sec to load;
    I’m using a plugin to optimise my loading time (picture size Page Caching, Cache Preloading ,Static Files Compression…) so I guess it’s not the point.

    I’m pretty sure it started to get really slow using SSL… but I can’t check because If I desactivate your plugin i have an other problem… the website doesn”t load correctly.. it’s all white with my content mixed… as If it can’t read CSS.

    I just paid for your Premium version to do a scan, but it doesn’t show any problem…

    I’d be really glad if you could help me on this one.

    Regards

    Clément

    #16282 Reply

    CLEMENT GRANDJEAN
    Participant

    Other question… do you know why in my favicon, I have a (i) mark instead of a locker or my normal favicon ?

    #16283 Reply

    The roll back issue could be caused by caching, either in your browser or in your site. Currently it seems still to redirect to https. Did you deactivate using the WordPress dashboard? Because you can’t just remove the plugin folder.

    It’s best to deactivate any caching plugins you might be using, and clear your browser cache after every change.

    Because you now have mixed content, you now have that i mark. It’s a sign of mixed content.

    The slow loading issue possibly is caused by 404 issues on your site caused by the move to SSL.
    For example this image has a 404 error: https://entrepreneurz.fr/wp-content/uploads/2015/10/Popup4.png

    Possible causes for this are:
    – Multilanguage plugins, that are handling redirections -> try to deactivate it to check this.
    – Hot link protection or security settings on your server.
    – Other redirection plugins on your site

    #16314 Reply

    CLEMENT GRANDJEAN
    Participant

    Hi Rogier, thank you very much… I tried to find all the http:// everywhere in my site and put https.

    Now i no more have the (i) and have the lock. Thank you

    The problem of speed is however still not resolved.

    it says :

    The requests for the following URLs don’t fit in a single packet. Reducing the size of these requests could reduce latency.
    data:application/font-woff;base64,d09GRgABAAAAA … K1ghsBBZS7AUUlghsIBZHbAGK1xYWbAUKwAAAAFX9iB7AAA=

    I guess it’s because of a css or a font… witch creates problem. I’ll keep looking;

    thanks a lot

    Clement

    #16315 Reply

    It seems to load pretty well now, but there are still some errors. These errors seem to be coming from a facebook plugin. static.xx.fbcdn.net is a facebook url. See also
    https://tools.pingdom.com/?testurl=https%3A%2F%2Fentrepreneurz.fr%2F#!/dXmTb7/https://entrepreneurz.fr/

    You could try deactivating and reactivating that plugin.

    #17122 Reply

    Paul

    Hi Clement,

    Did you figure this out? I am having the exact same problem with the following error:

    The requests for the following URLs don’t fit in a single packet. Reducing the size of these requests could reduce latency.
    data:application/font-woff;base64,d09GRgABAAAAA … K1ghsBBZS7AUUlghsIBZHbAGK1xYWbAUKwAAAAFX9iB7AAA=

    #17124 Reply

    Hi Paul,

    If you send me your domain, by email, or post it here, I can take a look.

    #19416 Reply

    Manuel

    Hey paul,

    Did you find a solution ?
    I have exactly the same problem:
    data:application/font-woff;base64,d09GRgABAAAAA … K1ghsBBZS7AUUlghsIBZHbAGK1xYWbAUKwAAAAFX9iB7AAA=

    Please post a fix.

    Kind regards

    Manuel

    #26683 Reply

    Satheesh

    I am also facing same problem after installed your plugin. Please help me to resolve this.

    Thanks in advance.

    #26684 Reply

    Satheesh
    #26685 Reply

    I don’t see that error in your console, it seems to look good. Did you try on another browser or system?

    #31528 Reply

    Adam Reece

    Hi there

    I have the same very slow loading after setting up SSL using your plugin. I don’t know where to start to look for the problem. Please can you help me?

    Regards

    Adam

    #31533 Reply

    Mark Wolters
    Keymaster

    Hi Adam,

    SSL is always a bit slower because of the use of encryption. Really Simple SSL is not active on the front-end except the mixed content fixer, you can try disabling this (in settings -> ssl) to see if it makes any difference. You can check your site performance on https://tools.pingdom.com to see why your site is loading slow. This will show you what is causing the page to load slow. You can also try using a caching plugin like WP Rocket to increase the speed of your website.

    Mark

    #31535 Reply

    Adam Reece

    OK thanks Mark, I’ll check that out.

    #32242 Reply

    Mark Deitrickson

    Hello, I was dealing with mixed content after I installed an ssl cert. I installed the ssl cert for the minor seo advantage. I installed your wp plugin and my site slowed down from 2s to 10s load and my seo score went from a “B” to a “C” due to additional redirects. I would love to have full ssl but seo is my main goal. Do you have any suggestions? Thank you. Mark

    #32243 Reply

    Mark Deitrickson

    correction: Hello, I was dealing with mixed content before I installed an ssl cert. I installed the ssl cert for the minor seo advantage. I installed your wp plugin and my site slowed down from 2s to 10s load and my seo score went from a “B” to a “C” due to additional redirects. I would love to have full ssl but seo is my main goal. Do you have any suggestions? Thank you. Mark

    #32259 Reply

    Looking at your increase in loadtime, I think your site might be loading resources from other websites as well, which can increase loadtime dramatically after a move to SSL. If you have for example domain1.com, loading a feed from domain2.com, but domain2.com is very slow on SSL, or does not have SSL at all, this might take ages to load.

    In most cases, when I see such slow loading times, there’s a remote resource that is slowing down the entire site. I would check which remote resources your site is using, and remove them to see how that impacts sitespeed.

    #32331 Reply

    I forgot to add: if you don’t have .htaccess redirect enabled, (settings/ssl) please enable it. That is the fastest redirect.

Viewing 18 posts - 1 through 18 (of 18 total)
Reply To: Website became Really Slow after SSL
Your information: