Too many redirects with Polylang

Home Forums General issues Too many redirects with Polylang

This topic contains 19 replies, has 3 voices, and was last updated by  Rogier Lankhorst 6 days, 22 hours ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #16118 Reply

    Jan Wessels
    Participant

    Hi,

    I have succesfully installed and activated SSL on the site.
    Although there are no issues on the Dutch version but when I switch to other languages (English and German) I get redirection issues.

    So I tried the fix you mentioned to remove the htaccess code from the plugin and put the define( ‘RLRSSSL_DO_NOT_EDIT_HTACCESS’, TRUE); inside the config. All without success.

    Could you check this out why it is not working for the other languages?
    The url is: http://polydioma.nl

    Thanks!
    Jan

    #16120 Reply

    Jan Wessels
    Participant

    Let me know if you need ftp or other access to the site.

    #16121 Reply

    Hi Jan,

    Multilanguage plugins have redirects of their own, which in this case probably causes the loop. If you re-save the settings of the polylang plugin, it should be fixed.

    Removing the .htaccess redirects of Really Simple SSL is not necessary.

    #16122 Reply

    Jan Wessels
    Participant

    Hi Rogier,

    Thank you for responding so swift.
    After re-saving the Polylang settings the issue is resolved

    Very helpful plugin!

    Thanks
    Jan

    #23537 Reply

    Juliana

    Hello! I am having the same issue on the site. As soon as I go to the other language is throwing a redirect loop when I try to visit even its home page.

    Can you please tell me how to re-save the Polylang settings? I don’t want to loose all the translated pages.

    Your help will be very appreciated.

    Thanks!

    Kind regards,

    Juliana

    #23538 Reply

    I think if you go the one or more of the polylang settings pages, and click save, that should do it. Saving settings should not cause any data to be lost. It just re-saves the data, but now with the https url.

    #23541 Reply

    Juliana

    Thanks Rogier. You are a star. it worked perfectly!!

    #23545 Reply

    Thanks 🙂

    #24037 Reply

    rougeot

    I encounter quite the same issue, but I guess I miss one point, since resaving polylang settings is useless.

    My problem is double:
    – my site lemagcinema.com, english version redirects to lemagcinema.fr I don’t understand why
    – if I try to access to an english article, for instance https://lemagcinema.com/divers/meeting-film-casts-at-the-british-film-festival/ I have an infinite loop.

    What should be done for polylang to work again ? (since before moving to https everything was OK)

    Thanks in advance

    #24046 Reply

    Are all redirects gone when PolyLang is deactivated?

    #24057 Reply

    Edit: I meant to say: Are all redirect loops gone when PolyLang is deactivated?

    #33513 Reply

    Moe

    i am having an issue with poly lang after i activated really simple SSL
    the issue is, i can create languages and i can add the languages to posts.
    but when i go to languages, posts show (ZERO) next to each language, that means Zero posts are attached to each language, and that makes the switcher disappear since it considers the website in 1 language because there are no posts attached to languages

    #33557 Reply

    Often you need to re-save the settings in the language plugins so the url is reset.

    Did you also try to re-save the permalinks in settings/permalinks?

    #34097 Reply

    Sunspot

    I’ve spend many hours trying to resolve the problem! Simple reasaving polylang setting resolves the problem!

    #36283 Reply

    Andres Arias

    hello, I installed the plugin Polylang but then after activate it and add few new languages I decided to delete it but now my URL has changed and idk how to change it to where used to be, can you help me please?

    before was

    Home Image Slider

    now it takes me to
    http://andresandvaleriyawedding.com/en/

    #36303 Reply

    Hi,

    For support on deactivating Polylang, I would contact the author of polylang. I can’t really help you with polylang specific issues.

    #43746 Reply

    adrian

    Hello,
    I have a problem with the polylang plugin. When I installed Really simple ssl plugin, it was ok but not the main page for both languages (others are) Really simple ssl plugin wrote me: The mixed content fixer is activated but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. When I deactive the polylang plugin, it was ok. You do not know what to do. The problem is here: https://usklare.cz/en/penzion-harrachov/ thanks for your help!!!!!

    #43747 Reply

    This problem usually resolves when you re-save the polylang settings.

    #51522 Reply

    le guernic johannie et cédric compagnon

    Hello, I have tried this solution too, but save the settings of polylang doesn’t work for me.
    https://compscedric.com/en

    YOu can see it, the english version make a loop

    #51575 Reply

    Hi, I don’t get any redirect loop, it seems to load fine.

Viewing 20 posts - 1 through 20 (of 20 total)
Reply To: Too many redirects with Polylang
Your information: