[Resolved] The mixed content fixer problem

Home Forums Mixed content in my site The mixed content fixer problem

This topic contains 8 replies, has 3 voices, and was last updated by  Rogier Lankhorst 1 week, 2 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #74392 Reply

    Rafal

    Hey,
    I have a problem with ssl on my website. I added ssl using Really Simple SSL and something is wrong with it, despite having I got an information, that everything with adding ssl is allright.
    There is a “The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working.” alert (data-rsssl=1), and I don’t have any ideas how to fix it.

    From ssllabs:
    https://www.ssllabs.com/ssltest/analyze.html?d=yogafor.pl

    From SSL Tests Plugin:
    Your server can detect HTTPS normally. The recommended setting for HTTPS detection is standard WordPress function.

    Your server environment shows this:

    Array
    (
    [LD_PRELOAD] => /usr/local/lib/h88/av.so
    [HTTPS] => on
    [X_SPDY] => HTTP2
    [SSL_PROTOCOL] => TLSv1.2
    [SSL_SESSION_ID] => 6d2bf375c2ab8eeaa8bf0f0da5c6a01575d352eea3349ad46bbbcb591a35b9ee
    [SSL_CIPHER] => ECDHE-RSA-AES128-GCM-SHA256
    [SSL_CIPHER_USEKEYSIZE] => 128
    [SSL_CIPHER_ALGKEYSIZE] => 128
    )

    Log:

    Notice: Constant FORCE_SSL_ADMIN already defined in /home/yogafor/domains/yogafor.pl/public_html/wp-config.php on line 79

    Notice: Use of undefined constant ‘WP_DEBUG_LOG’ – assumed ‘‘WP_DEBUG_LOG’’ in /home/yogafor/domains/yogafor.pl/public_html/wp-config.php on line 81

    Notice: Use of undefined constant ‘WP_DEBUG_DISPLAY’ – assumed ‘‘WP_DEBUG_DISPLAY’’ in /home/yogafor/domains/yogafor.pl/public_html/wp-config.php on line 82

    #74398 Reply

    Rafal

    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: litespeed
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.24
    Already on SSL, start detecting configuration
    ssl type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://yogafor.pl/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: self signed certificate
    checking if .htaccess can or should be edited…
    Edit of .htaccess blocked by setting or define ‘do not edit htaccess’ in really simple ssl.
    converting siteurl and homeurl to https

    #74413 Reply

    The scan from SSL labs shows your certificate is not configured correctly. You have a certificate name mismatch, which means the certificate is not valid for the domain you want to use it for. You can contact your hosting company about the certificate. If you send them the scan link, they should know what to do.

    #121750 Reply

    Joshua Suchet

    Hello,

    I get this message (The mixed content fixer is active, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working).
    I followed the instructions and my mixed content marker data-rsssl is not present.
    How can i fix this?

    Thank you!

    #121884 Reply

    Mark Wolters
    Keymaster

    Hi Joshua,

    could you provide me with your site address? Possibly there’s an issue with your certificate. If the site does have a green lock the warning can be safely ignored.

    Mark

    #126444 Reply

    Gaëlle

    Hi!
    I install a certificate and the plugin Really Simple SSL but I have a problem:

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.0.5
    Already on SSL, start detecting configuration
    Opening testpage to check server configuration: https://beta.macullo.ch/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    test page url, enter in browser to check manually: https://beta.macullo.ch/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    Could not open testpage cURL error 60: SSL certificate problem: self signed certificate
    SSL type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://beta.macullo.ch/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: self signed certificate
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    Could you please help me to solve that problem?

    Thanks a lot!
    Gaelle

    #126730 Reply

    Hi Gaelle, your site does not have a valid SSL certificate. Please check it in https://ssllabs.com/ssltest, you can see if it’s valid or not. Your hosting company can help you to install a valid certificate.

    #128223 Reply

    Sierra Jones

    The green lock briefly appears on my site and then disappears.

    I am trying my best to follow all the steps in your help articles but can’t seem to fix the “The mixed content fixer is activated, but was not detected on the front page. Please follow these steps to check if the mixed content fixer is working” error.

    I ran the test on SSL and got an A.
    Activated the switcher
    Updated all plugins and deactivated.

    Any advice? Thank you in advance!

    #128253 Reply

    If you have the marker “data-rsssl” in the html of your webpage, this means you still have some mixed content. To fix it you can follow these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: The mixed content fixer problem
Your information: