[Resolved] The mixed content fixer is active, but was not detected on the frontpage.

Home Forums Mixed content in my site The mixed content fixer is active, but was not detected on the frontpage.

This topic contains 15 replies, has 5 voices, and was last updated by  Rogier Lankhorst 1 day, 13 hours ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #95652 Reply

    Avantis Haung
    Participant

    Hello

    I was follow the fix step from https://www.really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/
    and I tried Mixed content scan, but it’s can’t found any problem
    my website still get this issue
    Please help me to fix, thanks!!

    This’s my site:
    https://avantis-life.net

    This’s log:

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://avantis-life.net/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 6: Could not resolve host: avantis-life.net; Name or service not known
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #95653 Reply

    Mark Wolters
    Keymaster

    Hi,

    I can see the ‘data-rsssl=1’ marker is active in the page source, this indicates that the mixed content fixer is active. The site doesn’t seem to have any mixed content either. If the site works fine over SSL and doesn’t show a mixed content warning this can safely be ignored.

    Mark

    #111064 Reply

    Fahad Mehar
    Participant

    I Need help here… The mixed content fixer is not ACTIVE rest of the options having Blue TICK but only The mixed content feature is not ACTIVE…. Please HELP !

    #111091 Reply

    Mark Wolters
    Keymaster

    Hi Fahad,

    do you have any mixed content on your website? If not, the warning can be safely ignored. If you do have mixed content on your website, can you try to select the ‘switch mixed content fixer hook’ option? If you keep experiencing issues, can you provide me with your site address?

    Mark

    #111111 Reply

    Fahad Mehar
    Participant

    Hello Mark ! Thanks for reply… The switch mixed content fixer hook” is already Enable i think from settings. my website is http://www.dalnetchatworld.com & http://www.fahad.us I also want to ask that my SSL is self-sign is it fine??? Can you tell me what Is Mixed Content?

    #111128 Reply

    Mark Wolters
    Keymaster

    A self-signed certificate is not enough to secure your website, a certificate has to be issued by a certified certificate authority like Comodo or Let’s Encrypt. Your hosting provider can help you with obtaining and installing a certificate. Your site has the green lock so it does have a valid certificate installed.

    Mixed content happens when an https:// site loads ‘unsafe’ http:// content. This will result in an exclamation mark in the browsers address bar. Since your site has the green lock there is no mixed content and the warning can be safely ignored.

    Mark

    #111174 Reply

    Fahad Mehar
    Participant

    I am using CloudFlare on of my website… If everything is Valid… Then why I am still getting “This site is not secure” Message?

    #111298 Reply

    Carmen

    Hello,

    in the debug plugin tab is displaying this error

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.0.2
    Already on SSL, start detecting configuration
    Opening testpage to check server configuration: https://sempreboaforma.com.br/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    test page url, enter in browser to check manually: https://sempreboaforma.com.br/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    Could not open testpage cURL error 60: Peer certificate cannot be authenticated with known CA certificates
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://sempreboaforma.com.br/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: Peer certificate cannot be authenticated with known CA certificates
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #111375 Reply

    Mark Wolters
    Keymaster

    Hi Fahad,

    the fahad.us domain seems to have a certificate issue now. The site uses a self-signed certificate, this certificate is invalid. This can be fixed by implementing a certificate that is issued by a certified certificate authority.

    Mark

    #111376 Reply

    Mark Wolters
    Keymaster

    Hi Carmen,

    while the debug log shows a warning, your site does have the green lock and seems to load without any issues. If you do experience any issues on your site, can you let me know where exactly? Otherwise this warning can be safely ignored.

    Mark

    #111380 Reply

    Fahad

    Hi Mark… Both of my websites are self-signed certificate this what i was saying yesterday… But now I have CloudFlare active on my sites but still no response and now on site http://www.dalnetchatworld.com
    “Mixed content fixer was successfully detected on the front-end”… But still getting “This site is not secure” I Clear Cache also… THIS SHOULD BE WORKING NOW :s

    #111387 Reply

    Mark Wolters
    Keymaster

    Hi Fahad,

    a self-signed certificate is not a valid certificate, a certificate needs to be issued by a verified certificate provider before it is valid. This is something your hosting provider can help you with, they can install a valid SSL certificate for you. The http://www.dalnetchatworld.com site does have a green lock, so the mixed content fixer warning can be safely ignored. Fahad.us will start working once a valid certificate is installed.

    Mark

    #111445 Reply

    Fahad

    You’re Right Mark! Few movements ago http://www.dalnetchatworld.com was working fine with Green Padlock but after sometime it again giving message unsecured website? While fahad.us is with Green Padlock now…

    #111593 Reply

    Mark Wolters
    Keymaster

    Hi Fahad,

    https://www.dalnetchatworld.com/ still has a green lock when I visit it. The lock doesn’t disappear for me. When does the lock disappear, does it happen when you click something?

    Mark

    #112277 Reply

    Dawn Walker

    I need some assistance. I have the certificate and my site is not secure. It is showing the same issue as this thread. I am not good at taking care of these kinds of things, I just update the site and let it go! LOL!
    SSL is enabled but it is still showing not secure in address bar. this is the mixed content warning: The mixed content fixer is active, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. I have attempted to make the change to the front page, but I don’t really know how to do all this technical stuff…can someone please help? Thanks in advance

    #112301 Reply

    Hi Dawn,

    First, please follow these steps:
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    If the mixed content fixer is active, but you still have mixed content, you can find the mixed content by following these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

Viewing 16 posts - 1 through 16 (of 16 total)
Reply To: The mixed content fixer is active, but was not detected on the frontpage.
Your information: