The mixed content fixer is activated, but was not detected on the frontpage.

Home Forums General issues The mixed content fixer is activated, but was not detected on the frontpage.

This topic contains 109 replies, has 4 voices, and was last updated by  Rogier Lankhorst 2 days, 15 hours ago.

Viewing 30 posts - 61 through 90 (of 110 total)
  • Author
    Posts
  • #80665 Reply

    Leandro Blanco

    Hi, Can you help me fix the error. SSL Certificate Expired
    My site: https://grupocinco.com.br

    #80768 Reply

    Mark Wolters
    Keymaster

    Hi Leandro,

    when the certificate is expired it has to be renewed. Your certificate provider can renew the certificate for you. Really Simple SSL is not a certificate itself and therefore cannot help you renew the certificate. It’s likely your hosting provider can, they will have access to the server and can assist you in renewing the certificate.

    Mark

    #82480 Reply

    Vikas

    Please help us we are also facing same issue “The mixed content fixer is active, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working”

    #82483 Reply

    Mark Wolters
    Keymaster

    Hi Vikas,

    can you give me your site address? Then I can check what the issue might be.

    Mark

    #84778 Reply

    Artur

    I NEED HELP PLEASE.
    don’t know how to fix the issue

    #84782 Reply

    Mark Wolters
    Keymaster

    Hi Artur,

    if you can provide us with your site address we can likely give you more information about the cause of the issue. Have you tried clearing the caches your website uses? See https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    Mark

    #84787 Reply

    Artur

    Hi, Can you help me fix the error.
    https://arturmaiz.com

    #84800 Reply

    Mark Wolters
    Keymaster

    Hi Artur,

    the website is in a redirect loop. A redirect loop is caused when there’s something on your site redirecting back to http:// at the same time when the https:// redirect is active. To check what is causing this, please follow the steps from this article: https://really-simple-ssl.com/knowledge-base/my-website-is-in-a-redirect-loop/

    Mark

    #85577 Reply

    Rayan

    hey
    I got this message when I debugged my site
    PLEASE HELP !!!!

    Options:
    * htaccess redirect
    * WordPress redirect
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://forum.sadakspot.com/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules test failed with error: cURL error 51: SSL: no alternative certificate subject name matches target host name ‘forum.sadakspot.com’
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #85587 Reply

    Mark Wolters
    Keymaster

    Hi Rayan,

    the most common cause of this issue is either an outdated PHP or OpenSSL version. Upgrading those will likely resolve your issue. I’d suggest to contact your hosting provider about this, they will have access to the server and can perform these upgrades for you.

    Mark

    #90012 Reply

    Thomas

    Hi Rogier!

    I have a same “The mixed content fixer is activated, but was not detected on the frontpage.” problem…
    please help!
    Thx T.

    #90019 Reply
    #90970 Reply

    Burnham Arlidge

    Hi Rogier,

    I have just downloaded the plugin and I’m getting this same message?? I tried clearing cache, but that didn’t do anything – I’m also not seeing the padlock image… Any help would be great.

    Thanks,
    Burnham

    #91033 Reply

    Mark Wolters
    Keymaster

    Hi Burnham,

    can you try to select the ‘Switch mixed content fixer hook’ option in the plugin settings? That will fire the mixed content fixer on a different hook. Can you also provide me with your site address so I can have a look where the mixed content is be coming from?

    Mark

    #91070 Reply

    Burnham Arlidge

    Hi Mark,

    I tried the hook but nothing changed. The website is arctic-cruise-guide.com

    Thanks!

    #91155 Reply

    Mark Wolters
    Keymaster

    Hi Burnham,

    there is an issue with the SSL certificate on your site. There seems to be a default certificate installed instead of one specifically for your domain. Before Really Simple SSL can function, a valid certificate has to be installed. A certificate can be obtained at your hosting provider, they will have access to the server and can help you install it. See https://www.ssllabs.com/ssltest/analyze.html?d=www.arctic-cruise-guide.com for more information about the current certificate.

    Mark

    #91159 Reply

    Burnham Arlidge

    Hi Mark,

    Thank you. I just rang my hosting provider and they said the SSL certificate was for arctic-cruise-guide.com, NOT http://www.arctic-cruise-guide.com. I think the ‘www’ is what was causing this? I hope so.

    Cheers,
    Burnham

    #91211 Reply

    As the site is redirecting to www, this is a problem. With SSL it is best practice to have an SSL certificate that is valid for both www and non-www domain. That should solve your issue.

    #91575 Reply

    Tija

    Hello

    I am having this issue too. ‘The mixed content fixer is active, but was not detected on the frontpage.’

    At the moment our site is not live. On the non live homepage there is no green padlock. But when I disable the ‘offline mode’ on the ‘site offline’ plugin the green padlock is on our homepage when it is live & every other page. Whether I am logged into wordpress or not.
    (it also has the green padlock on all these pages when I am logged into wordpress & the site offline mode is enabled, just not when I log out and go on our homepage when the offline mode is enabled)

    However when I disabled the offline mode & go on our sites homepage (which now had a green padlock) this error ‘The mixed content fixer is active, but was not detected on the frontpage’ was still there (I did refresh this page for this too)

    I also cleared our cache plugin ‘wp fastest cache’ . Is there anything else it could be?

    Do you think this issue will be fixed once I remove the ‘Site Offline’ plugin? (won’t be doing this until site is ready to go live though)

    Thank you

    #91585 Reply

    Mark Wolters
    Keymaster

    Hi Tija,

    does the ‘Site offline’ plugin insert a page that says the site is offline? If this plugin generates the page with http:// links it’s possible that disabling the site offline plugin will result in the site having the green padlock. The first step would be to check if your site uses a valid certificate at https://www.ssllabs.com/ssltest/. If the site does have a valid certificate and has a green lock I wouldn’t worry about the warning.

    See https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/ for more information.

    Mark

    #91661 Reply

    Tija

    Hello Mark

    Yes the ‘Site Offline’ plugin inserts a page (I think).
    By the looks of it we our site does have a valid SSL. We do have the green padlock on our homepage (& all other pages) when I am logged in.

    Thank you for your help hopefully it will be okay once we go to delete the ‘site offline’plugin.

    #91911 Reply

    Waseem Alsaeed

    I have problem I got this massage

    The mixed content fixer is active, but was not detected on the frontpage

    my website
    e-skyspace.com

    #91931 Reply

    Hi Waseem, Please check this article, it explains what to do in this case:
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    #91998 Reply

    Peng

    After activating REALLY SIMPLE SSL, I check my page source code and I always find these 2 lines of code that cannot be changed automatically.

    <html class=”” lang=”en-US” prefix=”og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#“>
    document.location = document.URL.replace(/^http:/i, “https:”);

    Do you have any idea where to find the files that contain these codes?

    I am using Cloudflare for my SSL.

    Really appreciate your help.

    #92002 Reply

    The first line has nothing to do with Really Simple SSL. The second line is part of the javascript redirect that is inserted when that setting is enabled. The entire script that is inserted is this:

    <script>
         if (document.location.protocol != "https:") {
            document.location = document.URL.replace(/^http:/i, "https:");
         }
    </script>

    You can disable it in settings/ssl

    #93613 Reply

    Al

    Hello sir,

    Can you please help me out on SSL certificate issue.

    I bought ssl certificate from gadaddy and import in my wordpress site.

    I used the link you provided for ssl test and the result showed me mismatch name on certificate, i checked certificate is with the same name as domain name.

    Can you please helped me out on this.

    Thanks

    #93619 Reply

    Mark Wolters
    Keymaster

    Hi Al,

    when this happens it’s likely that the correct certificate hasn’t been installed correctly yet. Once the right certificate is installed the SSL Labs scan should be able to detect it. It is possible that it takes a while before the certificate is being updated. If you still experience issues I’d suggest to contact GoDaddy about this as they can make changes to the certificate that is used on the server.

    Mark

    #94129 Reply

    Tony

    Hello,

    I got your plugin working on several websites so thanks for that. Could you help with one site Im having problems with?

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://davewillems.nl/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: unable to get local issuer certificate
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    When my client wants to post links to posts and pages on facebook It doesn’t show the image or subject of the post anymore since the SSl certificate and your plugin is installed. Also some people mentioning getting safety warnings when clicking on the facebook links to the website. Im on Mac / safari / iPhone and im not having this problem. Also im getting this error The mixed content fixer is activated, but was not detected on the frontpage.

    Any ideas?

    thanks

    #94230 Reply

    Mark Wolters
    Keymaster

    Hi Tony,

    the mixed content fixer issue seems to be resolved. The site has a green lock and the ‘data-rsssl=1’ marker is present in the page source which indicates that the mixed content fixer is active.

    In regards to a security warning when visiting the website through Facebook, this likely happens because the certificate chain is incomplete. What this means is that the webserver is not hosting all intermediate certificates. This is not an issue is most web browsers because they contain these intermediate certificates. However, Facebook does require the entire certificate chain to be present on the webserver. This can be fixed by requesting this certificate from Comodo and then installing it on the webserver. See https://www.ssllabs.com/ssltest/analyze.html?d=davewillems.nl for which intermediate certificate is missing.

    Mark

    #94231 Reply

    Tony

    Hi Mark

    ok thanks for the quick and professional reply. Very useful advice.
    Still a question, when you say installing it on the webserver is that something I can do myself? And if so do you know of instructions or a tutorial for that? Or must it is something I have to ask my hosting provider to install?

    thx Tony

Viewing 30 posts - 61 through 90 (of 110 total)
Reply To: The mixed content fixer is activated, but was not detected on the frontpage.
Your information: