The mixed content fixer is activated, but was not detected on the frontpage.

Home Forums General issues The mixed content fixer is activated, but was not detected on the frontpage.

This topic contains 59 replies, has 4 voices, and was last updated by  Rogier Lankhorst 4 weeks ago.

Viewing 30 posts - 31 through 60 (of 60 total)
  • Author
    Posts
  • #41200

    Sagu

    Hi,
    Followed the instruction but getting error.
    my website is https://cloudvedas.com/ .
    I see below error on ssl configuration page.
    =======================================================
    success SSL is enabled on your site.
    error The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. Instructions
    success An SSL certificate was detected on your site.
    success 301 redirect to https set: WordPress redirect
    ==========================================

    I followed the instructions and can see the data-rsssl in the front page source.
    Your help will be highly appreciated.

    #41206

    Can you run a test on ssllabs.com/ssltest ? When I open your site, I get an SSL certificate error, so it seems your certificate is not valid.

    #41211

    SAURABH GUPTA

    Thanks for the reply ! On testing i am getting “Certificate name mismatch ”
    Some details of my installation
    I am using bitnami wordpress installation hosted on AWS and domain registered by godaddy.
    I installed the let’s encrypt SSL certificate using WP encrypt plugin.

    #41228

    SAURABH GUPTA

    I finally got it working but without this plugin . The error can be because i was using a customized image of bitnami aws market place. I think i have to write a document for this on my site.
    Thanks that you replied to my query so soon, i was actually not expecting any update as you may already be getting lot of queries.
    Keep up the good work thanks!

    #41247

    Glad to hear you have it working!

    Really Simple SSL will only work when the ssl certificate is valid, so as long as it doesn’t check out on ssllabs.com/ssltest, it won’t work.

    #41808

    Caglar

    My website SSL is not working, can you help me?

    #41832

    Please check your certificate here: ssllabs.com/ssltest. If you have a valid certificate and need premium support, you can submit your support ticket here: https://really-simple-ssl.com/support, and add your license key.

    #45689

    Pedro

    Please help.
    Get following error “The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. Instructions”
    And by reading here I see that i’m not the only one with this problem.

    This site is in a WPMU and all other work perfectley.
    Theme: Divi on all sites, and same plugins as other site
    The plugin is Network activated
    URL: SerraPet.com

    #45691

    Hi,

    Like most other posters here, you do not have a valid SSL certificate, which you can check here: ssllabs.com/ssltest.

    As soon as you have a valid SSL certificate, it will start working.

    #50118

    Chris

    hello guys, Please help with this error. Thanks in advance.
    ” The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. Instructions “

    #50119

    I checked your site, the mixed content fixer is activated, but you have hardcoded http links in css files. You can find the source of the issue by following these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    #50457

    Jens Panduro

    Hi There

    I too get the message: The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. Instructions

    I have run through the steps, tried to see if anything wrong with .httaccess

    But I still can make it work.

    It is only my frontpage that wont show anything else works as do my other sites converted to https.

    Jens

    #50476

    Is the mixed content fixer marker in place? If so, you probably have hardcoded http links in css or js files. You can find these hardcoded http links by following these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    #52813

    Junior Bernard

    Hi there,

    I am having the same issue as most of the other users. My site keeps showing the same following message: The mixed content fixer is activated, but was not detected on the frontpage.

    Would you please help me fix it? I would really appreciate your help. Thank you!

    #52884

    Mark Wolters
    Keymaster

    Hi Junior,

    have you checked if the ‘data-rsssl=1’ marker is present in the page source? Have you tried clearing any caches your website may use? Do you use any security plugins? If you can provide us with your site address and configuration we might be able to provide you with more information. If you do not experience any mixed content on your site I wouldn’t worry about it.

    Mark

    #58407

    Marcin

    Hi,

    could you help me to fix my site, I have the same message as others

    my site:
    taxpr.pl

    debug console:
    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: litespeed
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.22
    Already on SSL, start detecting configuration
    ssl type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: taxpr.pl/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: self signed certificate in certificate chain
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    I would really appreciate your help.

    #58457

    Hi, I’m not entirely clear on what your issue is exactly, and what steps you have taken already to fix it.

    #58459

    Ahmet

    Rogier,l have the same problem with my website technoprogram.com
    deactivating all plugins but the problem continues

    #58470
    #58472

    Ahmet

    yes

    #58477

    And what were your results? Is the mixed content active?

    #58480

    Ahmet

    unfortunately not

    #58498

    I checked your site, you don’t have any mixed content? You have the green lock. What is the problem you are having? Can you please share some more details on what you tried, and what the problem is you are having?

    #60517

    Kongmeo

    the same error my site

    only Not show secure in homepage , but in category and post and product showed secure
    How to fix it
    In plugin show error : The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working.

    #60523

    Mark Wolters
    Keymaster

    Hi,

    your site has mixed content because of these errors:

    Mixed Content: The page at ‘https://hotdeal.la/’ was loaded over HTTPS, but requested an insecure image ‘http://hotdeal.la/wp-content/uploads/2017/04/logo-foody-vietnam@3x.png’. This content should also be served over HTTPS.
    (index):2610 Mixed Content: The page at ‘https://hotdeal.la/’ was loaded over HTTPS, but requested an insecure image ‘http://hotdeal.la/wp-content/uploads/2017/04/logo-ivivu@3x.png’. This content should also be served over HTTPS.
    (index):2688 Mixed Content: The page at ‘https://hotdeal.la/’ was loaded over HTTPS, but requested an insecure image ‘http://hotdeal.la/wp-content/themes/tiki/images/ic-location.svg’. This content should also be served over HTTPS.

    All these items are on the homepage of your website, I’m unable to trace where these items come from. This can be fixed by changing the http:// into https://. Fixing these three items should get you the green lock.

    #61609

    chantal

    Hello,

    I get the error:
    The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working.

    I do see “data-rsssl” in the page source, so I’m unsure if there is a plugin that’s affecting the mixed content filter. Please help.

    ddaisyfit.com

    #61683

    Mark Wolters
    Keymaster

    Hi Chantal,

    do you have the plugin active at all? Normally the plugin should automatically issue a redirect to https:// which isn’t happening on your site. Can you check in the Really Simple SSL options (Settings->SSL) if the mixed content fixer is activated and enable a redirect option? If you still experience issues after that you can try to enable the ‘Switch mixed content fixer hook’ option.

    Mark

    #62243

    Armando Ello
    Participant

    I have a premium version for a single site.

    The Simple SSL does not show any difference wether or not I got a pro version.

    What to do?

    #62245

    Armando Ello
    Participant

    Options:
    * Mixed content fixer
    SERVER: apache
    SSL is not yet enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.23
    Opening testpage to check for ssl: https://indogo.nl/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    test page url, enter in browser to check manually: https://indogo.nl/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    No ssl detected. No certificate, or the testpage is blocked by security settings. The ssl testpage returned the error:

    #62249

    Please post your own topic for each issue. You should install the pro add-on like any other plugin, you can follow these instructions:
    https://really-simple-ssl.com/knowledge-base/install-really-simple-ssl-pro/

Viewing 30 posts - 31 through 60 (of 60 total)

You must be logged in to reply to this topic.