Forum | Really Simple SSL

The mixed content fixer is activated, but was not detected on the frontpage.

Home Forums General issues The mixed content fixer is activated, but was not detected on the frontpage.

  • This topic has 179 replies, 1 voice, and was last updated 3 months ago by .
Viewing 30 posts - 1 through 30 (of 180 total)
  • Author
    Posts
  • #13636
    Anna
    Guest

    I followed all the instructions but no joy. Error message from debug below:

    ** Detecting configuration **
    plugin version: 2.3.9
    Already on SSL, start detecting configuration
    No server variable detected
    ssl type: LOADBALANCER
    — force ssl: FALSE
    Check for Mixed Content detection failed
    ** Configuring SSL **
    testing htaccess rules…
    htaccess rules test failed with error: FORBIDDEN
    wp config jetpack fix already in place
    checking if .htaccess can or should be edited…
    rules already added in .htaccess.
    converting siteurl and homeurl to https

    #13637
    Rogier
    Keymaster

    Could you send me your domain so I can take look?

    Did you try deactivating all plugins?

    #15747
    Tushar
    Guest

    I have the same issue. I dont have the pro version is this available to fix in pro version only?

    #15811
    Rogier
    Keymaster
    #16563
    Perfumeaz.com
    Guest

    Hi, Can you help me fix the error “The mixed content fixer is activated, but was not detected on the frontpage“. My site: https://www.perfumeaz.com

    #16564
    Rogier
    Keymaster

    Your site has the green lock, meaning you have no mixed content. Possibly you are using a caching plugin that uses minification that removes the marker Really Simple SSL uses to detect if it is active. So the mixed content fixer is active, the plugin only cannot verify that, because of the minification. See also https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/ for more details.

    #28179
    Patricio
    Guest

    mixed content fixer is activated, but was not detected on the frontpage

    getting same thing..please help!

    #28180
    Rogier
    Keymaster

    Hi Patricio,

    A quick look at your website reveals that the mixed content marker data-rsssl is not present. This is usually caused by a caching plugin. I see you are using W3TC. This plugin can sometimes be a bit hard to clear, so I would advise you to start with clearing and disabling W3TC.

    Please let me know if there is anything else I can assist you with!

    Rogier

    #29127
    Michael Huang
    Guest

    Dear Rogier,

    l have the same problem with my website https://www.lgpgasket.com

    http://prnt.sc/eikt7b

    Best Regards

    Michael

    #29209
    Rogier
    Keymaster

    Hi Michael,

    In your case the data-rsssl marker is in place in the websource, so even though the plugin does not see it, the mixed content fixer is active.

    #29245
    Michael Huang
    Guest

    Dear Rogier,

    thank you for your replied.

    could you tell me what is the real problem for my website ?

    the homepage can’t open.

    Best Regards

    Michael

    #29259
    Rogier
    Keymaster

    In the html of your theme I see the following message:

    This points to a html issue with your theme. I would try if it helps when you deactivate autoptimize.

    #29344
    Michael Huang
    Guest

    Dear Rorier,

    l have deleted autoptimize plugin,could you tell me what l should do next ?

    Best Regards

    Michael

    #29356
    Rogier
    Keymaster

    In the console, there is an error that you have an internal server error (500). This points to a PHP error in your code.

    What happens if you switch the theme to a default WordPress theme?

    #35952
    seth
    Guest

    hi kindly check my website though the website shows a padlock secure and i think functioning well but the sign on the setting of really simple ssl plugin has an X mark on the The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working.

    does it conflict with the jetpack since i cannot connect into jetpack plugin thanks.

    #35965
    Rogier
    Keymaster

    I use JetPack myself without any issues. Click “view source” on your website, then do a search on “data-rsssl”. If you find it, the mixed content fixer is active. If you have the green lock, this is probably the case.

    #36066
    Karine
    Guest

    Hi,
    All the FB likes seem to have transferred so am really please with as moving from http to https lead to losing them.
    However, since installing Really Simple SSL, I have then published a new post and on the homepage of my website (featuring in the slide on first position), it won’t show the number of likes. However, if I click on it to read more, the post opens and at the bottom I can see the number of likes.
    Could you help me show the likes also on the homepage please?
    Many thanks,
    Karine.

    #36083
    Mark
    Keymaster

    Hi Karine,

    have you set the date when your site went https:// in the settings of Really Simple SSL? The plugin needs this to assign new likes to new https:// posts. Did you also enable the replace og:url option?

    If so and the likes are still not showing on your homepage, could you send a support request via https://really-simple-ssl.com/support with a link to your site? Then we will have a look!

    Mark

    #37434
    Mariana Rosa SIlva-Buck
    Guest

    HELP

    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.16
    Already on SSL, start detecting configuration
    ssl type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://www.voguemycloset.com/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules test failed with error: cURL error 51: SSL: no alternative certificate subject name matches target host name ‘www.voguemycloset.com’
    wp config jetpack fix already in place
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #37445
    Rogier
    Keymaster

    Hi Mariana,

    The problem here is that you do not have a valid SSL certificate. See also this scan:
    https://www.ssllabs.com/ssltest/analyze.html?d=www.voguemycloset.com

    I would contact your hosting company and ask them to fix the certificate. In the meantime, you can regain access by following these instructions:
    https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    #39382
    Farhan
    Guest

    Chain issues Incomplete

    showing This server’s certificate chain is incomplete. Grade capped to B.Please help cannot open the site any link in shared post

    #39396
    Mark
    Keymaster

    Hi Farhan,

    there seems to be an issue with your SSL certificate. In these cases, it is best to contact the company which installed your certificate to see if they can help you fix it.

    Mark

    #39941
    shanice
    Guest

    Hello im having the same problem with my SSL.

    The following error keeps occurring and i cant sort it.
    The mixed content fixer is activated, but was not detected on the frontpage
    could you help me please.

    thanks shanice

    #39969
    Rogier
    Keymaster

    Please check this article for instructions how to deal with this:
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    #40144
    shanice
    Guest

    Hello ive tried this and im still having no joy. This is the error message thats still coming up with a x in my ssl plugin. Ive been onto the page and followed instructions but still cant figure out.
    error The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working.

    Many Thanks

    #40155
    Rogier
    Keymaster

    If you post your domain, or submit a support request, I’ll take a look.

    #40156
    shanice
    Guest

    http://www.juicejunkies.co.uk

    thank you so much

    #40158
    Rogier
    Keymaster

    Hi Shanice,

    Your SSL certificate is not valid. Please check this scan:
    https://www.ssllabs.com/ssltest/analyze.html?d=www.juicejunkies.co.uk&latest

    If you purchased your certificate at your hosting company, you should contact them to install a valid certificate.

    #40166
    shanice
    Guest

    Hi Rogier,

    Thank you for taking the time to help me, so if i contact go daddy they should instate the certificate and it should all work automatically?

    thanks again
    shanice

    #40168
    Rogier
    Keymaster

    If the certificate is installed, Really Simple SSL can do its work. If you want to be sure there are no hardcoded mixed content issues or hot linked images and such, you can do a scan with the pro plugin.

Viewing 30 posts - 1 through 30 (of 180 total)
  • The topic ‘The mixed content fixer is activated, but was not detected on the frontpage.’ is closed to new replies.

Subscribe