[Support request] SSL conversion worked, but "Almost Ready to Migrate" banner persists

Home Forums General issues SSL conversion worked, but "Almost Ready to Migrate" banner persists

This topic contains 1 reply, has 2 voices, and was last updated by  Rogier Lankhorst 2 weeks, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #141302 Reply

    Forrest Whitesides

    As the title says, I have activated SSL via the plugin, and the site works great and is fully https. But I still get the “Almost ready to migrate to SSL” massive banner on every admin backend page. I think the problem is that my admin area is not in the default folder (for security reasons), and the plugin appears to be hard-coded to assume the relative path is the default of “/wp-admin/”. So when I click “Go ahead, activate SSL”, it forwards me back to URL/wp-admin/ and I get a 404.

    Is there an easy way to resolve this? I’m comfortable making minor code edits. I already looked through the plugin code, but couldn’t find where the plugin defines where the look for the admin folder.

    #141325 Reply

    The form which posts back the submit actually posts to action=””, so should always post to the current page. To find out what the issue is, I’d have to debug the live site, or a copy of it.

    As a quick fix, you can force enable the plugin by adding
    define(“RSSSL_FORCE_ACTIVATE”, true);

    to your wp-config.php.

    You can remove it afterwards, as this will run the activation.

    Let me know if this helps!

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: SSL conversion worked, but "Almost Ready to Migrate" banner persists
Your information: