Home Forums General issues Site is now Not Secure

  • This topic has 30 replies, 3 voices, and was last updated 3 weeks, 3 days ago by Guilherme Carrapito.
Viewing 30 posts - 1 through 30 (of 31 total)
  • Author
    Posts
  • #42554 Reply
    Nicole M Carriere
    Guest

    I loaded the this plugin to help with site security. I had a user say that when she was creating an account in my woocommerce checkout that it said it was unsecure when putting in a user name and password. I downloaded this to help secure the site and now even when I load my wp admin page it says unsecure, I can’t access the site via mobile because I get warnings. Please help!

    #42558 Reply
    Rogier
    Keymaster

    Please note that this plugin is not an SSL certificate.

    If you post a domain name I can check. Your description sounds like you don’t have a valid SSL certificate. You can check this on ssllabs.com/ssltest.

    If you get errors on that scan, you should contact your hosting company and ask them to correct the issues with the certificate, or install it if that hasn’t been done yet.

    #98512 Reply
    Arpad Csipai
    Guest

    My page is not secure after installed your plugin:

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://tapolcaszallas.hu/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: self signed certificate
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #98582 Reply
    Rogier
    Keymaster

    Like the previous poster, your site does not have a valid SSL certificate. You can contact your hosting company to acquire a valid SSL certificate.

    #134659 Reply
    Rob Colfer
    Guest

    I installed the plugin, went to settings and hit force ssl, and still have a problem on a couple of pages, Any suggestions

    #134705 Reply
    Rogier
    Keymaster

    Hi Rob, Did you follow these instructions?
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    If you post your domain we can take a look.

    #152824 Reply
    Ralph
    Guest

    Hi, I seem to have run into an issue and I cannot fix it for the life of me. I have installed Really easy SSL, but it seems when I go to my site I get a message “Connection not secure” followed with “Parts of this page are not secure (such as Images). I have checked over and over and still cannot get it to show secured with the green padlock. Can anyone please assist me.

    #152887 Reply
    Mark
    Keymaster

    Hi Ralph,

    possibly your certificate isn’t valid. Can you run a test over at https://ssllabs.com/ssltest to check if your site uses a valid certificate?

    Mark

    #160090 Reply
    Thomas
    Guest

    Ive got an odd one – when im in the wordpress console I notice I have the secure lock icon, but when i’m in the front end of this site it still comes up with the i circle icon.

    What could be the problem?

    #160171 Reply
    Mark
    Keymaster

    Hi Thomas,

    likely there is still some mixed content on the front-end. An easy solution is often to clear all caches the website uses. If that doesn’t work, you can track down what’s causing the mixed content by following this guide: https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    #351682 Reply
    Yussuf Rahman
    Guest

    What is actually your plugin do of u cant provide ssl?

    #351773 Reply
    Rogier
    Keymaster

    Hi Yussuf,

    I take you’re referring to the pro plugin?

    Really Simple SSL is a plugin to optimize your site for SSL. Some of the features:
    – Extensive scan which enables you to detect the source of mixed content that couldn’t be fixed automatically.
    – Secure cookies
    – HTTP Strict Transport Security for your site
    – Easy implementable security headers: X-Content-Type-Options, X-XSS-Protection, X-Frame-Options, Expect-CT, Certificate – Transparency, No Referrer When Downgrade header, Content Security Policy, Upgrade Insecure requests.

    You can find the full details here: https://really-simple-ssl.com/premium/

    Let me know if you have any questions about this.

    #355036 Reply
    Femke
    Guest

    Hi!

    I just installed Really Simple SSL on the website I am working on, and despite having done this successfully many times on other websites, I cannot get it working now.

    The website has a valid SSL document (I double checked via your documents, grade A), the configuration settings all give green check marks (including the mixed content), but the website remains “not secure”. What am I doing wrong?

    #355180 Reply
    Mark
    Keymaster

    Hi Femke,

    it’s possible that your site uses caching, could you try to clear all caches your site uses? Can you also provide us with your site address so we can have a look?

    Mark

    #355951 Reply
    Femke
    Guest

    I already tried to empty all caches several times. Not sure if I am doing this the correct way?
    The domain: https://theatergroephardt.nl/

    Thank you in advance!

    #356678 Reply
    Aurel Smith
    Guest

    how do I get the site secure?

    #356872 Reply
    Mark
    Keymaster

    Hi Femke,

    the search icon added by your theme is what’s causing the mixed content. The URL is http://api.ning.com/files/dr2jDpSXWFhyuoGJ4YR5Fu-PwuqLz70YxRaUcpdKNxf2HI5ECzddyx3NHuPz-MB4ujGS4rEtdtS-aQoFlQrtv*XwVOu*AvC8/searchearchicon.png and the link is coming from your theme’s stylesheet: https://theatergroephardt.nl/wp-content/themes/genex-primal/css/violet.css?ver=1.0.0. To fix this, the http:// for the link has to be replaced to https://.

    Mark

    #356873 Reply
    Mark
    Keymaster

    Hi Aurel,

    to make your site secure you have to install an SSL certificate first, the SSL certificate can be added by your hosting provider. Once the SSL certificate is installed, you can install Really Simple SSL and your site should be secure.

    Mark

    #356964 Reply
    An Mustapha
    Guest

    i installed the really simple ssl plugin and then got this error – Your connection is not private

    pls help

    #356983 Reply
    Mark
    Keymaster

    Hi,

    Really Simple SSL requires a valid SSL certificate before it can work correctly. If you use cPanel hosting, you can use get a free SSL certificate as described here: https://really-simple-ssl.com/knowledge-base/how-to-install-a-free-ssl-certificate-on-your-wordpress-cpanel-hosting/. Otherwise your hosting provider can install a valid SSL certificate for you.

    Mark

    #370815 Reply
    Femke van Hilten
    Participant

    Hi Mark,

    I tried to replace the http to https like you recommended on April 2nd. However, this didn’t fix the issue. Do you have other options I could try?

    Never mind, it seems secure after I emptied my cache again! Thanks!

    #371617 Reply
    Christophe Richa
    Guest

    Hello

    only wp-admin page works for me and for other WP pages, I have a 404 HTTP.

    DEBUG info :

    General
    Plugin version: 3.3.1
    SSL certificate is valid
    SSL is enabled

    Options
    * Mixed content fixer
    * WordPress redirect
    * htaccess redirect
    * Use alternative method to fix mixed content

    Server information
    Server: apache
    SSL Type: SERVER-HTTPS-ON

    Detecting configuration

    SSL Configuration
    testing htaccess rules…
    test page url, enter in browser to check manually: https://testshop.restaurantfarid.com/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    converting siteurl and homeurl to https
    Could not connect to webpage to detect mixed content fixer

    Constants
    No constants defined

    #371851 Reply
    Mark
    Keymaster

    Hi Christophe,

    404 errors on pages are often caused by an issue with the permalinks. Could you try to re-save the Permalinks in the WordPress -> Permalinks menu twice? That can resolve the issue. Also see https://really-simple-ssl.com/knowledge-base/404-pages-wordpress-site-migrating-ssl/

    Mark

    #373165 Reply
    Guilherme
    Guest

    Hi, Mark!

    I’ve done all the steps mentioned above – I have a valid SSL certificate; done all the Really Simple SSL steps; searched for any http:// content on the website but there are none. Can you give me some help to find out what to do? My website is rio40aus.com.br (still under construction…). Thanks in advance!

    #373168 Reply
    Guilherme
    Guest

    Sorry, I forgot to mention that the problem is I still get the message that the website is “not secure”. Can you please help me? Thanks again!

    #373331 Reply
    Rogier
    Keymaster

    Hi Guilherme,

    Can you share your domain so we can take a look?

    Rogier

    #373338 Reply
    Guilherme
    Guest

    Sure, Rogier!

    My domain is https://rio40aus.com.br/

    #373390 Reply
    Rogier
    Keymaster

    As you are using Elementor, please follow the instructions in this article to remove the remaining mixed content:
    https://really-simple-ssl.com/knowledge-base/how-to-fix-mixed-content-in-elementor-after-moving-to-ssl/

    #373393 Reply
    Guilherme
    Guest

    Thanks for the response! Unfortunately, I’ve already followed those steps but had no success on changing the “not secure” status. Do you have any other suggestions of how to solve it? Thanks!

    #373943 Reply
    Rogier
    Keymaster

    Alternatively you can do it manually: Fore example, on the homepage, you have this image: Frida-35-scaled.jpg. If you look it up in your Elementor editor, then change it to https, it will be resolved as well.

    You can find for each page which image is causing the issue, then change it to https, using these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

Viewing 30 posts - 1 through 30 (of 31 total)
Reply To: Site is now Not Secure
Your information: