[Resolved] Secure cookie settings not enabled.

Home Forums Really Simple SSL pro Secure cookie settings not enabled.

This topic contains 10 replies, has 4 voices, and was last updated by  Rogier Lankhorst 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #65654 Reply

    Martyn Davies
    Participant

    I have not yet enabled SSL as I the configuration panel shows two warnings and an error. I’ve found the answer to the error elsewhere on this forum and the first warning is about HSTS, which I understand I should not turn on until the site has been running smootjly for a week.

    The one I can’t find an answer to is: Secure cookie settings not enabled.

    How do I enable them?

    #65656 Reply

    Hi Martyn,

    These will be activated automatically when you enable SSL.

    I will update the explanations on this. Thanks for the feedback.

    #65657 Reply

    Martyn Davies
    Participant

    Wow, quick response! Thank you very much 🙂

    #76167 Reply

    LAURA

    Hello,

    I have this error message as well “Secure cookie settings not enabled” but the difference is that my SSL is enebaled. I don’t understand what is the problem.

    #76389 Reply

    There is no problem. Secure cookies are an extra security feature, but your site will run on SSL without this setting as well.

    #85283 Reply

    Raman

    Does this plugin have any influence on affiliate links? I mean: My website is a money site, which has some affiliate links inside the pages. When the user is at this page and click in one of these affiliate links, will Really Simple SSL allow my affiliate cookie to be saved in the user’s browser?
    Thanks

    #85367 Reply

    Mark Wolters
    Keymaster

    Hi Raman,

    the plugin will leave external links untouched. The affiliate links won’t be altered and the cookies will still be set.

    Mark

    #128649 Reply

    JUDY

    Site shows green lock then disappears. I have an error message “Secure cookie settings not enabled’ Is this the cause?

    #129213 Reply

    Mark Wolters
    Keymaster

    Hi Judy,

    it’s not likely that the secure cookie settings are causing your site to be insecure, most likely this is happening due to mixed content on the site. Often clearing all caches the website uses will fix mix content issues, if you can provide me with your site address I will have a look to see what the issue might be.

    Mark

    #129412 Reply

    Jason

    Hello Mark,

    I appear to be having the same issue as Judy. I installed the plug in and cleared my cache from the WP Super Cache plug in, but I sill do not have any padlock.

    #129417 Reply

    Hi Jason,

    To track down mixed content, please follow these steps:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: Secure cookie settings not enabled.
Your information: