Redirect htaccess and Loadbalancer

Home Forums Really Simple SSL pro Redirect htaccess and Loadbalancer

This topic contains 1 reply, has 2 voices, and was last updated by  Rogier Lankhorst 4 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #37255 Reply

    Patric

    Hello,
    I’m using the redirect code below in htaccess:

    # HTTPS
    RewriteEngine On
    RewriteCond %{HTTP:HTTPS} !on
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
    # If using www
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteCond %{HTTP:HTTPS} !on
    RewriteRule .* https://xn--tryckbcker-jcb.se%{REQUEST_URI} [R,L]

    Everything is working but at Detected setup it states “Enable a .htaccess redirect or WordPress redirect in the settings to create a 301 redirect”.
    At Debug it states “htaccess rules test failed with error: Too many redirects”.

    Loadbalancer page gives too many redirects – https://xn--tryckbcker-jcb.se/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html

    In wp-config.php I have added this code:

    //Begin Really Simple SSL Load balancing fix
    if (isset($_SERVER["HTTP_X_FORWARDED_PROTO"] ) && "https" == $_SERVER["HTTP_X_FORWARDED_PROTO"] ) {
    $_SERVER["HTTPS"] = "on";
    }
    //END Really Simple SSL

    Thanks,
    Patric

    #37275 Reply

    As your .htaccess redirect is different from the default one in Really Simple SSL, it does not detect it.

    If you insert this in your .htaccess:
    # BEGIN rlrssslReallySimpleSSL rsssl_version

    It will stop showing the notice.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Redirect htaccess and Loadbalancer
Your information: