[Support request] Recover Facebook shares after switch to SSL

Home Forums General issues Recover Facebook shares after switch to SSL

This topic contains 8 replies, has 2 voices, and was last updated by  Cristina Biasini 2 weeks, 1 day ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #64721

    Cristina Biasini
    Participant

    Hi.
    I have switched to SSL at the start of September (my site “unacosaallavolta.it” is hosted at Siteground) using the Siteground plugin “SG optimizer” which has a “HTTPS config” option.

    Everything was apparently working fine, until I realized to my big surprise that I had “lost” the count of FB shares (shown by JetPack sharing buttons) on the “pre-SSL” part.
    I guess you know all too well what I’m talking about.

    After googling around, I switched off the “SG optimizer” plugin and installed your free “Really Simple SSL” plugin. A couple of days ago I finally bought and activated your “Really Simple SSL social” plugin, but I still can’t see the old http shares.
    I’m quite sure there’s some hopefully easy config error somewhere, but since I’m rather new to all this, I can’t find it myself and really need to be guided.

    For example, the SSL test page is empty, apart from the text:
    This page is for testing ssl functionality. #SSL TEST PAGE#

    Here’s the debug content from the plugin settings:

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.23
    Already on SSL, start detecting configuration
    ssl type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules...
    test page url, enter in browser to check manually: https://unacosaallavolta.it/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited...
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    Really looking forward hearing from you.
    Cristina.

    #64740

    Hi Cristina,

    If the shares are retrieved with anything like the default Facebook button the shares will usually recover, unless Facebook decides not to play along anymore. You can test this by with this simple script:
    https://really-simple-ssl.com/test-shares.php. You should enter the http url.

    You will see a Facebook button and an API frame. The button should return the same results as the Facebook API. If not, Facebook has started to return the https count even for a http request. In that case you can use the built in share buttons, which retrieve the shares directly trough the API, and are therefore more reliable.

    In your case, the share tester seems to return the correct number. I also checked your websource of your site: the social recovery is active and you have enabled the og:url setting. Nonetheless your shares are not recovering.

    As you mention JetPack, I’ve re-checked the code, and made some changes to the JetPack filters that might help in your case. Can you contact me directly so I can send you a beta release of this version?

    As alternative you can use the built in sharing buttons in Really Simple Social, and customize the look and feel of the buttons to suit your needs.

    #64751

    Cristina Biasini
    Participant

    I’d like to contact you directly but I can’t find a Personal Messaging system here…
    Don’t you already have my email?

    #64760

    I’ll send you an email.

    #64764

    Cristina Biasini
    Participant

    Rogier, thanks a lot for your prompt reply and for your customization to the plugin filters!
    I’ll keep my fingers crossed while waiting for it 😉

    What worries me a bit is that I checked the “notify me of follow-up replies via email” from the start, but I didn’t get any…

    #64774

    I sent you an email, but it returned as undeliverable. Apparently your email is not working at the moment. You can also send me an email directly: rogier (at) really-simple-ssl.com

    #64790

    Cristina Biasini
    Participant

    Done from my personal gmail account.

    #64810

    Cristina Biasini
    Participant

    Ok, I’ve just checked and it was my fault: I made a typo while registering my account, there was an extra “a” in the mail address.
    You can try again.

    Sorry for not double checking this before.
    Cristina.

    #64977

    Cristina Biasini
    Participant

    Hi Rogier.
    You have a new mail!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.