Problem with subfolders

Home Forums Multisite Problem with subfolders

This topic contains 12 replies, has 4 voices, and was last updated by  Mark Wolters 5 months, 4 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #23675 Reply

    Omid

    Hi, I have subfolder multisite and I added SSL cert along with really simple ssl plugin, everything works well for my main site, but wp-admin for all sufolders are not accessible and also the pages on subfolders not displaying properly, on google chrome inspect section I am seeing too many below errors:
    Failed to load resource
    server responded with a status of 404 ()

    #23679 Reply

    Hi,

    Re-saving the permalinks often resolves the issue. You can check some possible solutions here:
    https://really-simple-ssl.com/knowledge-base/404-pages-wordpress-site-migrating-ssl/

    Let me know if this helps!

    #23698 Reply

    Omid

    Thanks for reply, every subfolders work perfectly but /fa , I did the following:
    1-deleted /fa site,
    made a new site /fa , activated my theme (newspaper) —> same problem
    2-deleted /fa site
    made a new site /test , activate my theme —> works fine
    my conclusion: there should be something wrong with /fa

    =====================================Debug info
    ** Really Simple SSL debug mode **
    building domain list for multisite…
    adding: https://www.
    adding: https://www./fa
    adding: https://www./ru
    adding: https://www./ge
    ** Detecting configuration **
    plugin version: 2.4.3
    Already on SSL, start detecting configuration
    No server variable detected
    ssl type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    .htaccess contains redirect
    settings page, per site activation or hsts option change, updating htaccess…
    retrieving redirect rules
    single site or networkwide activation
    converting siteurl and homeurl to https
    .htaccess contains redirect

    ===================== .htaccess my file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.4.3]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL

    #23702 Reply

    Omid

    I have checked Stop “editing the .htaccess file” settings for all the subfolders (/ /fa /ge /ru) and reverted back the .htaccess to default(multisite), and observed all of subfolders are working fine with SSL and even /fa is looking nicer, but still some imagaes are not there and the structure is not acceptable

    #23706 Reply

    It sounds as if you have mixed content on that site. Check this article how to track down these issues:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    Can’t say why /fa does not work with the generic redirect, and all others do. Maybe you have a page or category that is also called fa, that conflicts with the /fa ?

    #31485 Reply

    Arturo Lores
    Participant

    Hi!
    All my images and CSS’s are not showing when using https. Is there any way you can help solve this issue?
    I have run a scan with Pro version but no error is found.
    Thanks

    #31513 Reply

    Mark Wolters
    Keymaster

    Hi Arturo,

    if you could open a support ticket at https://really-simple-ssl.com/support/ and include the url of your website I’ll be happy to help you.

    Mark

    #31516 Reply

    Arturo Lores
    Participant

    Images and CSS are not showing when using https://
    See https://malecon.no
    Can you please help me fix this issue?
    Thanks;

    #31525 Reply

    Hi Arturo,

    Your images do not load because of 403 forbidden errors. This is probably due to hot link protection on your server, see also this article:
    https://really-simple-ssl.com/knowledge-base/403-errors-images-ssl-activated/

    #31562 Reply

    Arturo Lores
    Participant

    I have installed the pro version but keep on getting error message:
    You haven’t activated your Really Simple SSL pro license yet. To get all future updates, enter your license on the settings page. Go to the settings page or purchase a license

    #31569 Reply

    In settings/ssl/license you can save the license, then click “activate”. Then the message should go away.

    #92874 Reply

    Josh Deshazer

    Hi I purchased the pro version of really simple ssl and everything is working over ssl on my site except when I try to browse to my sub folder to get a pdf document. For example https://www.americo.com/SiteCollectionDocuments/BenChangeIndividuallyOwnedorMultiplePersonsOwnedPolicies.pdf

    this worked when it was just http but now my links are broken. Any help with this? I did alter the wp settings to make my site ssl and put in a rule in my web.config to make all http traffic go to https all that is working great just need help with my sub folders

    #92895 Reply

    Mark Wolters
    Keymaster

    Hi Josh,

    the PDF link seems to be working fine now. Do you still experience issues?

    Mark

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: Problem with subfolders
Your information: