[Support request] Page isn't redirecting properly – I've edited .htaccess to remove redirects but

Home Forums Redirect loops Page isn't redirecting properly – I've edited .htaccess to remove redirects but

This topic contains 3 replies, has 3 voices, and was last updated by  Julieanne 2 weeks, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #134013 Reply

    Julieanne van Zyl
    Participant

    Hi, hoping you can assist me please.

    After activating the plugin, the website can’t load.

    The SSL test page works as shown here:
    https://rollingstonesexperience.com/wp-content/plugins/really-simple-ssl/ssl-test-page.php

    HTACCESS file
    After trying some other suggestions recommended here, which didn’t work, I removed all the code for the Really_Simple_SSL so it looks like this now:

    # BEGIN Really_Simple_SSL_UPGRADE_INSECURE_REQUESTS
    # END Really_Simple_SSL_UPGRADE_INSECURE_REQUESTS
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have the iThemes Security plugin installed, which has put a lot of code into the .htaccess file. It’s mostly code to deny different ISPs though.

    Thanks in advance for any assistance you can give!!

    #134019 Reply

    Julieanne van Zyl
    Participant

    PS. I deactivated the plugin for now, so the website can be accessed via http

    #134080 Reply

    You have a redirect to http in your site. When you activate Really Simple SSL, this redirect to http wil conflict with the redirect to https, causing a redirect loop.

    To resolve the issue, you should remove the redirect to http.

    If you have any SSL options in iThemes settings enabled, please deactivate them. Especially the per page options in iThemes may conflict with a generic redirect to https.

    #134176 Reply

    Julieanne

    Thanks so much Rogier. Now it’s working perfectly after deleting the other redirct.

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Page isn't redirecting properly – I've edited .htaccess to remove redirects but
Your information: