[Support request] One active, Really Simple SSL blocks my WP eMember Content

Home Forums Mixed content in my site One active, Really Simple SSL blocks my WP eMember Content

This topic contains 1 reply, has 2 voices, and was last updated by  Mark Wolters 3 months, 4 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #217349 Reply

    Henk-Jan

    Hi,
    On verkoopsucces.nl/iknmv I have setup a membership site using the WP eMember plugin.
    All works fine in a http setting. The moment I activate Really Simple SSL, member can log in, but all pages show the “you are not allowed to view this content, please log in” message.
    The moment I de-activate Really Simple SSL, all works fine.
    Any suggestions?

    Here is my debug content: (removed the testpage-info)
    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.1.5
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…

    [info in this line deleted]

    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #217360 Reply

    Mark Wolters
    Keymaster

    Hi Henk-Jan,

    usually this happens because the log in cookies are set for the http:// domain. Because https:// is seen as a different domain your users might have to log in after activating Really Simple SSL. Do the users stay logged in after logging in again after the message?

    Mark

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: One active, Really Simple SSL blocks my WP eMember Content
Your information: