[Resolved] no green padlock?

Home Forums General issues no green padlock?

This topic contains 49 replies, has 6 voices, and was last updated by  Melissa Haymes 5 days, 1 hour ago.

Viewing 30 posts - 1 through 30 (of 50 total)
  • Author
    Posts
  • #104742 Reply

    Jason

    Hi, i’m using really simple SSL plugin with the following site https://flamingocontracting.co.uk/
    when i’m logged into the dashboard i get the green SECURE confirmation from my Chrome browser, but when viewing the site itself, it’s not there, is this because of mixed content? and is this something your pro version will fix automatically (or will it just tell me the problem items for me to change myself)
    thanks
    J

    #104751 Reply

    Mark
    Keymaster

    Hi Jason,

    the site seems to be using Divi theme. Divi is know for having a very persistent cache mechanism. Usually clearing the Divi cache and disabling/enabling the minification options resolves the issue. The Divi cache is located under Builder -> Cache.

    Let me know if this resolved your issue.

    Mark

    #104867 Reply

    Ceonn Bobst

    Either way Jason, you can expect a wonderful customer experience from both Rogier and Mark. They are really cool dudes!

    Best regards,
    Ceonn Bobst

    #126484 Reply

    Ricky Knight

    Hi,

    I am having a similar issue to the above on belleacademy.co.uk

    Not showing a secure icon when I load the homepage however it shows as secure when we load the wp dashboard?

    Any ideas on how to solve this…

    Thanks.

    #126731 Reply

    Rogier
    Keymaster

    There’s this image in your site about copy protection:
    banners.copyscape.com/images/cs-wh-3d-234×16.gif

    The img src is in caps, so the mixed content fixer won’t pick it up. If you change the url to https you should be fine.

    #131362 Reply

    Ann Smith
    Participant

    Hello – I’ve just installed the Pro version on my site: navmonline.org. I see that it now says https; however I don’t have the green padlock. Please advise. Thanks!

    #131466 Reply

    Mark
    Keymaster

    Hi Ann,

    there are still two images being loaded over http://. Http content on an https:// site will cause a mixed content warning. These two images are coming from your theme’s stylesheet (https://www.navmonline.org/wp-content/themes/churchope/css/skin.css?ver=4.9.8). You can try to clear all the caches your website uses, if that doesn’t solve the issue you can update the links to https:// manually.

    Mark

    #133589 Reply

    Muhammad Aqib

    Hi, i’m also using really simple SSL plugin here https://instadpdownloaders.com/
    It’s working perfectly fine on admin panel but sometimes for http content on front-end, it shows mixed content warning. Does it have any feature to redirect http images to https?
    Thanks!

    #133600 Reply

    Mark
    Keymaster

    Hi Muhammed,

    http content on an https site will indeed show a mixed content warning. The Really Simple SSL mixed content fixer will only redirect internal links (so no external images) to https://. If you are sure all images returned by the search are available over https://, you can replace all occurrences of http:// to https:// by adding a filter for the mixed content fixer output in your theme’s functions.php file:

    function rsssl_replace_all_https($html) {
      $html = str_replace('img src="http://', 'img src="https://', $html);
      return $html;
    }
    add_filter("rsssl_fixer_output","rsssl_replace_all_https");

    Do note this will break any images if they aren’t available over http://.

    Mark

    #133717 Reply

    Susan Finch

    Hello, I use CloudFlare for SSL, caching (level is standard), etc. and purged cache. In cloudflare I have rules set to always use https:

    I use the Avada child theme. Have added in the script code above to functions. In Avada theme options > advanced I have reset fusion caches, turned on js compiler, using css compiling method in database. I have the Really Simple SSL plugin in place, too. BUT I do not have a green padlock. I’m wondering why and how I can solve the issue?

    In the generated code I see the first line mentions http: instead of https – <html class=”avada-html-layout-boxed” lang=”en-US” prefix=”og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# og: http://ogp.me/ns#“> All other occurances are only links to other sites that are not https.

    #133736 Reply

    Rogier
    Keymaster

    Hi Susan, it is possible you have still hardcoded http links in css or js files. These should be changed to https as well. You can track these down using these instructions:
    https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    #139760 Reply

    Srikanth

    Hi,

    I am having a similar issue to the above on tacklebloke.com

    Not showing a secure icon when I load the homepage however it shows as secure when I load the WP-Admin Dashboard

    Please help me to solve this

    Thanks in Advance..!

    #139764 Reply

    Mark
    Keymaster

    Hi,

    there’s one image loaded over http:// (http://tacklebloke.com/wp-content/uploads/2018/10/IMG-20151028-WA0001_1_d1450.jpg). This image is coming from the following stylesheet: https://tacklebloke.com/wp-content/uploads/themify-css/themify-builder-40-generated.css?ver=1540307755. Since this is a reference your own domain, you can try to clear all caches the website uses, that will usually resolve the issue. If it doesn’t, you might have to check your theme settings or re-save them, since the stylesheet containing this http:// link is generated by the theme. For more information on how to locate these issues see https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/.

    Mark

    #139775 Reply

    Saïf

    Hi,

    I have the same problem as everybody. https://edoomarketing.nl/ is my website.
    The green padlock is showing when I’m logged in to the wp dashbord, but not on my homepage.
    I hope you can help me!
    Thanks in advance!

    Saif

    #139998 Reply

    Joy

    I have the same issue with the padlock not showing on https://www.afrostylicity.com/
    It only shows up when I am logged in to the WP dashboard. Any idea what could be causing this and how I can resolve it? Thanks in advance!

    #140020 Reply

    Mark
    Keymaster

    Hi Saïf,

    the site does seem to have the green padlock now, possibly this was caused by caching. Do you still experience issues?

    Mark

    #140021 Reply

    Mark
    Keymaster

    Hi Joy,

    the mixed content fixer doesn’t seem to replace all links to your own domain with https://, could you try to clear all caches the website uses? If that doesn’t solve it, try to enable the ‘Switch mixed content fixer hook’ option in the plugin settings.

    #200933 Reply

    Chelsea

    Hello, i am having the same issue. I have installed the plugin and i am not seeing the green padlock. i have checked for mixed content warning in the inspect element and i do not have the WP CACHE installed. i’m not sure what the issue is.

    Thank you,

    #201078 Reply

    Mark
    Keymaster

    Hi Chelsea,

    can you check if your site has a valid SSL certificate here https://ssllabs.com/ssltest? If the certificate is valid, can you send us your site address so we can have a look?

    Mark

    #204195 Reply

    Jazz

    Hi

    I think I have done everything on my website including forced redirects, fixing mixed content but greenpadlock is not appearing. The site SSL passes on https://www.whynopadlock.com/ and https://ssllabs.com/ssltest.

    Can you please help?

    #204201 Reply

    Mark
    Keymaster

    Hi,

    can you provide me with your site address so I can check what might be going wrong? Usually mixed content occurs because the page is being cached, clearing all caches will usually solve the warning. Also see https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/

    #213967 Reply

    Jake

    Hi,

    I am having trouble getting the padlock and url to appear green on my website.

    #214414 Reply

    Mark
    Keymaster

    Hi Jake,

    usually if the green padlock does not appear it’s because of caching. Can you try to clear all caches your website uses? If that doesn’t help, can you send me your site address?

    Mark

    #214648 Reply

    Jake

    Hi Mark,

    I have cleared all the catches but unfortunately it has not helped.
    my website is http://www.saintvalais.com

    Thanks,
    Jake

    #214651 Reply

    Mark
    Keymaster

    Hi Jake,

    the site does have a secure lock, I have checked multiple pages and all seem to be secure. Since a while some browsers don’t show a green padlock anymore, but a secure grey padlock. As long as the lock is closed there’s nothing to worry about.

    #214652 Reply

    Jake

    Hi Mark,

    Thanks for getting back to me. the main browser I want to have the green url for is safari, I know allot of websites have a green url on safari. is there nothing else I can do to achieve this?

    Thanks,
    Jake

    #214666 Reply

    Mark
    Keymaster

    Hi Jake,

    I see, you can get a green address in Safari by installing an Extended Validation (EV) SSL Certificate.This is the only certificate that will show a green url in Safari. See https://www.globalsign.com/en/ssl-information-center/what-is-an-extended-validation-certificate/ for more information. Your hosting provider can install an EV certificate for you.

    #222851 Reply

    Greg Smith

    Hi
    I’m unable to get the padlock to show on the Home page even though it appears for every other page. It is a Divi website. I’ve cleared the cache on the website and on my browser, disbaled/enable minification within the Divi settings. Are there any other issues I should try.
    Appreciate your help
    Greg

    #223235 Reply

    Mark
    Keymaster

    Hi Greg,

    have you also tried to clear the Divi builder cache as described here https://really-simple-ssl.com/knowledge-base/mixed-content-when-using-divi-theme/? Usually that will solve the issue. Could you also provide me with your site address so I can have a look?

    #228451 Reply

    Paul

    Hi
    I’m unable to get the padlock to show on the Home page even though it appears at the admin page page. My website URL is https://naturactin.com (Health supplements)
    Could someone help me to understand what is going on and how I can fix the problem?
    Thank you!!!

Viewing 30 posts - 1 through 30 (of 50 total)
Reply To: no green padlock?
Your information: