[Support request] Multisite redirect loop on homepages only. Sub pages work fine

Home Forums Redirect loops Multisite redirect loop on homepages only. Sub pages work fine

This topic contains 1 reply, has 2 voices, and was last updated by  Rogier Lankhorst 2 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #157521 Reply

    Wayne Philips

    When the plugin is active all homepages only on a multisite show a redirect loop.

    Example https://baird-consulting.co.uk/ wont load and loops but all subpages work find with SSL, eg https://baird-consulting.co.uk/contact

    if I disable the plugin everything works fine…

    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: litespeed
    MULTISITE
    SSL is being activated per site
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.1.3
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules...
    test page url, enter in browser to check manually: https://app.go6.studio/peter/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited...
    converting siteurl and homeurl to https
    #157556 Reply

    The problem is that you have a force redirect to http:// active. As soon as Really Simple SSL activates, it will activate a redirect to https://. This causes the loop.

    The solution is to remove the redirect to http, which is probably located in your .htaccess file or in a redirect plugin.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Multisite redirect loop on homepages only. Sub pages work fine
Your information: