[Resolved] menu link to subdomain being rewritten with https, how to remove this

Home Forums General issues menu link to subdomain being rewritten with https, how to remove this

This topic contains 6 replies, has 2 voices, and was last updated by  Sharon 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #120516 Reply

    Sharon

    I have a subdomain forum.domainname.com and am linking to it from the main menu of the site domainname.com. The subdomain does not have a secure cert but the plugin is putting https in front of it …. how can I bypass this for the subdomain?

    Thank you
    Sharon

    #120595 Reply

    Mark Wolters
    Keymaster

    Hi Sharon,

    what you can try is to exclude the subdomain url from the mixed content fixer, that should show the link with http://. See https://really-simple-ssl.com/knowledge-base/exclude-url-mixed-content-fixer/ for instructions on how to do this.

    Mark

    #120651 Reply

    Sharon

    Hi Mark
    Firstly thank you so much for the reply … something odd is going on though, maybe you can help.

    I did exactly as you said and added

    function rsssl_exclude_http_url($html) {
    $html = str_replace(“https://www.domain.com”, “http://www.domain.com”, $html);
    return $html;
    }
    add_filter(“rsssl_fixer_output”,”rsssl_exclude_http_url”);

    to my functions.php (I downloaded the file, added this at the end and uploaded it again)
    But when I then access the file via Appearance > Editor to check that it is correct I see that it has been amended to …

    function rsssl_exclude_http_url($html) {
    $html = str_replace(“https://www.domain.com”, “https://www.domain.com”, $html);
    return $html;
    }
    add_filter(“rsssl_fixer_output”,”rsssl_exclude_http_url”);

    An “S” has been added in automatically.

    Help!

    Many thanks
    Sharon

    #120839 Reply

    Mark Wolters
    Keymaster

    Hi Sharon,

    strange, can you try to remove the s and re-save the file? Perhaps some form of autocorrect has added the S.

    Mark

    #120846 Reply

    Sharon

    Hi Mark

    I did it a few times to be sure. It is not an autocorrect mistake.

    Does the plugin rewrite urls as they are saved, I don’t have anything else installed for SSL besides this plugin?

    Thanks
    Sharon

    #120889 Reply

    Mark Wolters
    Keymaster

    Really Simple SSL won’t edit your theme’s functions.php, so therefore I’m surprised the http:// is converted into https://. I’m not sure what could be causing this, perhaps it’s an issue with your theme or another plugin. To test this you can disable all plugins except Really Simple SSL and see if the http:// is still replaced with https://. If that doesn’t help you can try temporarily switching to a default theme to see if that resolves the issue.

    #121986 Reply

    Sharon

    So this is what happened for me …

    Leaving Really Simple SSL active and working I did the following

    in Setting > General
    For the WordPress Address and Site Address …
    I switched them both back to http:// instead of https://
    clicked save changes
    And reuploaded functions.php via FTP again with the code as above

    This time what ever was switching the http to an https didn’t do it so everything is working fine.

    funnily when I went back into Settings > General the https:// is back in front of both addresses

    No idea what is going on but if this happens to anyone else, this fix worked for me.

    Thanks so much for your replies Mark

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: menu link to subdomain being rewritten with https, how to remove this
Your information: