Forum | Really Simple SSL

Long load time after SSL

Home Forums General issues Long load time after SSL

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42551
    Chris
    Guest

    After installing SSL and the plugin, running a speed test on Pingdom I received a performance grade of “D 65 Minimise redirects” Remove the following redirect chain if possible:
    http://mmsdetox.com.au/
    https://mmsdetox.com.au/
    https://www.mmsdetox.com.au/
    https://www.mmsdetox.com.au/?v=6cc98ba2045f

    The SSL test page shows:

    #SERVER-HTTPS-ON# (on)
    #SERVERPORT443#
    #ENVHTTPS#
    #SUCCESFULLY DETECTED SSL#

    my .htaccess file has the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I’m not sure what I need to do in order to reduce the load time

    #42560
    Rogier
    Keymaster

    This last one is generated by the Woocommerce geo option.

    The first is from Really Simple SSl. Then WordPress redirects to your canonical domain.

    These redirects do not really slow your site down, as most hits will come in through the primary domain: Google will not show the http and non-www domain as it is all 301 redirected.

    This redirect chain is needed when you want to enable HSTS preload, so I would not change it. But if you want, you can bypass it in the .htaccess:
    https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/

Viewing 2 posts - 1 through 2 (of 2 total)
  • The topic ‘Long load time after SSL’ is closed to new replies.

Subscribe