[Support request] Installed Really Simple SSL and Site is not running slower

Home Forums General issues Installed Really Simple SSL and Site is not running slower

This topic contains 6 replies, has 2 voices, and was last updated by  Mike 1 week, 2 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #202889 Reply

    Mike

    Prior to installing Really Simple SSL, I had A scores on GT Metrix and a 1.6 load speed time. I had an 89 on Google Page Speed Insights. I was trying to avoid the multiple page redirects. But, after loading up RSSSL, my GTMetrix score dropped to 1.7 with an AB and Google dropped to a 73 – much worse. And I’m getting messages that I had not previously gotten, like Reduce Server Response Time (TTFB)

    So, I’m wondering what I did wrong and should I simply disable RSSSL and go back to where I was. I am on Siteground and I had SG Optimizer doing my SSL previously.

    Thanks for the help/advice.

    #202890 Reply

    Mike

    That’s funny. Title should have said that Site IS running slower.

    #202896 Reply

    Mike

    I deactivated Cloudflare and the Page Insights score improved to 85. But, there was no change on GTMetrix score.

    #202937 Reply

    Mark Wolters
    Keymaster

    Hi,

    SSL can make your site a little bit slower, however this should be barely noticable. Possibly you are taking the redirect to https:// into account. Since most users will come in via the https:// domain, a speed test should be performed with the https:// domain as well. See https://really-simple-ssl.com/knowledge-base/really-simple-ssl-make-site-slower/ for more information about why your site can become slower after moving to SSL.

    #203009 Reply

    Mike

    Thank you for the quick followup. I guess my question was more specific rather than general. As I indicated, I already had SSL enacted and https running through the SG Optimizer plugin through Siteground. So, adding your plugin should not have added more lag. I installed the RSSSL after a chat with Rogier because it seemed like it would help avoid the multiple landing page redirect and, therefore, speed up the site a little more.

    If it’s slowing in down some, whereas the SSL activation with SG Optimizer was working, should I just deactivate the RSSSL? Or is there something else I can do? Also, 2 of my photos on my mobile site are also now missing.

    Thanks.

    #203215 Reply

    Mark Wolters
    Keymaster

    Hi Mike,

    you could try to disable the mixed content fixer option to see if that increases your sites speed, that’s the only option that affects your front-end. Since you already had SSL with the SG Optimizer plugin you can safely disable Really Simple SSL via the ‘Settings->SSL->Deactivate and keep SSL’ button.

    The two images are likely loading via an http:// domain and are thus blocked on https://. If these images are coming from your own domain, clearing all caches the website uses will usually solve this. Otherwise you can locate the cause by following the steps in this article https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/.

    #203369 Reply

    Mike

    Thank you Mark. That is very helpful.

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: Installed Really Simple SSL and Site is not running slower
Your information: