Image Not Showing After Mixed Content Fixed

Home Forums Mixed content in my site Image Not Showing After Mixed Content Fixed

This topic contains 27 replies, has 5 voices, and was last updated by  Mark Smith 1 year ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
  • #24862 Reply


    I have problem with mixed content before. Then I fix that with clear cache on my website plugin cache.
    And after this mixed content fixed, I get the green lock icon but all images on my website does not appear.
    What can I do to fix this?
    Here the link of my website

    #24872 Reply

    Hi Maria,

    I just checked your site, all images seem to be visible. Is there any specific page where I should be looking?

    #25028 Reply



    I just fixed it by reuploading the images to my website. And it take much time.
    Do you have another solution for me?

    Thank you

    #25029 Reply

    I would need to see what the cause is to suggest a solution, but I can’t seen any images not showing currently. Some common issues with images: If you use photon, deactivate it. If you have hot-link protection on your server activated, deactivate it.

    Otherwise, do you have a page where I can see the problem? In the developer console you can see the errors for these images, and this will give some idea about a solution.

    #25030 Reply


    Here the link
    It show “Failed to load resource: net::ERR_TOO_MANY_REDIRECTS”

    #25032 Reply

    I don’t see any issues on the page. I’ve checked with FireFox, Safari and Chrome. What browser are you using?

    #25118 Reply


    I use Chrome and FireFox.
    There are two images on that page. Are they appear on your browser?

    #25136 Reply

    I see one image, not two, but I also don’t see any errors, not on the screen and not in the console. There do not seem to be any issues on this page. Could you paste a link to a screenshot of what you see?

    #25244 Reply


    May I get your email address Rogier? Or would you contact me via email? I want to send you the screenshot.

    #25252 Reply

    You can email it at rogier (at)

    #29685 Reply


    Hi Rogier,

    I am experience the same problems as discussed earlier on this block. I installed SSL and had Mixed Content and image problem but I was able to fix the mix content issue. But have been finding it very difficult to resolve the cracked image issue. Please here is my website, kindly check how the images look like?

    Thanks for helping.

    #29687 Reply

    Your issue is caused by Photon having trouble with your SSL. See also this article:

    If you deactivate Photon in JetPack, it should be fixed.

    #40404 Reply


    Hi Rogier,
    I have been experiencing the exact same issue with my images. Your suggestion to deactivate hotlink protection led to my solution.
    Even though I didn’t deactivate hotlink protection, adding the https URL to allow access did also help.
    So, thank you! 🙂

    For those of you who might need the information where to find hotlink protection:
    login to your cpanel and look under the category “security”.

    #51294 Reply


    Hi, I’m having the same issue… just went live with my site and SOME images are not showing up… I Fixed the links in the appropriate css file as the SSL Pro scan indicated from but the pictures still don’t show up, despite the fact that additional Quick scans came back with green check marks… I Need to fix this asap, please … please assist.
    Thank you kindly.

    #51343 Reply

    Mark Wolters

    Hi Monika,

    can you give us your site address? Then we will have a look at what the issue might be.

    #95607 Reply


    Hi Mark,

    I’m having a problem with images displaying too. I’m not getting a mixed content notice and the posts the images are in are loading perfectly but the images are missing … now here’s the funny thing – it seems to be all my posts in 2012!!!

    #95645 Reply

    Mark Wolters

    Hi Edwina,

    could you provide me with your site address? It sounds like the images which are uploaded in 2012 might be hosted on another domain or that the /wp-uploads/2012/ folder has a redirect back to http://, causing a mixed content warning. To check where the mixed content is coming from exactly you can follow this guide:


    #102904 Reply



    The SSL plugin is converting all http into https.
    This is fine for my own images that are hosted on my https server, and indeed for images hosted on other https servers.
    However the above forum topic has images that are hosted on a http server and the plugin keeps adding an s to the http url.

    How do I stop the plugin from adding an s to a http ul?

    #103105 Reply

    Mark Wolters


    you can exclude an url from the mixed content fixer by adding a piece of code to your functions.php file like this: That should fix your issue.


    #108302 Reply

    Daniel Huiet

    All my media files have disappeared after installing really simple Ssl. I purchased the pro version which didn’t change anything. The full scan gave me errors but not a fix button and I don’t understand what the errors are saying.

    #108341 Reply

    Mark Wolters

    Hi Daniel,

    can you provide me with your site address and the errors you see when using the plugin? We can help you in identifying and solving your issue.


    #108821 Reply

    Daniel Huiet

    When we scan, there are no errors listed, but no images are showing up on the site. The site address is All of the images worked prior to updating this plugin earlier this week.

    The results of the scan are below:

    Blocked url’s
    No references to domains without ssl certificate found.
    CSS and JS files with mixed content
    No references to domains without ssl certificate found.
    CSS and JS files from other domains with mixed content
    No CSS and JS files on other domains with mixed content.
    Posts with blocked resources
    No posts found that contain references to domains without an SSL certificate.
    Widgets with blocked resources
    No widgets found that contain references to domains without an SSL certificate.
    Database tables with blocked resources
    No references to blocked resources found within the database.

    #108851 Reply

    Brian M. Sullivan

    I just loaded the free version, then the paid version. All my media is gone. Please advise. Thank you!!!

    #108872 Reply

    As your images all return a 403 response, I suspect you have hot link protection enabled:

    Disabling hot link protection should resolve your problem.

    #108876 Reply

    @brian, possibly the same goes for you as well: hot link protection. As you haven’t posted a domain, I can’t check that. To prevent multiple discussions running through each other, it’s best to start your own thread. Otherwise I lose track of who is who, and which item is closed.

    #108986 Reply

    Daniel Huiet

    Thank you for the insight. Can you point me in the right direction for how to go about disabling hot link protection?

    #109001 Reply

    It’s usually a setting on the hosting admin panel, for example in CPanel or directAdmin.

    If you can’t find it, your hosting company will be able to tell you where it is.

    #114737 Reply

    Mark Smith

    Thank you! Hotlink protection was causing images not to show.

Viewing 28 posts - 1 through 28 (of 28 total)
Reply To: Image Not Showing After Mixed Content Fixed
Your information: