I'm getting error – The page isn't redirecting properly

Home Forums Redirect loops I'm getting error – The page isn't redirecting properly

This topic contains 12 replies, has 3 voices, and was last updated by  Burt 2 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #25450 Reply

    Filip Visic

    I’m getting error – The page isn’t redirecting properly (both Firefox and Chrome)

    Also, after I enable Really Simple SSL, and try to run PageSpeed Insights or GTmetrix, I get these errors:

    Google PageSpeed Insights

    Fetching the page exceeded the maximum of 10 redirects. The last URL fetched was https://www.zanosna.com/. This may indicate the page is redirecting to itself, or has a loop of redirects.

    GTmetrix

    Analysis Error
    Redirect loop detected!
    Visiting the page has resulted in an endless chain of redirects. This is usually caused by a problem in your application.

    Here is the code that plugin inserts to .htaccess file

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.5.0]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    #25451 Reply

    If the issue is gone when you remove the .htaccess redirect, you could you try this instead of the current redirection:

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:CF-Visitor} '"scheme":"http"'
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>

    Add this to your wp-config to prevent it from writing the .htaccess again:
    define( 'RLRSSSL_DO_NOT_EDIT_HTACCESS', TRUE );

    #25473 Reply

    Filip Visic

    Thanks! It did the job 🙂

    #25535 Reply

    Just for my information: do you use the free CloudFlare flexible SSL?

    #41831 Reply

    Luccy

    I have same problem. My site not redirect to https

    #41833 Reply

    Did you follow the instructions in this article?
    https://really-simple-ssl.com/knowledge-base/redirect-https-not-working/

    #68812 Reply

    Stefan

    Hey Roger,

    Why did you ask this “Just for my information: do you use the free CloudFlare flexible SSL?”

    I am using CloudFlare flexible SSL and I get this issue on Google Insights or GTmetrix. What should I do?

    #68813 Reply

    The original poster had an issue because of the specific configuration in CloudFlare. Here’s an article how you should setup CF:
    https://really-simple-ssl.com/knowledge-base/ssl-cloudflare-really-simple-ssl/

    If the issue is not a redirect loop, but you get warned about having three redirects, I would recommend reading this article:
    https://really-simple-ssl.com/knowledge-base/avoid-landing-page-redirects/

    #119138 Reply

    michael stabile
    Participant

    Same issue here, GTMetrix can’t scan my site, keeps saying “Redirect loop detected”. Otherwise the site seems to work fine, pages load with green lock, Really Simple SSL mixed content scan shows no issues. Using Cloudflare flexible SSL & all required settings are in place (Aways Use HTTPS page rule is setup, Automatic HTTPS rewrites is enabled). Only issue is indicated by GTMetrix, but I use GTMetrix alot & would like to know what’s causing this.

    https://www.bestdealsfind.com/uncategorized/pix/ (always has the problem)
    https://www.bestdealsfind.com (problem is intermittent)

    #122415 Reply

    Greg

    Same issue here…GTMetrix can’t scan my site…have you found the solution?

    Using Cloudflare flexible SSL and Really Simple SSL.

    #122466 Reply

    Possibly the problem is caused by Cloudflare. I don’t have this problem with Really Simple SSL for example. I would recommend to contact CloudFlare support and ask them if they know of this problem.

    #122674 Reply

    mike

    What is your domain ? I have not gotten an answer to this yet. Guys at Really Simple SSL couldn’t say what it is. I found that if I disable the plugin my SSL still works and there’s no issue on GTMetrix. However with the plugin I’m getting .5-1 second faster speed on Pingdom, so I prefer to use the plugin. I went back and forth many times with both Cloudflare & GTMetrix. GTMetrix pointed out that the redirect only happens on their Vancouver location, not Dallas, so when you test your site you can use Dallas no problem. But it still left me wondering if my site is inaccessible from visitors in Vancouver or even other places. I tested my site here to see if it loads from different locations worldwide: https://www.geoscreenshot.com/capture

    First test showed this error for Vancouver:
    “Error 1018 Cloudflare is unable to resolve your requested domain.”
    But when I ran the test again it worked, so I don’t know.

    If you give me your domain I’ll write to Cloudflare again and tell them I’m not the only one. They had even asked for a route trace from GTMetrix which I got and gave them. Thought they’d be able to pinpoint the problem, but they didn’t. And corresponding with them like 20 times each time I get a reply from a different rep who doesn’t really know what’s going on. I would like to get this fixed though so let me know your domain and let me know if you have the same result when you disable the plugin, or when you test GTMetrix using Dallas location.

    #136097 Reply

    Burt

    I had the same issue and this is how I solved it –

    Go to your account in cloudflare -> crypto

    1. In SSL choose Full
    2. Always use https – set to off
    3. HTTP Strict Transport Security (HSTS) – set to disabled
    4. Authenticated Origin Pulls – set to off
    5. Opportunistic Encryption – On
    6. Onion Routing – On
    7. TLS 1.3 – Enabled
    8. Automatic HTTPS Rewrites – Enabled

    I just went around in circles with GTMetrix on vancouver, however changing the above settings resolved it for me. Also I am on Amazon AWS if that helps. Fel free to visit us – https://burtkohl.com

    Hope the above helps!

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: I'm getting error – The page isn't redirecting properly
Your information: