[Resolved] I had to deactivate the Polylang plugin to make the site running, and now what?

Home Forums General issues I had to deactivate the Polylang plugin to make the site running, and now what?

This topic contains 14 replies, has 3 voices, and was last updated by  James 3 weeks, 6 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #63626 Reply

    Jean-Luc Crucifix

    Hi,

    On my site lepontias.com, there was a redirect loop after installing Really Simple SSL.

    Following instructions found in the knowledge base, I deactivated the Polylang plugin (multilingual), and now the site in perfectly online in SSL, although monolingual ;-).

    What am I supposed to do now to recover my multilingual site?

    Thanks for your help!
    And by the way thanks for the plugin which I used without any problem on my 2 other sites on the same server (and strangely one of them has the very same Polylang plugin!!)

    JL

    #63683 Reply

    Rogier
    Keymaster

    Hi Jean Luc,

    In most cases the issue resolves when you re-install, and/or re-save the settings in polylang. The problem is that Polylang is still redirecting to http, while Really Simple SSL redirects to https. This causes the loop.

    #63721 Reply

    Jean-Luc Crucifix

    Resolved! I just resaved the settings in Polylang and now it works fine!
    Thanks Rogier! Great plugin, so easy to use.

    #91873 Reply

    Sofia Oliveira

    Hello Jean-Luc.

    I have installed polylang to make my site on english and portuguese.
    But when the polylang is activated, the homepage turnes insecure. When I desativated the pollylang the homepage returns secure.
    Do you know how to solve this? Thanks

    #93854 Reply

    Jorge Morales

    I installed Polylang, set default language (Spanish) and added English as second language. When i go to my pages i am unable to add the English translation manually because the (+ sign) doesn’t react. I deactivated and activated the plugin endless times and the problem keeps coming back. The (+ sign) is there but not working.

    #93987 Reply

    Rogier
    Keymaster

    Hi Jorge,

    This sounds like an issue you should take up with Polylang support.

    #95062 Reply

    Sofia Tavares

    Hello Jean-Luc.

    I have installed polylang to make my site on english and portuguese.
    But when the polylang is activated, the homepage turnes insecure (on private browser). When I desativated the pollylang the homepage returns secure.
    Do you know how to solve this? Thanks

    #95109 Reply

    Mark Wolters
    Keymaster

    Hi Sofia,

    it is likely that Polylang still loads resources over http://, thus resulting in an insecure site. Usually this is caused by caching. You can try to clear all caches the website uses. If that doesn’t work, try to disable/enable Polylang and re-save the Polylang settings.

    Mark

    #102263 Reply

    Jeroen

    Hi there, I have the same problem.

    How can I re-save the settings. If I go to the settings I can’t re-save polylang settings.

    Can someone please help me?

    #102439 Reply

    Mark Wolters
    Keymaster

    Hi Jeroen,

    have you tried to disable and then enable Polylang again? You should be able to save the settings, if saving the settings doesn’t work you can try to contact Polylang support.

    Mark

    #102444 Reply

    Jeroen

    Hi Mark,

    Now polylang is working together with the secure SSL certificate. But it only works when I’m logged in to wordpress. Seems like the redirect doesn’t work correctly in simple SSL.

    Is there something I can do about this?

    Thanks in advance,

    Jeroen

    #102457 Reply

    Mark Wolters
    Keymaster

    Have you tried clearing all caches your website uses? Usually when you are logged in to WordPress caching is disabled, you might have to clear the cache before these changes take effect when logged out.

    Mark

    #264464 Reply

    James

    I installed Polylang on my g2elite.academy website and added Chinese as language 0. Then all of a sudden all pages turned blank and I can’t even enter my dashboard any more. My site is blank now. Can I restore it?

    #264484 Reply

    Mark Wolters
    Keymaster

    Hi James,

    if this happened after installing Polylang, you might want to contact Polylang support about this issue. They can help you better with their product than we can.

    #264934 Reply

    James

    Thanks a lot, Mark. Yes, I contacted them and they gave me several pieces of good advice. I’m trying to locate what lines were changed in the PHP code so I can go back to the original …..

Viewing 15 posts - 1 through 15 (of 15 total)
Reply To: I had to deactivate the Polylang plugin to make the site running, and now what?
Your information: