[Resolved] https://www to non www not working

Home Forums General issues https://www to non www not working

This topic contains 27 replies, has 4 voices, and was last updated by  Rogier 2 weeks, 4 days ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #66205 Reply

    ezwest
    Participant

    I’m a but of a noob with ssl, but I’ve never had this issue with a site.

    I’m trying to set the redirect to https://mydomain.com/

    going to http://www.mydomain.com and http://mydomain.com/ WORKS

    However, going to https://www.mydomain.com gives me this error:


    This site can’t provide a secure connection

    http://www.mydomain.com uses an unsupported protocol.
    ERR_SSL_VERSION_OR_CIPHER_MISMATCH

    Or if I try and go to http://www.mydomain.com/sub-page/, it redirects to https://www.mydomain.com/sub-page, but returns the same error.

    Any ideas would be greatly appreciated!

    #66227 Reply

    Rogier
    Keymaster

    The server or the certificate is not properly configured. You can find out more by checking ssllabs.com/ssltest, and running a scan. With the results, you can contact your hosting company.

    #66234 Reply

    ezwest
    Participant

    Thanks for the reply Rogier.

    Turns out the issue was caused by a CNAME record that was pointing away from the site.

    #77593 Reply

    Alta

    My site does not seem to redirect to non-www. This is possing an issue with my simple social media buttons not showing up. Does this have to do with my SSL? Sorry, I am a complete novice at this but learning more every day! 🙂

    #77636 Reply

    Rogier
    Keymaster

    This is not SSL related. If you have set your home_url and site_url in settings/general to www, WordPress should redirect your site to this URL with www.

    #154458 Reply

    Ananya Sharma

    mine is also not working
    when i am trying to open https://apkdataobb.com — its not working but
    when i try to open https://www.apkdataobb.com — its working Perfectly

    please help..

    #154464 Reply

    Ananya Sharma

    Same is happening to my another domain which is paperquestion.com
    please help guys…i am losing my traffic

    #154500 Reply

    Rogier
    Keymaster

    The non www domain is not added to your SSL certificate:
    https://www.ssllabs.com/ssltest/analyze.html?d=www.apkdataobb.com (note that only the www domain is listed).

    You can contact your hosting company about this issue.

    #219116 Reply

    James white

    I own the website
    and I found that when I visit http://9blogspace.com and http://www.9blogspace.com, redirect works perfectly
    to https://9blogspace.com
    But when I visit https://www.9blogspace.com it works but no redirect to the https://9blogspace.com
    I have an A record for “a” and ‘www’ for my domain
    but I use a ssl certificate provided by a third party based on my application hosted on a virtual platform
    I really need help as I have scanned the internet, spoken with customer service bt non has any reasonable answer
    Thanks

    #219471 Reply

    Mark Wolters
    Keymaster

    Hi James,

    the www domain does seem to be redirecting to non-www now. Do you still experience issues or did you manage to fix it?

    #221863 Reply

    Afaq Khan

    Im Also having the same issue help plz
    sciencetechhealth.com

    #222332 Reply

    Mark Wolters
    Keymaster

    Hi Afaq,

    have you tried to add the redirect code to your .htaccess file as described here: https://really-simple-ssl.com/knowledge-base/avoid-landing-page-redirects/?

    #226598 Reply

    Kumar

    My client is running massage spa. Their website is deindexed overnight. goldenoaksspa.com/ and goldenoaksspa.com/ getting errors. Any one kindly tell me how to rectify this?

    #227152 Reply

    Mark Wolters
    Keymaster

    Hi Kumar,

    what errors is your client getting exactly? The site seems to be working fine over SSL. A drop in raking can occur after moving to SSL, however that should restore quickly. Have you made the changes to your Google setup as described here: https://really-simple-ssl.com/knowledge-base/how-to-setup-google-analytics-and-google-search-consolewebmaster-tools/?

    Mark

    #257632 Reply

    Sanjeevi

    My site https://ridgewaterhomes.com.au/ has installed SSL. In that, all url redirection to https with non-www is working fine. But only one url is not working properly https://www.ridgewaterhomes.com.au while viewing in moz. It throws some warning message. Can you please help with that?

    #257764 Reply

    Rogier
    Keymaster

    It looks like you don’t have the www version of your domain added to the certificate. If you add the www domain to your cert the issue will be resolved. An alternative is to add a .htaccess redirect from www to non www, as described here, but this is not recommended.
    https://really-simple-ssl.com/knowledge-base/avoid-landing-page-redirects/

    #258270 Reply

    Sanjeevi

    This SSL certificate will support only one URL, with www or with non-www. We prefer the non-www. So we have to do the redirection. I tried this code
    #redirect all www requests to non-www.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
    </IfModule>

    it’s not redirecting

    #258301 Reply

    Mark Wolters
    Keymaster

    Hi Sanjeevi,

    the redirect is defined within an block. This means the redirect will only be done when the server can detected the mod_rewrite.c module. If the redirect doesn’t work, it’s possible this module isn’t enabled on your server. You can contact your hosting provider to check if the module is enabled.

    #258313 Reply

    Sanjeevi

    Ok. Is anything needs to be changed in the below code. Like we need to insert url instead of https://%1/$1 like any other modification??

    #redirect all www requests to non-www.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
    </IfModule>

    #258338 Reply

    Mark Wolters
    Keymaster

    You shouldn’t have to make any changes to the code, it should work as is.

    #258555 Reply

    Sanjeevi

    I tried that code but it’s not working. mod_rewrite.c module is enabled in our server. Still it’s not working. Is there any other way to solve this issue??

    #258597 Reply

    Mark Wolters
    Keymaster

    strange, you could try to replace

    RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

    with

    RewriteRule ^(.*)$ https://%{HTTP_HOST}%/$1 [R=301,L]

    to see if that makes a difference.

    #258687 Reply

    Sanjeevi

    I tried replacing the code but all end up vain. I tried WordPress plugin, some htaccess code and redirection did in Cpanel nothing help us out to solve this issue. I don’t know what to do after this

    #259164 Reply

    Mark Wolters
    Keymaster

    Hi Sanjeevi,

    it’s possible there’s a different redirect overriding the Really Simple SSL redirect. This redirect can be done by a different plugin, in your .htaccess file or in your hosting control panel. If you can send me the contents of your .htaccess file I can check this for you.

    Mark

    #259185 Reply

    Sanjeevi

    Yeah sure. Here the content in the .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    #redirect all www requests to non-www.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
    </IfModule>

    #259544 Reply

    Mark Wolters
    Keymaster

    Everything seems to be fine, you might have to contact your hosting provider about this issue.

    #268812 Reply

    Hemant
    #268868 Reply

    Rogier
    Keymaster

    This is not an SSL problem: It looks like the domain without www isn’t properly configured. It’s not pointing to an ip number. Your hosting provider can help you with that.

Viewing 28 posts - 1 through 28 (of 28 total)
Reply To: https://www to non www not working
Your information: