[Resolved] HTTPS force works except for 1 image

Home Forums General issues HTTPS force works except for 1 image

This topic contains 5 replies, has 3 voices, and was last updated by  Novato Felipe 3 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #77957 Reply

    Stephanie VC

    Hi!

    Thanks for the nice plugin! However, I have a tiny issue concerning one image that doesn’t get forced to https, whilst the rest of the http URL’s do.

    I’m a marketeer with practically no webdev skills, so I really need your help to get why it doesn’t work :p

    So: I’m in charge of this website. When the plugin is turned off, I get notice of 16 HTTP URL’s. When I turn the plugin on, I get notice that the website isn’t a safe environment. When I do a test in whynopadlock.com, I get this information:

    “Soft failure: An image with an insecure url of “http://toujoursfemme.be/wp-content/uploads/2016/10/tou-sprite.png” was loaded via the javascript file: https://toujoursfemme.be/wp-includes/js/jquery/jquery.js?ver=1.11.3 on line 4. The insecure URL may not be directly contained in the script file and may exist elsewhere.
    You may need to contact your web hosting provider for assistance.
    This URL will need to be updated to use a secure URL for your padlock to return.”

    Any ideas why only this image does not get forced?

    Thanks soooooo much!
    Stéph

    #78054 Reply

    Mark Wolters
    Keymaster

    Hi Stephanie,

    there’s an http:// link to that image in the following stylesheet: https://toujoursfemme.be/wp-content/themes/betheme/css/base.css?ver=11.6. Changing the stylesheet link to the protocol independent // (or https://) will result in the image being loaded over https:// as well.

    Mark

    #97770 Reply

    scotty maturin

    im also getting this error

    An image with an insecure url of “http://alienstreams.net/wp-content/uploads/2018/04/fanart.jpg” was loaded via the javascript file: https://alienstreams.net/wp-includes/js/jquery/jquery.js?ver=1.12.4 on line 2. The insecure URL may not be directly contained in the script file and may exist elsewhere.
    You may need to contact your web hosting provider for assistance.
    This URL will need to be updated to use a secure URL for your padlock to return

    please help

    #98151 Reply

    This is not an error message from Really Simple SSL pro, so I don’t know the details, but what that error message says is that you need to replace the http:// url of that image to https.

    #106441 Reply

    Josh

    Just update the wp-options table in your database using phpadmin with https instead of http and reupload the images and your problem is solved. worked for me

    #220692 Reply

    Novato Felipe

    Thank You Josh, you are very PRO.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: HTTPS force works except for 1 image
Your information: