htaccess redirect issue

Home Forums General issues htaccess redirect issue

This topic contains 11 replies, has 2 voices, and was last updated by  CrownRandall 11 months, 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20170 Reply

    CrownRandall
    Participant

    I got error of writing SSL redirect to my htaccess but even when i go and input manually it still says it and even is gone when i go back in to see if still in the file. Help please

    #20171 Reply

    If you do not enable the option “stop editing htaccess file” in the SSL settings, and the plugin cannot determine the correct redirect, it will remove the redirect.

    Here are some more detailed instructions how to insert the htaccess redirect.
    https://really-simple-ssl.com/knowledge-base/manually-insert-htaccess-redirect-http-to-https/

    If you have any problems with this, let me know.

    #20172 Reply

    CrownRandall
    Participant

    That did it… now i have this issue and seeing a broken homepage in IE browser still…I do see the little tag it says to look for but not sure what is wrong still

    The mixed content fixer is activated, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working

    My website url is earlybirdpaper.com

    #20180 Reply

    Did you clear any caching plugins, and caching in your browser?

    I can’t check your site, I’m blocked by sitelock.

    #20181 Reply

    CrownRandall
    Participant

    What country are you in? I do have many countries blocked and if not in usa then that would do it…caching all been clear…

    #20192 Reply

    CrownRandall
    Participant

    ok…you should be able to access now

    #20198 Reply

    Yes, I can see your site now, but I get too many redirects. Did you use these lines?

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>

    If that doesn’t work, I’d remove the htaccess redirect and enable the javascript redirect in the settings. Then I can check your site for mixed content.

    #20200 Reply

    CrownRandall
    Participant

    I still had redirect in javascript enabled…is it better now when you check? i disabled that and left the coding in htaccess

    #20204 Reply

    Looks good now. I don’t see any mixed content on your site. There is a warning about a parse blocking cross origin script that could cause issues on some browsers, this link is the cause: https://servedbyadbutler.com

    This link could possibly give a solution to solve it:
    http://stackoverflow.com/questions/39610829/a-parser-blocking-cross-origin-script-is-invoked-via-document-write-how-to-ci

    #20205 Reply

    CrownRandall
    Participant

    Thank you so much. I do have one last one…bluehosts says i have to buy a separate ssl certificate to use with our bluebagmedia.com domain does nothing more than redirect to our main domain at earlybirdpaper.com

    right now…if anyone types it in their browser it gives a privacy warning before going to our regular site…is there any other way around this other than buying another cert just for a redirect?

    Last question i promise 😉

    #20206 Reply

    Glad to help! What I use in these cases is a simple redirect in the .htaccess before all other stuff, which redirects to the https version of your primary domain. This way, the redirect takes place before the SSL redirect, so no certificate is needed.

    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteCond %{HTTP_HOST} ^bluebagmedia.com [OR]
      RewriteCond %{HTTP_HOST} ^www.bluebagmedia.com
      RewriteRule (.*)$ https://www.earlybirdpaper.com/ [R=301,L]
    </IfModule>
    #20207 Reply

    CrownRandall
    Participant

    you my friend are awesome…thanks a million!!!

Viewing 12 posts - 1 through 12 (of 12 total)
Reply To: htaccess redirect issue
Your information: