Force non-ssl

Home Forums Multisite Force non-ssl

This topic contains 2 replies, has 2 voices, and was last updated by  Philip 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #37734 Reply

    Philip
    Participant

    I use multisites with subfolders and domain mapping on a reasonably large multisite (100s of sites, half with their own domain).

    I have bumped into Letsencrypt rate limiting problem on the first renewal anniversary and find that 3 sites have not got a valid certificate, with obvious consequence that users get a stark warning message.

    I need to revert these to non ssl for a week.

    With the multisite plugin, I can override ssl. I have removed the ssl directive from the affected domains in /etc/apache2/sites-enabled/mydomain.org.conf

    However I am still getting pushed to https on 2 of the 3 domains, unless I use incognito browser session. Is it possible to force the non-ssl?

    .htaccess has no references to the domains and using Debug everything appears to be OK, except perhaps:

    The ssl testpage returned the error: cURL error 60: SSL certificate problem: self signed certificate

    Am I missing something? (caching and google’s listing are going to affect users)

    Any pointers/advice gratefully received.

    #37738 Reply

    This sounds like your browser is forcing SSL. If you would force http on the site, this would result in a redirect loop. In that case the only way to fix is to clear the browser cache.

    #37740 Reply

    Philip
    Participant

    I see. It may well be caching, so I guess users will experience a few problems until such time as I can get a valid cert next week. There are some other strange things going on, but I will see if they fix themselves before posting again!

    Thank you Rogier for the quick response.

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: Force non-ssl
Your information: