Forum | Really Simple SSL

Error Message in One Site

Home Forums Multisite Error Message in One Site

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #703
    Jay Goodrich
    Guest

    Hello,

    I am getting a message in one of my multisite sites. It states…You run a Multisite installation with subfolders, which prevents this plugin from handling the .htaccess. Because the domain is the same on all sites. You can just as easily activate ssl on all your sites. So to get rid of this annoying message, just activate network wide.

    I have the plugin running across the network, out of the 10 sites this is the only one with this message. Looking at the settings area of SSL the “Turn HTTP Strict Transport Security on” is unchecked and grayed out so that it cannot be checked. Any advice?

    Cheers,

    Jay G.

    #731
    Rogier
    Keymaster

    Hi Jay,

    Sorry for the delayed response, missed your message. You have a multisite installation with subfolder sites and activated networkwide? I’d have to take a look, but you shouldn’t get this warning in that case.

    #755
    surrogatekey
    Guest

    Hi –

    I’m having the same problem. I have a multisite installation with 3 sites, and Really Simple SSL is activated for the network. I get this message only on the last subsite:

    You run a Multisite installation with subfolders, which prevents this plugin from handling the .htaccess. Because the domain is the same on all sites. You can just as easily activate ssl on all your sites. So to get rid of this annoying message, just activate networkwide.

    #756
    Rogier
    Keymaster

    Was this site added before activating the plugin? The plugin uses a WordPress function to detect if the plugin was activated networkwide. The issue seems to be that when a site is activated after the plugin was activated, this check is not performed again. I’ll look into that for the next update. For now, as a temporary solution:
    find the class-admin.php, and look for the function get_admin_options().

    Comment out this line by adding two slashes:
    //$this->set_rewriterule_per_site = isset($options['set_rewriterule_per_site']) ? $options['set_rewriterule_per_site'] : FALSE;
    And add this line below as replacement, which will tell the plugin to act as networkwide.
    $this->set_rewriterule_per_site = false;

    #762
    Josh Ferguson
    Guest

    Hey There,

    Having a little issue on a sub-domain multisite install. When we enable the plugin on only the main site (sermonboxonline.com), for some reason every other site redirects to https as well. Some of our demo sites do not have ssls nor do we intend on adding those ssls either.

    We offer SSL support as an addon so not all of our sites will have SSLs installed. I say all that to say this. When we went to the class-admin.php file and found this line:

    $this->set_rewriterule_per_site = false;

    We changed the rule to read:

    public function detect_if_rewrite_per_site($networkwide) {
        if (is_multisite() && !$networkwide) {
            $this->set_rewriterule_per_site = TRUE;
        } else {
            $this->set_rewriterule_per_site = TRUE;
        }
        $this->save_options();
      }

    This fixed our issue. So I’m guessing that for whatever reason the plugin is not seeing that we are on a sub-domain multisite install? Anything else I might be missing?

    #763
    Rogier
    Keymaster

    Thank you for the feedback. There is an issue with the rewrite_rule_per_site setting. I’ll work on this issue for the next update.

    #786
    Rogier
    Keymaster

    The set_rewrite_rule_per_site variable wasn’t store as a network variable, but as a site variable. I’ve fixed this, I’ll be pushing out a beta soon.

    #791
    Rogier
    Keymaster

    On https://downloads.wordpress.org/plugin/really-simple-ssl.zip you will find a beta release which fixes this on my testing accounts.

    #2442
    blasck
    Guest

    hello,I am using your plugin as well until I have actived the multisite
    and now it shows a message says:
    “You run a Multisite installation with subfolders, which prevents this plugin from handling the .htaccess. To enable .htaccess redirection, activate SSL networkwide. To ignore this message, just dismiss it.”

    what does it mean?
    and my ssl is still work?

    thanks

    #2444
    Rogier
    Keymaster

    Hi,

    If you enable SSL per site on a multisite installation, the plugin can’t manage that in the .htaccess, as it can’t distinguish between a subsite and a page (both domain.com/name).

    As you have the certificate for your domain, you can also choose to activate it networkwide instead of per site. If you do that, all your sites will be on SSL.

    If you want it active on just one site, as it appears to be now, you can dismiss the message. Your site will function on SSL normally, only without the .htaccess redirect.

    If you have any questions, just let me know.

    Rogier

    #12337
    Andi
    Guest

    Hi Rogier

    We have the same problem and followed the above ideas but it is simply not working. The message still appears.

    Could you please write down a step by step way how to fix that problem, as I think that probably it is important to have the correct order in getting things done.

    We have a multisite

    https://domain.tld
    https://domain.tld/site1
    https://domain.tld/site2
    https://domain.tld/site3

    Your plugin is activated as well as prosites.

    Kind regards

    Andi

    #12338
    Rogier
    Keymaster

    Hi,

    Do you have Really Simple SSL activated networkwide, and you still get this message?

    #12429
    Andi
    Guest

    Hi Rogier
    What are the exactly steps to activate SSL networkwide what that error message suggests.
    We have SSL installed for all our sites and running multisite from subdirectories and all subs should have the same SSL.

    Thanks

    #12430
    Rogier
    Keymaster

    Hi Andi,

    If you go to My Sites (top of the screen), Network Admin, plugins, you will get the plugins overview. In this view, you can choose to network activate plugins. If you do that, Really Simple SSL will force all sites over SSL.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Error Message in One Site’ is closed to new replies.

Subscribe