ERR_TOO_MANY_REDIRECTS when .htacess edited

Home Forums Redirect loops ERR_TOO_MANY_REDIRECTS when .htacess edited

This topic contains 14 replies, has 4 voices, and was last updated by  Mark Wolters 3 days, 23 hours ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #24082 Reply

    Leo George Kimble
    Participant

    Hi,
    When I add the suggested code from the plugin to the .htaccess file I get
    ERR_TOO_MANY_REDIRECTS error in browser.

    However, I found code on my hosts support database for the htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{ENV:HTTPS} !=on
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>

    I do not get the error in the browser if I use this. However, I do not know enough about editing .htacess files to know whether or not it is achieving the desired outcome?

    If it is can I just ignore the error message on your plugin?

    #24102 Reply

    Thanks for the feedback, I’ll add this condition to the core plugin, so others will benefit from your experience 🙂

    This looks good, but to make sure, you could check with http://www.redirect-checker.org/index.php if you now have a 301 redirect.

    You can dismiss the .htaccess notice now.

    #25996 Reply

    Mickael

    Hi,

    Just to confirm this also happened to me. Thanks Leo.

    When I activated the plugin I got

    ERR_TOO_MANY_REDIRECTS

    Here is what I tried:

    1. remove the part added by the plugin and replace by the one from Leo
    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.5.1]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{ENV:HTTPS} !=on
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL

    2. Go to plugin settings: /wp-admin/options-general.php?page=rlrsssl_really_simple_ssl&tab=settings
    (this is tricky because plugin will overwrite the .htaccess each time, so you have to reupload your edited version)

    3. check “Stop edit htaccess file”

    4. Admin is all upside down – issue CSS maybe?

    5. Remove the plugin 🙁

    6. Remove the lines added in .htaccess

    7. Add this in your wp-config.php

    /** Fix mixed content */
    $protocol = ($_SERVER[‘HTTPS’] == ‘on’ ? ‘https://’ : ‘http://’);
    $url = $protocol . $_SERVER[‘HTTP_HOST’];
    define(‘WP_DOMAIN’, $domain);
    define(‘WP_HOME’, $url);
    define(‘WP_SITEURL’, $url);

    Just for info, I started my WP with SSL, maybe that’s the problem as the plugin assume it is activated on a non-ssl wp?

    #26031 Reply

    Another option would be to add the constant:

    define("RLRSSSL_DO_NOT_EDIT_HTACCESS", true);

    to your wp-config.php, then remove the .htaccess redirect. Then the plugin won’t edit the .htaccess anymore, and you don’t have to remove the plugin.

    Then you still have the benefit of the mixed content fixer in the plugin. The code you used to fix mixed content will only work for dynamically generated urls, not for hardcoded urls in files or urls in posts or pages.

    For the plugin it does not matter if the site already is SSL or not. The thing is that there are thousands of different server configurations. I try to check the correct redirect rule, then test it by opening a testpage through that .htaccess redirect. So if the plugin adds that redirect, it must have successfully checked the page. So would be interesting to know what redirect rule the plugin added to your .htaccess. Because as of 2.5.1 the

    RewriteCond %{ENV:HTTPS} !=on
    is also checked for, and added in the .htaccess if encountered. So to be able to improve the plugin it would be great to know what redirect the plugin detected.

    If you could share that information, that would be great!

    #28624 Reply

    Varun

    Hi

    Since yesterday, my site isn’t working. I am getting this error:

    The learningpro.co.uk page isn’t working

    learningpro.co.uk redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    If you could help please. I also like the pluging which does the work very well.

    Looking forward to the solution.

    Many thanks
    Varun

    #28625 Reply

    Hi Varun,

    What do you have currently in your .htaccess?

    In the settings, can you disable the .htaccess redirect, and enable the WordPress 301 redirect? That should resolve the issue.

    Rogier

    #28902 Reply

    Rinaldo

    I am struggling now for one DAY with the redirect problem since I updated all plugins and it appears the culprit is RS SSL.
    It appears to me “enable the WordPress 301 redirect” IS the issue, not the resolution.
    I installed a fresh htaccess and everything is fine Frontend and Backend.
    As soon as I click on SETTINGS the Dashboard is not accessible anymore. Only the FE. This lasts until I load a new htaccess, but I cant see that your plugin added any code.
    What must I look for?

    #28905 Reply

    There are two redirects: wp 301 redirect, and the .htaccess 301 redirect.

    The WP 301 redirect is a redirect that does not use htaccess, so if you have disabled “htaccess redirect” in the settings, the plugin won’t change the .htaccess anymore (as of version 2.5.10).

    As of 2.5.10, the .htaccess does not get inserted automatically anymore.

    If you installed with an previous version, and can’t access the backend, you can add:
    define('RLRSSSL_DO_NOT_EDIT_HTACCESS', true);
    To your wp-config.php, which stops the plugin from making any changes.

    #28984 Reply

    Rinaldo

    Thanks, I inserted the code in wp-config. No change, which doesnt surprise me, since I could not see any change in the httaccess. After overwriting the htaccess the Dashboard is working again.If you are interested in analysing this weird effect I will email the htaccess. Its a multisite though.

    #28995 Reply

    What version are you using? There was an issue in an older version which could have caused this.

    Updating to 2.5.10 might solve this issue. Make sure that you set the .htaccess to not writeable and disable redirect for all websites.

    Multisite can be a bit difficult sometimes, we are working on a feature to improve that 🙂

    #29008 Reply

    Rinaldo

    I am using 2.5.10.
    The problem appeared after updating to this version!
    Albeit, I also updated WP to 4.7.3 at the same time.
    I made htaccess 444, thanks!

    #36728 Reply

    Emrah

    I did the new update today
    Has homepage access but sub-pages ERR_TOO_MANY_REDIRECTS
    No code knowledge
    My website has dropped to bad state
    This is the solution step by step

    #36775 Reply

    Hi Emrah,

    The information you posted is not enough for me to say anything about the issue. Could you submit a support request with your .htaccess file, debug log, and domain? Than I can investigate the issue.

    You can submit your request on:

    Support

    Rogier

    #61483 Reply

    Suraj

    Dear mate,
    This page isn’t working

    http://www.rvsmedia.co.uk redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    Please solve this issue
    Thanks

    #61492 Reply

    Mark Wolters
    Keymaster

    Hi Suraj,

    when a redirect loop occurs this is most likely because something is issueing a redirect back to http://. Really Simple SSL tries to redirect to https://, and if something else does the same but to http:// a redirect loop will occur. You can fix this by locating the http:// redirect and remove it. This is often caused by another plugin, .htaccess rule or redirect setting in your hosting control panel. A good start is to disable all plugins and check if the redirect still occurs after that.

    Mark

Viewing 15 posts - 1 through 15 (of 15 total)
Reply To: ERR_TOO_MANY_REDIRECTS when .htacess edited
Your information: