ERR_SSL_PROTOCOL_ERROR

Home Forums Mixed content in my site ERR_SSL_PROTOCOL_ERROR

This topic contains 4 replies, has 2 voices, and was last updated by  Rogier Lankhorst 6 days, 4 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #22195 Reply

    Juanca

    Hello,

    I´m using the Really Simple SSL plugin on a WordPress with Woocommerce installation and a Comodo SSL site certificate installed.

    The RS-SSL plugin is configured with the Mixed content option turn on, then:

    Just after clicking on the purchase button from woocommerce checkout page, the browser show an ERR_SSL_PROTOCOL_ERROR page.

    However, if I turn-off the “Mixed content” plugin option (the browser show now a not secure page at all), the browser show the correct payment page in a Bank’s URL.

    I try to apply the “Disabling ssl for one page only” solution (with the checkout page) but nothing happens, the browser lock is always green.

    That could be happening?

    Regards,
    Juanca

    #22196 Reply

    Rogier Lankhorst
    Keymaster

    Disabling SSL for one page only will not work when the homepage is SSL, after visiting the homepage, the browser will visit subpages over SSL as well. In your case, you have the ssl version of the page in the cache as well.

    It’s hard to say what is happening without seeing the website. When the mixed content fixer is active, it will force all resources over https. If that resource does not support https, this might be the result. You could check which url is generating this error by right clicking your webisite, then click “inspect element”, then “console”. You will see more details about the error there.

    #22251 Reply

    Juanca

    Hi again,

    An image console error:

    A) Image Mixed Content Turn OFF

    B) Mixed Content Turn ON

    Regards,
    Juan Carlos

    #22260 Reply

    Juanca

    Hi again Rogier,

    Problem solved. The bank in test mode don´t let us the HTTPS connection to their servers. However, really Simply SSL always transform that URL to HTTPS (perhaps the PRO version module could discriminate that particular url).

    Solution: Simply put (after make the tests with RS SSL plugin OFF) the bank system in real mode the problem is over.

    Regards,
    Juanca

    #22516 Reply

    Rogier Lankhorst
    Keymaster

    Thanks for the update!

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: ERR_SSL_PROTOCOL_ERROR
Your information: