[Resolved] Edit Posts Not Working After SSL Update

Home Forums General issues Edit Posts Not Working After SSL Update

This topic contains 29 replies, has 3 voices, and was last updated by  Rogier Lankhorst 1 month, 3 weeks ago.

Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
  • #73503 Reply


    We just updated our SSL certificate on our WordPress site, and used Really Simple SSL to force all of our pages to adopt SSL. Everything worked as it should, we can login to the admin and all of our pages are successfully showing up as HTTPS.

    Unfortunately, when we go to edit a post on our site, we get a 404 error on the edit page. I’ve looked through the forum and couldn’t find an answer.

    Again, the rest of our site is showing up fine and I can access the admin dashboard, I just can’t edit individual posts.

    Any suggestions would be greatly appreciated, thank you!

    #73504 Reply


    Actually, a few more features don’t work. In addition to not being able to edit pages, I can’t upload or deactivate any plugins. It’s like any URL with a = in it stops working.

    Again any suggestions are very appreciated!

    #73543 Reply

    Mark Wolters

    Hi Chris,

    can you try to re-save the permalinks? If that doesn’t solve your issue can you try to use a default WordPress theme and check if the error still occurs?


    #74329 Reply



    Pretty much same problem here, Ive added SSL cert on server and installed Really Simple SSL Pro this week and I can no longer add new posts of edit old ones. The existing posts still show on the frontend, but the options to see them or add new have gone from the dashboard. Under the Posts menu I simply get Categories and Tags now, nothing else. Ive re-saved permalinks, but no joy. Don’t want to try a default theme just yet as middle of the day on Saturday and as a charity, its one of our busiest times for people viewing. Can try later but wondered if any more news on this?

    #74332 Reply


    OK, further update, unlike Chris, I can add and remove plugins, media, etc, it does just seem to be new or editing posts that is the problem.

    #74368 Reply


    Sorry, further info if needed

    All cookies/cache cleared and two different browsers tried, Safari and Chrome but all to no avail.

    I bought the 5 site Pro version, installed on two sites so far and all good on the other one, everything working as it should.

    If I put the direct link to add a post or show a list of existing posts in the address bar, I get a WordPress generated “Sorry, you are not allowed to access this page.” message, not a server message. Ive checked my user settings etc, nothing I can see is untoward.

    I’ve tried with Mixed content fixer on admin panel turned on and off, same problem.

    The final odd thing is that if I click on a post from the dashboard homepage, under the Recently Published tab, I can view and edit that post.

    Totally stumped.

    #74648 Reply

    Mark Wolters

    Hi Yvonne,

    What version of WordPress are you using? Have you yet tried to switch to another theme? We have encountered this issue in the past where the theme was causing this, quickly switching to another theme to check if the issue is also occurring there is enough.


    #74656 Reply


    Hi Mark

    Yes, I tried that, and even with a default WordPress theme active, I still have the same problem. Tried in both Safari and Chrome. I can’t help but think I’m missing something obvious, but, well, yes, Im missing it, whatever it is.

    #74769 Reply

    That message points to a WordPress permissions issue.

    To rule out the secure cookies settings as a possble cause, you can try if you also have this issue when the pro plugin is deactivated.

    #74845 Reply



    OK, tried with pro deactivated, and then basic deactivated too. Cleared cookies etc and logged back in, but I still have same problem. I’ve now reactivated as I need the site secure because of the donation page.
    I’ve only added 2 plugins recently, the Charitable one, which came first, and new/edit posts was still working after that was added, then a day later, Really Simple SSL.
    Later I will try deactivating both and see if functionality returns, but if anyone has other ideas in the meantime, I’d love to hear them.

    #74854 Reply


    Oh fff….. am I allowed to swear? Missing something obvious….

    OK, so I ran Charitable in test mode until I had SSL sorted, at which point it went live. My last test with both fully operational was an actual real donation…. I have just been into the User panel and noticed I was showing as a ‘donor’ as well as ‘administrator’. So, as there seems to be no way to remove the ‘donor’ I created myself a new admin only log-in and bingo, new posts all back and working on that log in.
    So, basically, whilst it looked like simple SSL was causing the problem, it wasn’t, I am soo sorry!! Feeling a bit blond now 🙁

    Many thanks for your help anyway, apologies if I’ve had you scratching your heads.

    #74862 Reply

    No problem, great it’s solved!

    #163094 Reply


    I installed the Really Easy SSL plug-in and lost the ability to edit pages.

    I deactivated the plug-in, deleted it, and reinstalled the current version of WordPress.

    I still can’t edit pages.

    The website itself now appears as not secure, but the WP admin pages indicate that they’re secure.

    How can I get page editing capability back?

    #163136 Reply

    Hi Dick,

    If you’re using some sort of pagebuilder, the pagebuilder may be having a javascript error if it tries to load the javascript over http. You can check this by looking for errors in your console. Right click on the screen, then click “inspect element”, “console”.

    #163650 Reply


    Perhaps I asked the wrong question. Having de-activated and deleted Really Easy SSL, and having reinstalled the current version of WordPress, I thought I’d be back to where I started.

    But I’m not. I still can’t use either WordPress’s visual editor or the editor in the Divi theme on the site.

    If I right-click on the screen and look at inspect element, the console window is blank.

    How do I get rid of whatever remains of Really Easy SSL so that I have a clean WordPress again?

    #163710 Reply

    Mark Wolters

    Hi Dick,

    deactivating Really Simple SSL via the plugins overview will undo all changes that have been made by Really Simple SSL. If the editor doesn’t work, there’s possibly something else that’s causing your issue. I’d suggest to start by clearing all caches the site uses, including the Divi builder one as described here: https://really-simple-ssl.com/knowledge-base/mixed-content-when-using-divi-theme/

    #165048 Reply


    I cleared the Divi cache, but that didn’t make any difference.

    As it stands, neither of the visual editors works, and even if I edit a page using html, the preview function doesn’t work, either.

    I’m a WordPress user, not a guru, and my knowledge of WP’s internals doesn’t go much deeper than the user interface. I have no idea what other caches the site uses.

    I’m at the point where I think my only way out is to hire a professional to clean up the mess that Really Easy SSL made.

    #165097 Reply

    Hi Dick,

    As you deactivated Really Simple SSL, and still have this issue, the issue won’t be caused by Really Simple SSL, but by your site being on SSL. This is an important difference, which is not always clear to users as activating Really Simple SSL will also move your site to SSL. Moving back your site to http will probably revert everything to normal.

    As you mention your site runs on https, but you deactivated Really Simple SSL, I would check if your site_url and home_url are https. If this is not the case, setting these URL’s to https might help, as this should tell the pagebuilders to load the URL’s over https.

    The issue you are experiencing is caused by the pagebuilder still trying to load javascript over http, which is then blocked by the browser. I would recommend to try using a different browser, to make sure you’re not using any cached resources.

    The plugin does not make any permanent changes to your site. The only changes that are made will be rolled back when you click the “deactivate” link in the plugins overview. To check all possible changes, you can check the manual uninstall instructions:

    If you check the developer console in your browser when loading the pagebuilder, you will probably see some console errors regarding the javascript files. If you post them here, we can take a look. Or you can submit a support ticket and we can discuss this directly.

    #166081 Reply


    Both the website proper and the WordPress console appear to be running just http, but the problem persists. I learned about the problem when our content editor reported it to me. Firefox is my default browser, but I checked on Chrome and on my laptop, which has just had a clean Windows 10 install. No visual editors anywhere.

    If I interpret things correctly, there should no longer be a problem with Javascript if everything is http and there’s no mixed content.

    The developer console remains empty.

    I think it would be better to work this as a trouble ticket. I’d like to send you a screenshot so you can see what I’m seeing.

    #166090 Reply

    Hi Dick,

    I’ve answered your ticket with request for more info, we’ll take it from there.

    #204491 Reply


    Edit Posts Not Working After SSL Update.
    Hallo, na aanbeveling heb ik jullie Really Simple SSL certificaat gedownload en opgeladen.
    Alles werkt naar behoren behalve dat ik de pagina’s niet meer kan bewerken? Ik heb jullie vraagbaak over andere soortgelijke problemen gelezen echter zit hier niet de oplossing voor mij tussen?

    Moet ik bepaalde links in bepaalde opgeladen documenten (fia FTP) wijzigen van Http naat Https?

    Bedankt voor jullie reactie alvast.

    #204545 Reply

    Hallo Jeroen,

    Really Simple SSL is geen SSL certificaat, dus het kan goed zijn dat je probleem veroorzaakt wordt door het ontbreken van een geldig certificaat.

    #204642 Reply


    Hi Rogier,

    Ok dat was mij niet geheel duidelijk ik was in de veronderstelling dat dat juist een SSL certifcaat was.
    Enfin, ik moet nu dus nog een SSL certificaat kopen. Kunnen jullie mij een aanbieder adviseren die goed samenwerkt met jullie plugin?


    #204819 Reply

    Mark Wolters

    Hallo Jeroen,

    we raden aan om een SSL certificaat bij je hostingprovider te halen, zij hebben toegang tot de server en kunnen het certificaat voor je installeren. Dit is meestal de makkelijkste en snelste manier.


    #228396 Reply

    Stuart Boyd

    Hi, I change my wordpress admin website URL from http to https before I had uploaded correctly the SSL certificate. Now I have been locked out of WordPress and the website is not responding. It shows this error ERR_SSL_PROTOCOL_ERROR.

    Is there any way I can simply reverse saving the https as the URL?

    Access to WordPress Admin again?

    #228399 Reply

    Mark Wolters

    Hi Stuart,

    you can disable SSL by running the built-in force-deactivate script. For instructions please see https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/. Running that script will revert the site back to http://.


    #232368 Reply


    Ik heb 2 formulieren actief staan op deze website. Beiden werken goed totdat ik via ‘Really simple SSL’ de website overzet naar Https. Dan krijg ik 2 verschillende foutmeldingen. Beide de ene dat de waarde niet goed is en bij de andere een Ajax melding.

    Nadat ik de plugin activeer, update ik ook de permalinks. Maar dat maakt geen verschil. Is er iets dat ik over het hoofd zie? Voor nu draait de website weer onder http.

    Graag een reactie.

    #232395 Reply

    Mark Wolters

    Hallo Miriam,

    op welke site ervaar je dit precies? Het zou mogelijk kunnen zijn dat een van de formulieren nog http:// links gebruikt, dan lost het legen van de cache het probleem meestal op.

    #241321 Reply


    I used really simple ssl to push my website to https but now i cant edit my pages on wordpress. the site loads ok but doesnt have the media in the background. the console in inspect element shows some error.. I am pating the erors below… how can i fix it?

    Media resource https://ga-dubai.com/wp-content/uploads/2019/06/sample-mov-upload.mp4 could not be decoded. ga-dubai.com
    All candidate resources failed to load. Media load paused. ga-dubai.com
    Media resource https://ga-dubai.com/wp-content/uploads/2019/06/sample-mov-upload.mp4 could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005)
    Details: mozilla::MediaResult __cdecl mozilla::WMFVideoMFTManager::ValidateVideoInfo(void): Can’t decode H.264 stream because its resolution is out of the maximum limitation

    #241363 Reply

    Hi Shalini,

    This might be due to caching. I just tried your site and it loads fine. Please try to clear your browser cache, and check if this helps.

Viewing 30 posts - 1 through 30 (of 30 total)
Reply To: Edit Posts Not Working After SSL Update
Your information: