[Support request] CPU Usage 100%, Entry Processes 37/40

Home Forums General issues CPU Usage 100%, Entry Processes 37/40

This topic contains 3 replies, has 2 voices, and was last updated by  Mark Wolters 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #160281 Reply

    Pc3400o
    Participant

    Hello!

    I had a problem with one my website where I sue Really Simple SSL. And Would like to ask you about help because this site and your plugin kill my hosting. I always have CPU Usage 100%, Entry Processes 37/40 and in the RAW file this site start ion every second an entry process.

    When I switch off Really Simple SSL and delete my cache everything is okay.

    So I don’t know what happend but on my other sites works well your plugin.

    Todaya I checked my .htaccess file while your plugin was working.
    But I didn’t find in .htaccess file any changes.

    My options in .htaccess file are:

    # STRONG HTACCESS PROTECTION
    <Files ~ “^.*\.([Hh][Tt][Aa])”>
    order allow,deny
    deny from all
    satisfy all
    </Files>

    # BEGIN WordPress – Kiszedtem, hátha ez megoldja a Really Simple SSL tömeges lekérés áradatát
    #<IfModule mod_rewrite.c>
    #RewriteEngine On
    #RewriteBase /
    #RewriteRule ^index\.php$ – [L]
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule . /index.php [L]
    #</IfModule>
    # END WordPress

    # BEGIN GZIP
    <ifmodule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript
    </ifmodule>
    # END GZIP

    # BEGIN EXPIRES – régebbi
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault “access plus 10 days”
    ExpiresByType text/css “access plus 1 week”
    ExpiresByType text/plain “access plus 1 month”
    ExpiresByType image/gif “access plus 1 month”
    ExpiresByType image/png “access plus 1 month”
    ExpiresByType image/jpeg “access plus 1 month”
    ExpiresByType application/x-javascript “access plus 1 month”
    ExpiresByType application/javascript “access plus 1 week”
    ExpiresByType application/x-icon “access plus 1 year”
    </IfModule>
    #END EXPIRES

    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>

    # BEGIN – Wp-config fájl védelme
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    # END – Wp-config fájl védelme

    <ifModule mod_headers.c>
    Header set Connection keep-alive
    </ifModule>
    <FilesMatch “\\.(js|css|html|htm|php|xml)$”>
    SetOutputFilter DEFLATE
    </FilesMatch>

    I am not an expert:
    It is possible that some options are the problem.

    I wait for your help.

    Thanks,

    Norbert

    #160319 Reply

    Mark Wolters
    Keymaster

    Hi Norbert,

    sounds like this might be a server issue, Really Simple SSL shouldn’t use that much resources. You could try to disable the mixed content fixer in the plugin setting temporarily to see if that solves the issue. If you use the pro plugin, you can check if the scan is stuck. Otherwise I’d suggest to contact your hosting company about this issue.

    Mark

    #160529 Reply

    Pc3400o
    Participant

    Hi Mark,

    First of all: Thanks for your fast answer.

    It is an interesting case because we stopped firstly every plugins in this site.
    And it works well, when I switched on your ssl the site kill the CPU.
    I use kill processes but in every second it satrted new processes.

    I had some consulatation eith hosting company but this not their fault.
    We have more hosting in this comapny and others work well.
    If I switced off you plugin it solve the problem.
    But because Google, seo we want to use it.

    Where change your plugin things to do ssl?
    Because I edit the htaccess file but I didn’t find any changes?
    (In my opinion my .htaccess configuration fight with yours.)
    Or how can I do ssl manually?
    Or for the worst scenario: How can I do the site ssl without your plugin?

    Thanks for your answer and help,

    Regards,

    Norbert

    #160866 Reply

    Mark Wolters
    Keymaster

    Hi Norbert,

    Really Simple SSL will do a number of things upon activation, it will change your home- and site-url to https://, fix mixed content by taking the contents of your webpage and replacing http:// to https:// using php’s string replace function and it will add a redirect to https://. The only function of Really Simple SSL that can possibly cause this is the mixed content fixer, however that seems unlikely since it doesn’t have much of an impact in regards to site speed. You can try to disable the ‘Mixed content fixer’ option to see if that resolves your issue, if it doesn’t, there might be another SSL process interfering with your servers resources.

    The .htaccess redirect is disabled by default but can be enabled by enabling the ‘301 .htaccess redirect’ option in the plugin settings.

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: CPU Usage 100%, Entry Processes 37/40
Your information: