Config with Cloudflare FlexibelSSL and WP Rocket / SSL Lock disappear / appear..

Home Forums General issues Config with Cloudflare FlexibelSSL and WP Rocket / SSL Lock disappear / appear..

This topic contains 9 replies, has 2 voices, and was last updated by  Sally 8 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #30088 Reply

    Sally
    Participant

    Hello,

    WP Rocket recommend Really Simple SSL to redirect from http to https. I installed the Plugin set redirect to auto and checked testpage:

    SSL test page
    This page is used purely to test for ssl availability.
    #LOADBALANCER#

    #SUCCESFULLY DETECTED SSL#

    I get the Load Balancer message, but this is added with the plugin:

    BEGIN rlrssslReallySimpleSSL rsssl_version[2.5.11]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    The Problem is that the ssl lock appear / disappear .. checked my website regarding mixed content and the links / Images seems fine ..

    Also what is strange, that redirection seem not to work on Homepage URL:

    http://lemontrend.com is redirected to https://lemontrend.com
    https://lemontrend.com is redirected to https://lemontrend.com
    http://www.lemontrend.com -> Error to many Redirects
    https://www.lemontrend.com -> Error to many Redirects

    When i to the Test with my Category Pages it works:

    Like when opening https://lemontrend.com/fashion/ i can open with http / https / www and get proper redirected to https.

    Can you please let me know what i have to adapt, to get really simple ssl plugin work ?

    Thx
    Best regards
    Sally

    #30092 Reply

    The www domain is being redirected back to http://, which causes a redirect loop. This redirect can be a custom redirect you added, or it might be CloudFlare redirecting. Maybe you need to add a page rule on CloudFlare:

    My website is in a redirect loop

    Mixed content: this image:
    http://mproxy.banner.linksynergy.com/fs/banners/36828/36828_202.jpg

    causes the mixed content. When the page is reloaded, it seems to load over https after all, but not at first. So maybe the ad script has a bit of a problem with the SSL.

    #30094 Reply

    Sally
    Participant

    Hi Rogier,

    thanks for the Info.

    Best regards
    Sally

    #30278 Reply

    Sally
    Participant

    Hi Rogier,

    when i check the redirect i get the following results:

    >>> http://lemontrend.com

    > ——————————————–
    > 200 OK
    > ——————————————–

    Status: 200 OK
    Code: 200
    Date: Mon, 20 Mar 2017 20:14:24 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: close
    Set-Cookie: __cfduid=d821809ca95dc7319c47826f715a71e7e1490040864; expires=Tue, 20-Mar-18 20:14:24 GMT; path=/; domain=.lemontrend.com; HttpOnly
    Vary: Accept-Encoding
    Last-Modified: Mon, 20 Mar 2017 19:37:08 GMT
    Cache-Control: max-age=0
    Expires: Mon, 20 Mar 2017 20:14:24 GMT
    X-Powered-By: PleskLin
    MS-Author-Via: DAV
    X-Content-Type-Options: nosniff
    Server: cloudflare-nginx
    CF-RAY: 342b566803ec35f0-LHR

    Check your URL redirect for accuracy. Do you use search engine friendly redirections like to many redirects or do you loose link juice for seo by redirects using HTTP Statuscode 301 vs. 302. Check now!

    Error: no URLs found.

    Normally http should responde with 301 not with 200 ok, and also https should responde..

    What are the settings for your plugin, to get the correct redirection?

    Thx
    Sally

    #30280 Reply

    In settings/ssl, you will find the current settings. By default WordPress redirect is added, but in some cases this does not force the redirect. In that case you can enable the .htaccess 301 redirect, which is preferable as it is faster as well.

    #30281 Reply

    Sally
    Participant

    Have enabled this setting already, please debug log

    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site** Detecting configuration **
    plugin version: 2.5.11
    Already on SSL, start detecting configuration
    ssl type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://lemontrend.com/vxxxxxx/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    retrieving redirect rules
    single site or networkwide activation
    converting siteurl and homeurl to https

    #30282 Reply

    Can you post the .htaccess? The settings look good.

    #30286 Reply

    Sally
    Participant

    Can i send you the htaccess via eMail also?

    Sally

    #30350 Reply

    Sure, you can send it at support (at) really-simple-ssl.com

    #30375 Reply

    Sally
    Participant

    Hi Rogier,

    thanks Files send.

    Regards
    Sally

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: Config with Cloudflare FlexibelSSL and WP Rocket / SSL Lock disappear / appear..
Your information: