Forum | Really Simple SSL

Can’t fix mixed content

Home Forums Mixed content in my site Can’t fix mixed content

  • This topic is empty.
Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #56452
    Jackie Goldstein
    Guest

    I am moving my web sites to httpS and am using the Really Simple SSL plugin
    I see to still have a fixed content issue that I am trying to resolve – on my site eng.beithillel.org.il I have a problem that I have narrowed down to the code in the last sidebar widget.

    When I test the individual links in this code, they are displayed as secure. But still on my site displayed as ?

    Any help would be greatly appreciated. Thanks!

    #56607
    Rogier
    Keymaster

    Hi Jackie,

    I checked your site, and I get the green lock. Did you clear your browser cache?

    #56633
    Jackie Goldstein
    Guest

    Hi Rogier,

    Thanks for the quick response.

    I was able to locate and fix the problem after posting in the forum. But since it was not yet approved/published, I couldn’t update it to say that I fixed it.

    Jackie

    #73846
    Jolanda van Groningen
    Guest

    Hello Rogier,

    I have https on my website and am also using the Really Simple SSL plugin.There is still one image thats with http thats causing the bug.I found the http, and don’t know how to fix the problem. So the green lock won’t show. I see fixed content issue and removed the image from my website.

    Can you please help me?

    Greets,
    Jolanda van Groningen
    The Netherlands

    #74146
    Mark
    Keymaster

    Hi Jolanda,

    can you give us your site address? Then we’ll have a look to see what the issue might be.

    Mark

    #74701
    Vera Greif
    Guest

    Hi
    i am using Really Simple SSL Pro, but my problem with mixed content is still there. In DevTools i have found the problem in the source code, but i can´t edit the code and fix it. Can you help me please?
    Please visit http://www.sozialdienst-germering.de.

    Mixed Content: The page at ‘https://www.sozialdienst-germering.de/’ was loaded over HTTPS, but requested an insecure image ‘http://https//www.sozialdienst-germering.de/wp-content/uploads/2016/07/logo55px.png’. This content should also be served over HTTPS.
    (index):1023

    Mixed Content: The page at ‘https://www.sozialdienst-germering.de/’ was loaded over HTTPS, but requested an insecure image ‘http://https//www.sozialdienst-germering.de/wp-content/uploads/2016/07/logo55px.png’. This content should also be served over HTTPS.

    Vera

    #74768
    Rogier
    Keymaster

    H Vera, can you send us the output of the scan? That is helpful so we can see where these images are loaded.

    #74860
    Vera Greif
    Guest

    Hi Rogier,
    sorry, but i dont´t know what you mean with output of the (what?) scan.
    This ist the wrong link: http://https//www.sozialdienst-germering.de/wp-content/uploads/2016/07/logo55px.png in the source code. View the source code view-source:https://www.sozialdienst-germering.de/ line 1016 and 1028.

    Thanks a lot,
    Vera

    #74861
    Rogier
    Keymaster

    Hi Vera, as pro user you have a new tab with the scan option: you can find it in settings/ssl/scan.

    #74873
    Vera Greif
    Guest

    Here is the result of the full scan. Deactivated caching ans security plugins.
    All green.

    Blocked url’s
    No references to domains without ssl certificate found.

    CSS and JS files with mixed content
    No references to domains without ssl certificate found.

    CSS and JS files from other domains with mixed content
    No CSS and JS files on other domains with mixed content.

    Posts with blocked resources
    No posts found that contain references to domains without an SSL certificate.

    Widgets with blocked resources
    No posts found that contain references to domains without an SSL certificate.

    Database tables with blocked resources
    No references to blocked resources found within the database.

    Fehlersuche – Protokoll:
    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.24
    Already on SSL, start detecting configuration
    ssl type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://www.sozialdienst-germering.de/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    settings page, or network admin, updating htaccess…
    retrieving redirect rules
    starting insertion of .htaccess redirects.
    single site or networkwide activation
    converting siteurl and homeurl to https

    Best regards,
    Vera

    #74876
    Rogier
    Keymaster

    An, I see. Because the domain is not a valid domain, it does not get picked up by the scan, so you can’t use the fix button for this.

    In your site you have this URL:

    http:https://www.sozialdienst-germering.de/wp-content/uploads/2016/07/logo55px.png

    If you remove the first part, (http:) the URL is valid. But… If I enter this URL:
    https://www.sozialdienst-germering.de/wp-content/uploads/2016/07/logo55px.png

    I get a not found. So it seems the image is not there anymore. In that case I would just remove it.

    As it is in a class called “logo-default”, I would expect it to be in your theme logo settings. Let me know if this helps!

    #74878
    Vera Greif
    Guest

    I know the problem with the url. But my problem ist, how i can get into the source code to edit it.

    #74883
    Rogier
    Keymaster

    The source code is created based on your theme settings. I can’t say for sure, but based on the html markup of this image, I expect it to be located in your theme settings, where you upload the logo. If you can’t find it, you can send your wp admin login in the support form, so we can take a look.

    #85978
    Alvaro
    Guest

    Hi there.

    I have a problem with my SSL certificate, The mixed content fixer is activated, but was not detected on the frontpage. The thing is that I can see the green lock on my website on my laptop but when I go through with my smarthphone it pop up an alert message with the text “your connection is not private”

    How can I fix this?

    Thank you.

    #85981
    Rogier
    Keymaster
    #87482
    Caio
    Guest

    Hello,
    i tried to configure ssl whit the plug-in and after doing all the expesions and tutorials as possible i keep having this on the settings:

    success SSL is enabled on your site.
    error The mixed content fixer is active, but was not detected on the frontpage. Please follow these steps to check if the mixed content fixer is working. Instructions
    success An SSL certificate was detected on your site.
    success 301 redirect to https set: WordPress redirect

    please help, i don´t know what to do.

    #87489
    Rogier
    Keymaster

    Hi,

    What exactly have you tried? Do you have any issues on the front-end? Did you follow the steps in this article?
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

Viewing 17 posts - 1 through 17 (of 17 total)
  • The topic ‘Can’t fix mixed content’ is closed to new replies.

Subscribe