Forum | Really Simple SSL

Can't enable per site on Multisite with domain mapping

Home Forums Multisite Can't enable per site on Multisite with domain mapping

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #913
    Trevor
    Guest

    Hi,

    I’ve been trying to get your plugin to work without success. I suspect it’s something in my server configuration and not your plugin, but after much Googling and messing with the htaccess, etc., I’m no further along so I’m hoping you may have a suggestion. Anyway, here’s the details:

    1.I’m operating a subdomain multisite installation with domain mapping.
    2. I did NOT “network enable” your plugin…I want to enable it on a per-site basis, although I do intend to install SSL on all my sites, eventually.
    3. I’m trying to enable the plugin on the “host” domain of cyberboss.ca.
    4. I have iThemes security “network enabled.”
    5. I’m on shared hosting with a LiteSpeed server.
    6. I tried to force the ssl because I know I have it.

    Here is the debug log from the settings page:
    pluginurl: http://cyberboss.ca/wp-content/plugins/really-simple-ssl/
    building domain list for multisite…
    ** Detecting configuration **
    plugin version: 2.3.1
    Opening testpage to check for ssl: https://cyberboss.ca/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    No ssl detected. the ssl testpage returned an error: FORBIDDEN
    — force ssl: TRUE
    ssl not enabled, show noticepluginurl: http://cyberboss.ca/wp-content/plugins/really-simple-ssl/

    However, if I go to https://cyberboss.ca/wp-content/plugins/really-simple-ssl/ssl-test-page.php directly, this is what is returned:
    SSL test page

    This page is used purely to test for ssl availability.

    #SERVER-HTTPS-ON# (on)
    #SERVERPORT443#

    #SUCCESFULLY DETECTED SSL#

    HTTP_HOST: cyberboss.ca
    REQUEST_URI: /wp-content/plugins/really-simple-ssl/ssl-test-page.php

    Obviously, the FORBIDDEN being returned from the admin settings page is a problem. Any help would be appreciated.

    Best,
    Trevor

    #914
    Trevor
    Guest

    Update: I got it working using the JavaScript option, but I’d rather use the htaccess, if possible. It seems like the plugin in unable to make the changes it requires.

    Here’s the debug info (I’m now activating ssl for two sites):
    pluginurl: https://inspirerejuvenation.ca/wp-content/plugins/really-simple-ssl/
    building domain list for multisite…
    adding: https://cyberboss.ca
    adding: https://inspirerejuvenation.ca
    ** Detecting configuration **
    plugin version: 2.3.1
    Opening testpage to check for ssl: https://inspirerejuvenation.ca/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    We do have ssl, but the testpage loaded with an error: FORBIDDEN
    ssl type: NA
    — force ssl: FALSE
    Check for Mixed Content detection failed
    ** Configuring SSL **
    checking if .htaccess can or should be edited…
    per site activation or hsts option change, updating htaccess…
    converting siteurl and homeurl to https

    I looked in PHPMyAdmin, and the plugin is NOT changing my site and home url to https in the database. Also, here’s my .htaccess:
    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.3.1]
    # END rlrssslReallySimpleSSL
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Notice that it can write to the file, but it’s not putting any changes in.

    Best,
    Trevor

    #915
    Rogier
    Keymaster

    Hi,

    Because the plugin can’t reach the test page, it can’t deduce what redirect rule to use. That’s why your .htaccess is still empty. It is strange your homeurl are not changed.

    Do you have some security plugin that might block the plugin from reaching the testpage?

    You could add the redirect yourself, and change the url in the settings to https.

    Redirect rules for the .htaccess based on your testpage:
    RewriteCond %{HTTP_HOST} ^domain-1.com [OR]
    RewriteCond %{HTTP_HOST} ^www.domain-1.com [OR]
    RewriteCond %{HTTP_HOST} ^domain-2.com [OR]
    RewriteCond %{HTTP_HOST} ^www.domain-2.com
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘Can't enable per site on Multisite with domain mapping’ is closed to new replies.

Subscribe