[Resolved] Broken Media Library with enabled SSL Plugin

Home Forums General issues Broken Media Library with enabled SSL Plugin

This topic contains 16 replies, has 4 voices, and was last updated by  Mark Wolters 1 month, 2 weeks ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #73777 Reply

    Savas

    Hi everyone,

    maybe someone might be able to help me in this regard.

    So, my WordPress is running with Let’s Encrypt SSL certificate, whole server runs fine. Blog itself works, images are shown, no mixed-content errors.

    But, the media library stays empty in that every image triggers a 403 Access Denied. But only in the media library, not in blog posts.
    Disabling the plugin and the media library works flawlessly.

    I already saw several posts of .htaccess configuration, hot linking etc. but nothing worked out and I am pretty much out of ideas how to solve this issue.

    Maybe someone has an idea how to figure this out.

    Thanks a lot in advance

    #73782 Reply

    Mark Wolters
    Keymaster

    Hi Savas,

    if I understand you correctly the images from the media library are visible when used in posts, but not when accessing them directly through the media library?

    It’s likely there’s some configuration active that is blocking the images from showing on SSL. Like you said, this is usually caused by either hotlink protection or a .htaccess configuration. If you’d like, you can send us your .htaccess file via https://really-simple-ssl.com/support/ so we can have a look. Can you check the /uploads/ folder permissions as well?

    Mark

    #73788 Reply

    Savas

    Hey Mark,

    yeah, the .htaccess I deleted/renamed already to rule it out.
    uploads/ I changed to 777 temporarily, to circumvent any issues here, too.

    Same thing: Media Library empty with many 403 errors.

    Best

    #73958 Reply

    Mark Wolters
    Keymaster

    Hi Savas,

    have you also tried to clear your browsers cache / using another browser to check if the issue also occurs there? Do you use a regular WordPress installation or a multisite? And what WordPress version are you using?

    Mark

    #74649 Reply

    insanitydesign
    Participant

    Hey Mark,

    Wordpress is up-to-date 4.9.2 and I deleted my cache as well as different browsers/incognito modes.

    It is a regular site installation. Just my one site.

    Thanks

    #74654 Reply

    Mark Wolters
    Keymaster

    Hi Savas,

    is it possible to temporarily disable all plugins (except Really Simple SSL) and switch to a default theme to check if the issue persists?

    Mark

    #74655 Reply

    insanitydesign
    Participant

    Hey

    Just tried. All plugins disabled but ReallySimpleSSL, then logged in in incognito mode and MediaLibrary hat the same 403.

    Sorry

    #74767 Reply

    It’s very hard to say without seeing the actual problem. If you contact us through the support form, and send us the wp login, we can take a look and see if we can find what is going on.

    #75331 Reply

    Mark Wolters
    Keymaster

    There was a .htaccess file in the /wp-content/uploads/ folder only allowing connections over http://, changing the http:// in https:// should solve the issue.

    Mark

    #114491 Reply

    Serena

    Just wanted to say that I had this same issue after installing an SSL certificate. I am using Really Simple SSL and was also getting the 403 image errors. However, Mark’s final comment about the .htaccess file in the /wp-content/uploads/ folder fixed my issue! Thank you!

    #126725 Reply

    fredy

    MArk, tuve ese problema de que las imagenes no se pueden ver en multimedia de wordpress, pero abri el archivo que indicas en tu ultimo comentario y modifique los http a https y se soluciono.
    gracias

    #139477 Reply

    John Dehnel

    I switched to https: using really simple SSL. Many (most) of the images on the site have disappeared. Switching back to http: hasn’t helped. Any ideas please?

    #139547 Reply

    Mark Wolters
    Keymaster

    Hi John,

    strange, reverting back to http:// should undo all changes that Really Simple SSL has made, reverting the image links back to their original state. On what domain are you experiencing these issues?

    #139742 Reply

    John Dehnel

    Many images have apparently disappeared from the media library (but not all of them). They no longer appear on the lives pages. But when I go in to edit the pages the images are still there. For example the home page should have pictures under the words “serving communities … worldwide”
    I’m using WordPress.

    #139748 Reply

    Mark Wolters
    Keymaster

    Hi John,

    can you provide me with your site address? That way I can check quickly if something is off on the front end of the site.

    If some images do show in the media library, and some don’t, this might be caused by a security setting. It could be that hotlink protection is enabled in your hosting control panel for some file extensions, see (https://documentation.cpanel.net/display/74Docs/Hotlink+Protection). Another possibility would be an .htaccess file in your /wp-uploads/ folder, only accepting http:// connections for some file types. This would explain why some images show and others don’t, they might have a different file type. Can you open your browsers Developers Console both on the front-end of your site and in the media library to check for any errors? You can find how to open the Developers console here: https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/.

    Mark

    #139750 Reply

    John Dehnel
    #139752 Reply

    Mark Wolters
    Keymaster

    Hi John,

    I don’t see any mixed content errors on the front end, however there seems to be an issue with a minified stylesheet generated by Divi. Can you follow the steps described in this article to see if that resolves your issue? https://really-simple-ssl.com/knowledge-base/mixed-content-when-using-divi-theme/

Viewing 17 posts - 1 through 17 (of 17 total)
Reply To: Broken Media Library with enabled SSL Plugin
Your information: