Home Forums General issues Blank page after plugin activation

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #45374 Reply
    Max
    Guest

    Hi there!

    First of all thanks for the great plugin. 🙂

    I’m trying to migrate my website, i have been using Really Simple SSL previously and want to activate it again on my new server. But when i activate the plugin i get a white loading screen and nothing happens. On the wp-admin and the website as well. It loads pretty quickly after deleting the plugin via FTP.

    How to get SSL up and running again?

    Thanks in advance!

    #45376 Reply
    Rogier
    Keymaster

    Hi Max,

    Do you mean this happens before you even click “enable SSL”?

    I haven’t seen this behaviour before. Is it possible that not all plugin files are available? Can you try to download a fresh copy of Really Simple SSL, then activate again?
    What PHP version and WordPress version do you use? What is the version of Really Simple SSL?

    If that doesn’t help, I’ll need the debug log:

    Add this to your wp-config.php:

     define('WP_DEBUG', true);
     define('WP_DEBUG_DISPLAY', false);
     define('WP_DEBUG_LOG',     true);

    And replace
    define('WP_DEBUG', false);

    Than you should get a debug.log in your wp-contents.

    #45399 Reply
    Max
    Guest

    Hi Rogier,

    Thanks for the very quick reply!

    Here is my debug log. I see a lot of errors with the WP Super Cache plugin, so i tried to delete the cache, disable caching and deleted the plugin, but nothing worked.

    [25-Jul-2017 15:13:03 UTC] PHP Warning: require_once(/home/admin/domains/domein.nl/public_html/wp-content/plugins/really-simple-ssl//class-front-end.php): failed to open stream: No such file or directory in /home/admin/domains/domein.nl/public_html/wp-content/plugins/really-simple-ssl/rlrsssl-really-simple-ssl.php on line 95
    [25-Jul-2017 15:13:03 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home/admin/domains/domein.nl/public_html/wp-content/plugins/really-simple-ssl//class-front-end.php’ (include_path=’.:/usr/local/lib/php’) in /home/admin/domains/domein.nl/public_html/wp-content/plugins/really-simple-ssl/rlrsssl-really-simple-ssl.php on line 95

    #45402 Reply
    Rogier
    Keymaster

    Trimmed the log a bit 😉

    Can you check if the file “class-front-end.php” is there in the plugin folder?

    #45403 Reply
    Max
    Guest

    Yes, it’s there! I download the plugin fresh from the plugin directory.

    #45404 Reply
    Rogier
    Keymaster

    I notice there’s an additional slash in the path. I haven’t encountered any issues with this, but maybe this is a problem on your server. So I’ve fixed it in this file:
    https://github.com/rlankhorst/really-simple-ssl/blob/master/rlrsssl-really-simple-ssl.php

    Can you replace this file in your site with this one to see if it fixes the issue?

    #45406 Reply
    Max
    Guest

    Thanks a lot!

    But still doesn’t work.. Keeps loading a white page directly after activating the plugin. Guess it’s something on my server indeed. Wonder what went wrong with the migration..

    #45407 Reply
    Rogier
    Keymaster

    The problem seems to be that the server can’t find the file. Can you check if the first part of the path is correct?
    home/admin/domains/domein.nl/public_html/

    #45408 Reply
    Max
    Guest

    Changed it a bit before posting here, but yes the path is correct.

    #45424 Reply
    Rogier
    Keymaster

    Reading on this thread:
    https://stackoverflow.com/questions/6996402/failed-opening-required

    It might be a user permission issue.

    #45598 Reply
    Rogier
    Keymaster

    Did you fix it in the meantime? Just noticed the errors on wp super cache are similar: these warnings also point to a permission or configuration issue:
    include_once(): open_basedir restriction in effect. File(….) is not within the allowed path(s):
    failed to open stream: Operation not permitted in …..

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: Blank page after plugin activation
Your information: