Forum | Really Simple SSL

Avoid landing page redirects

Home Forums General issues Avoid landing page redirects

  • This topic is empty.
Viewing 24 posts - 31 through 54 (of 54 total)
  • Author
    Posts
  • #131319
    Harvis
    Guest

    In my case

    http://alahas.com.do
    302 Found
    https://alahas.com.do/
    301 Moved Permanently
    https://www.alahas.com.do/
    200 OK

    Theres nothing in htacces that point to that 302 redirect also i have used really simple 301 redirect via htacces and still the 302 there. :/

    #131337
    Rogier
    Keymaster

    Possibly this is a redirect configured in your CPanel. If it’s not in the .htaccess I would look on the server configuration level.

    #135214
    Nimisha
    Guest

    Hi,

    My website GTMetrix score is 7seconds. And one of the major issues is Avoid landing page redirects which is grade F(32%). How should I fix it?

    Avoid landing page redirects for the following chain of redirected URLs.

    http://www.vaisselle.org/
    https://www.vaisselle.org/
    https://vaisselle.org/

    Nimisha

    #135255
    Mark
    Keymaster

    Hi Nimisha,

    long redirect times are often caused by your hosting provider. You can try to enable the ‘301 .htaccess redirect’ option in the plugin settings. The .htaccess redirect is generally the fastest redirect option and should improve the redirect speed. If that doesn’t improve your sites loading speed, you can contact your hosting provider about this issue.

    Having a redirect chain from http://www, https://www to https:// is not an issue. If users come in via the http:// domain there will only be one redirect to https://. You can set a preferred domain without in Google Webmaster Tools/Search Console. This will make sure that incoming organic traffic will be taken straight from the http:// to the https:// domain.

    Mark

    #136963
    mikaeil
    Guest

    Avoid landing page redirects for the following chain of redirected URLs.

    http://www.taksiz.org/
    https://www.taksiz.org/
    https://taksiz.org/

    #137295
    Mark
    Keymaster

    Hi Mikaeil,

    your redirect chain is normal and nothing to worry about. Really Simple SSL will redirect the first requests to https://, from http://www to https://www and then WordPress will redirect to the site address, which is https:// in this case. Visitors coming in on the non-www domain will be redirected to the https:// domain directly.

    Mark

    #146450
    devri adrian selano
    Guest

    How to set up so that the website redirect blogger doesn’t come out like this when I check using gmetrix or google page speed

    (Initial: http://jakwebs.com/)
    0 ms
    http://www.jakwebs.com 190 ms
    https://www.jakwebs.com 980 ms

    Will it affect website ranking?
    if anyone knows how to get out of this problem please help, thank you guys

    #146582
    Mark
    Keymaster

    Hi,

    the redirect chain you currently have is normal. To increase the redirect speed, you can try to enable the .htaccess redirect option. The .htaccess redirect is generally the fastest redirect available, that can increase the loading speed. If the redirect speed doesn’t improve, you can contact your hosting provider about this issue.

    Mark

    #162968
    Manu
    Guest

    Hi,

    Check your address in WordPress / general settings …

    WordPress address:

    https://6kteam.com

    Web address:

    https://6kteam.com

    Best Regards

    #200528
    Waqas
    Guest

    Really helpful

    #205334
    Anand N
    Guest

    I have the same problem.

    My site is PHP. How to resolve

    Avoid landing page redirects for the following chain of redirected URLs.

    http://parkinhost.com/
    https://parkinhost.com/
    http://www.parkinhost.com/
    https://www.parkinhost.com/

    #205387
    Mark
    Keymaster

    Hi Anand,

    see https://really-simple-ssl.com/knowledge-base/avoid-landing-page-redirects/ for code examples on how to change this.

    #213883
    Spasov
    Guest

    https://bambooapp.com- This is WordPress website.
    In .htaccess file, I tried to add snippet code which you provided above but the site is broken down.
    This is my .htaccess file content. I just want you to fix this.
    BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    #213955
    Rogier
    Keymaster

    I just checked your site, it redirects from
    http://www
    to
    https://www
    to
    https://

    Which is the secure and best practice redirect. So your site is configured correctly. For more information see this article:
    https://really-simple-ssl.com/knowledge-base/avoid-landing-page-redirects/

    To enable .htaccess, you can just use the .htaccess 301 redirect setting in settings/ssl, which will enable the best redirect for your site.

    #217818
    adsgurus
    Participant

    Same problem.
    I tested my site with GTmetrix.
    One of the anwers is :
    Avoid landing page redirects for the following chain of redirected URLs.

    http://ad1.in/
    https://ad1.in/
    https://www.ad1.in/

    Have you got an idea to solve the problem.
    Thanks for your help
    All the best

    #218043
    Rogier
    Keymaster

    As commented in the previous post, this is the correct redirect, it should not be changed. Please see the attached article for more info on why this is the correct redirect. If you still want to have a non best practice redirect, you can follow the instructions in that article.

    #222340
    Usman
    Guest

    I installed Really simple SSL I have the same issue according to google page speed.
    https://www.mansgazette.com
    https://mansgazette.com

    How to fix?

    #222341
    Rogier
    Keymaster

    Please read previous comment 🙂

    #232366
    Somnath Jadhav
    Guest

    I am facing similar issue on my website https://www.somnathjadhav.com/. I have enables HSTS, its still not resolved. Do I need to wait or I can do something?

    Please help.

    #232377
    Rogier
    Keymaster

    Hi Somnath,

    Have you read our replies to the previous commenters? In what way is your issue different?

    #268880
    Mateusz
    Guest

    Hello
    Thanks for all the replies above. You assure that the redirects make no difference to SEO, yet again seeing the ‘waterfall’ on GTMetrix is really worrying. The redirects take up to 1.36 seconds of the load time in my case. That’s half the time it takes to load the page.
    Similarly to the users above me, the result I get is:
    http://domain.pl/
    https://domain.pl/
    https://www.domain.pl/

    Is there any way to deal with that?

    Regards,
    Mateusz

    #268893
    Rogier
    Keymaster

    Hi Mateusz,

    A regular user won’t get a redirect, or at most once on the first visit. There will only be two redirects (as in your redirect chain) if the user explicitly types in the url both with http and without www (if the primary url is with www).

    Redirect on first visit:
    – if a user types in a http URL, the browser will remember the site should load over https.
    No redirect at all:
    – if a user clicks on a search result in a search engine they will get the https URL right away, so will net get any redirects.
    – If the site has enabled HSTS with preload

    If your redirection is slow, I would recommend to enable the .htaccess redirect, which is fastest, preferably with HSTS preload enabled.

    When you add to your site to the preload list, you will notice your request will be declined if you don’t have the recommended redirect chain.

    #272046
    Somnath Jadhav
    Guest

    Thank you. It could help me to solve the issue.

    #313515
    Mahabur Rahaman
    Guest

    I have successfully address plugins and it is very good working on my website.

Viewing 24 posts - 31 through 54 (of 54 total)
  • The topic ‘Avoid landing page redirects’ is closed to new replies.

Subscribe