Avoid landing page redirects

Home Forums General issues Avoid landing page redirects

This topic contains 20 replies, has 4 voices, and was last updated by  Mark Wolters 1 month, 3 weeks ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #15890

    Filname
    Participant

    Hello,

    I tested my site with GTmetrix.

    One of the anwers is :

    Avoid landing page redirects for the following chain of redirected URLs.

    http://mydomaine.com/
    https://mydomaine.com
    https://www.mydomaine.com

    Have you got an idea to solve the problem.

    Thanks for your help

    All the best

    #15903

    For a detailed explanation see this article:
    https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/

    If the redirects are 301 permanent, there should be no issue.

    Because Really Simple SSL aims for best practices, the redirect is handled so you can enable HSTS. If you redirect while “avoiding landing page redirects”, in other words, you redirect on in one go from http://domain.com to https://www.domain.com, you can’t use HSTS in a secure way, as explained in the article above.

    #15914

    Filname

    Thanks for your quick anwers. I keep Relly Simple SSL like this. it’s work vey well.

    Thank again for the precision brought

    Best Regards

    #23293

    Michel Luarasi

    Hello

    I got a similar problem here.

    Google PageSpeed Insights reported this chain of redirects:
    http://www.michelluarasi.com/work
    http://michelluarasi.com/work
    https://michelluarasi.com/work
    https://michelluarasi.com/work/

    Do you have an idea how to fix this?

    Thanks for your help.

    Best,
    Michel

    #23299

    As long as the redirects are 301 permanent, it should not be a problem: Google will use only the end result in the search results. But if you want you can add a redirect for each type of request to make it redirect directly to the primary domain.

    For example, a request for http://www.domain.com first redirects to the http://domain.com You can use the following instructions to make it redirect to https directly.

    https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/

    #23303

    Michel Luarasi

    Hello Rogier

    Thanks for your reply.

    The plugin seems to work fine. I had some other permalink and seo-plugin issues. My goal was to have a clean URL no “WWW” and no trailing “/” with the least possible redirects. It works now!

    Thanks a again,
    Michel Luarasi

    #39046

    Hafizie Jamaludin

    Hi i got some isssue, i dont mind redirection from http to https but what is bother me is this another one

    http://heaxabell.com/
    https://heaxabell.com/
    https://heaxabell.com/?v=0fd3f8dd5edc —-> what is this & How to remove this?

    #39087

    That looks like the geo plugin from WooCommerce. You can disable it in the WooCommerce settings I think.

    #43514

    Frank

    Hi Rogier,

    I’m facing the same issue as mentioned before, when i test my site speed it comes up saying that
    the http www moves to https www
    and the https www moves to https non www
    both 301 moved permanently

    I don’t understand how to avoid this and if I actually should
    My site doesn’t manage personal data but the email address in case someone leaves a comment

    Can you give me an advice in regard?

    Thanks for your help
    Frank

    #43517

    Mark Wolters
    Keymaster

    Hi Frank,

    I would advise to leave it the way it is. As long as the redirects are 301 permanent and done via .htaccess it doesn’t matter, since search engines will only use the latests result and the .htaccess redirect is very fast. For a more detailed explanation about why these redirects happen and instructions on how to bypass them you can use the following article:

    https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/

    Mark

    #47345

    Vitaliy Vinogradov

    Every 301 has around a 10% drop in link juice, I rather have 10% than 20% so is there a real fix or not?

    #47722

    Mark Wolters
    Keymaster

    Hi Vitaly,

    see the following article if you want to eliminate redirects: https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/.

    Mark

    #48319

    Margaret

    Hello everyone,

    I noticed these issues in GT Metrix:

    Avoid landing page redirects for the following chain of redirected URLs.

    http://www.arpa.gr/
    http://www.arpa.gr/
    arpa.gr/en/home___/

    This is my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    The customer who own this site, complains about site’s speed. I red the article you mentioned above, but I am not sure how to change the .htaccess file. Is it necessary? Whenever I make changes to .htaccess, the site brokes. Can you help me please?

    #48322

    Margaret

    I guess something gone wrong with my previous post..

    this is my .htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    www.arpa.gr/
    www.arpa.gr/
    arpa.gr/en/home___/

    The customer who own this site, complains about site’s speed. I red the article you mentioned above, but I am not sure how to change the .htaccess file. Is it necessary? Whenever I make changes to .htaccess, the site brokes. Can you help me please?

    #48544

    Mark Wolters
    Keymaster

    Hi Margaret,

    you seem to use a 302 redirect to redirect from the arpa.gr to apra.gr/en/home.

    arpa.gr
    302 Moved Temporarily
    arpa.gr/en/home___/
    301 Moved Permanently
    arpa.gr/en/home___/
    200 OK

    Using a 302 redirect is generally not advised. A 302 redirect means the redirect is temporary. It would be better if you use a 301 redirect for that as well. Have you tried enabling the ‘.htaccess redirect’ option in Really Simple SSL? That should add the right redirect to https:// automatically so you don’t have to change to .htaccess manually.

    Mark

    #48659

    Margaret

    Thank you for your answer.

    So, if I enable that option I should change the .htaccess back to default or it doesn’t matter?

    Margaret

    #48660

    Margaret

    Ok, so I followed these steps showed in this link

    https://really-simple-ssl.com/knowledge-base/remove-htaccess-redirect-site-lockout/

    but the site broke down.

    So I changed the settings back to what I had.

    What now…?

    #51359

    Margaret

    Hello again, please, any suggestions to my previous posts?

    #51370

    What I currently see: The redirect to https is a 301 redirect as it should, probably handled by Really Simple SSL. But there is a redirect prior to that, which is a 302 redirect, from http://arpa.gr/ to http://arpa.gr/en/home___/

    Depending on how you have set up your site, this might be caused by a plugin or by a .htaccess setting.

    Here are instructions how to redirect your domain, but as this redirect is not a Really Simple SSL redirect, I can’t say if this will work or if you need to disable this other redirect somehow.
    https://really-simple-ssl.com/knowledge-base/redirect-non-www-to-www-domains-in-htaccess/

    #57479

    Vale

    Hello, I need your help
    I have a strange situation, When I check Gtmetrix, Pingdom and Google speed test …
    All show that I have a 301 redirection
    Http//www.mysite.com/theme/library/images/disc.png
    1) I don´t have any image called disc.png in my media library
    2) I don´t have any .htacess redirection nor on CPANEL redirection feature.
    3) the EXPIRES on that image is Wed, 11 Jan 1984 05:00:00 GMT

    Server
    Apache
    Keep-Alive
    timeout=2, max=499
    Date
    Thu, 19 Oct 2017 20:26:45 GMT
    Connection
    Keep-Alive
    Vary
    Accept-Encoding,Cookie
    Cache-Control
    max-age=86400
    Content-Type
    text/html; charset=UTF-8
    Location
    http://mysite.com
    Transfer-Encoding
    chunked
    Expires
    Wed, 11 Jan 1984 05:00:00 GMT
    Request Headers
    Connection
    keep-alive
    Referer
    http://mysite/
    User-Agent
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.96 Safari/537
    .36
    Accept-Encoding
    gzip, deflate, sdch
    Accept
    image/webp,image/*,*/*;q=0.8
    Accept-Language
    en-US,en;q=0.8
    Host

    #57551

    Mark Wolters
    Keymaster

    Hi Vale,

    it’s hard to say what might be causing this without knowing your site address. Could you give me your url? Can you find the image in the console?

    Mark

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.