Activating plugin breaks site

Home Forums Really Simple SSL pro Activating plugin breaks site

This topic contains 26 replies, has 6 voices, and was last updated by  Mark Wolters 2 weeks, 5 days ago.

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #48849 Reply

    Bebe Kinnett
    Participant

    Installing and activating the pro plugin breaks the site http://caseysoutdoor.com/. Need some assistance here ASAP. I’ve sent an email to support but haven’t heard any response yet.

    #48901 Reply

    Mark Wolters
    Keymaster

    Hi,

    I did receive your first support request and sent a reply but it looks like something has gone wrong and you didn’t receive it.

    Breaking both the styling on the front and backend of your site is normal when you visit your site over [https://]https://. This is most likely caused by stylesheet still loading over [http://]http://. This can be fixed by activating the mixed content fixer and clearing any caches your site may use. If the mixed content fixer doesn’t work directly, you can try to enable the ‘Switch mixed content fixer hook’ option in the Really Simple SSL settings.

    #49144 Reply

    Alvis Togatovs
    Participant

    Hi just got premium version, in order to remove warning i Used

    Add this you your theme’s functions.php:

    add_action(“init”, “rsssl_dismiss_success_message”);

    function rsssl_dismiss_success_message(){

    $options = get_option(‘rlrsssl_options’);

    $options[‘ssl_success_message_shown’] = true;

    update_option(‘rlrsssl_options’,$options);

    }

    as suggested, but now the website has gone 4herogame.com

    this is the message
    Parse error: syntax error, unexpected end of file in /home7/forquizc/public_html/4herogame/wp-content/themes/myarcadetheme/functions.php on line 1040

    please i need help to fix this!

    #49156 Reply

    Alvis Togatovs
    Participant

    and you guys call it really simple ssl 😀

    #49157 Reply

    Alvis Togatovs
    Participant

    I have fixed this issue with my host by removing these line of codes

    #49986 Reply

    Bebe Kinnett
    Participant

    Your fix does not work.

    “This can be fixed by activating the mixed content fixer and clearing any caches your site may use. If the mixed content fixer doesn’t work directly, you can try to enable the ‘Switch mixed content fixer hook’ option in the Really Simple SSL settings.”

    I have two sites now that aren’t working. One is causing a redirect loop on all internal pages…and the other still breaks completely on activation no matter the settings.

    Is there someone I can actually speak to about this rather than communicate through the forum? I need to get this fixed ASAP because I have about 25 sites I need to convert before October.

    #50231 Reply

    Luc

    Hello
    I have a big problem when I activated the plugins
    my site to plan
    can not access the site nor a wordpress, I used a backup
    and this every time
    I have a ssl certificate from my supplier
    and during the scan: I have this error:
    The native WordPress function is_ssl () returned false

    the home page of my site is https, impossible to go back in http and it bug, the other pages are staying in http, but if I put the https manually the site crashes, the pages are not well written

    Thank you for your help
    for my english, i am french

    #50233 Reply

    Without seeing the issue myself it is hard to say what the problem is. Based on your description possibly it might help to add

    $_SERVER[“HTTPS”] = “on”;

    to your wp-config.php.

    This will make sure is_ssl() will return true. is_ssl() is a function WordPress uses to determine if it is on SSL. This should return when your admin is loaded over https, but will always return false when loaded over http.

    Normally Really Simple SSL will insert this for you, but if the wpconfig is not writable, or the server does not allow access to the testpage, this insertion might have failed.

    If this does not solve the issue, can you supply me with some more details, like
    – A screenshot of the error(s)
    – A debug log of the plugin

    Let me know if this helps!

    #50242 Reply

    @Bebe Kinnett,

    Can you submit a support request, and check your spam for incoming emails?

    I can’t say for sure, and I can’t reproduce it, but as you describe the issue as an error on activation, my guess is that another plugin is flushing the rewrite rules at the wrong moment, causing Really Simple SSL to flush on an empty object.

    If that is the case, a quick fix would be to comment out in line 97 in wp-content/plugins/really-simple-ssl/class-admin.php:
    add_action( 'shutdown', 'flush_rewrite_rules');

    like this:
    //add_action( 'shutdown', 'flush_rewrite_rules');

    If activation does not cause an error, but cause styling issues, breaking the layout, you might want to check if the mixed content fixer is active:
    https://really-simple-ssl.com/knowledge-base/how-to-check-if-the-mixed-content-fixer-is-active/

    If it is not, and you have cleared all caches, there is a plugin blocking the mixed content fixer. In that case, you can find which plugin is causing this by deactivating them one by one. Especially social plugins are know to sometimes do this.

    #50539 Reply

    Bebe Kinnett
    Participant

    absolutewebdesigns.com Internal pages will not load at all.
    Debug:

    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.20
    Already on SSL, start detecting configuration
    ssl type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://absolutewebdesigns.com/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    settings page, or network admin, updating htaccess…
    retrieving redirect rules
    starting insertion of .htaccess redirects.
    single site or networkwide activation
    converting siteurl and homeurl to https

    #50556 Reply

    Did you try re-saving the permalinks?

    You have a redirect loop on this site. There are a few possible causes for this:
    – A plugin redirects back to http (most likely). For example, SSL settings in iThemes can cause this.
    – A redirect in the .htaccess to http
    – A redirect on the server to http.

    Because Really Simple SSL redirects to https, the redirect to http causes an infinite loop. Removing the redirect to http will fix the problem.

    I have created a list with common redirect loop issues here:
    https://really-simple-ssl.com/knowledge-base/my-website-is-in-a-redirect-loop/
    You can ignore the CloudFlare, Varnish and certificate items, these do no apply to you.

    #92124 Reply

    DMYTRO PYLTIAI
    Participant

    Ouhhh,… This isn’t the really simple journey, you know… I just bought my 5-sites license, and spent almost 2 hours been trying to make the plugin workable @ my main website…

    The issue is that when I start to do something even go through the SSL settings, occasionally my database connection is gonna be breaking, simply thanks to what I have my dedicated server hosted at Cloudways (BTW, the Let’s Encrypt SSL Certificate comes from there too, and installed properly for both non-www and www domains), I try to manage this of somehow… Anyway, so far, I cannot make a full scan for my mixed content, etc., etc. …

    May someone go to the Admin of my website to look of what’s going on, and try to make the plugin workable in the end? Thanks in advance.

    #92150 Reply

    Sure, can you submit a support request at really-simple-ssl.com/support and include your credentials so we can take a look at your site? We should be able to set you up quickly!

    #95048 Reply

    Gavynn W

    Hello, I am having a issue with the site after activating the plugin and have tried the various fixes in the thread above to no avail.

    Currently there are 8 images that are not loading on the banner on the homepage.

    Here is the debug log:

    Options:
    * WordPress redirect
    * Mixed content fixer
    SERVER: litespeed
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.26
    Already on SSL, start detecting configuration
    SSL type: SERVER-HTTPS-ON
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://denvertherapies.com/wp-content/plugins/really-simple-ssl/testssl/serverhttpson/ssl-test-page.html
    htaccess rules tested successfully.
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #95056 Reply

    I just checked your site, but didn’t see any issues with the banner images. Did you fix this in the meantime?

    #111913 Reply

    Eugene

    Activated the plugin and now the website is not working. Every time I attempt to go to my page it asks me to download a script. How to fix it?

    #111946 Reply

    Your site asks you to download a script? That is certainly not the doing of Really Simple SSL. Can you post a domain so I can take a look, or submit a support ticket?

    Do you have a valid SSL certificate?

    #113477 Reply

    LT

    URGENTE!!!
    Buongiorno, durante l’aggiornamento del plugin sul sito si è verificato questo errore
    “Parse error: syntax error, unexpected T_FUNCTION in /home/campania/public_html/wp-content/plugins/really-simple-ssl/class-mixed-content-fixer.php on line 173”

    Come si risolve?

    Grazie

    #113492 Reply

    Mark Wolters
    Keymaster

    Hi LT,

    it’s likely your PHP version is below 5.3.0. Anonymous functions, like the one used on line 173 of the class-mixed-content-fixer.php files were added in PHP 5.3.0. Can you check which PHP version your site uses and update it if it’s below 5.3.0?

    If it’s not possible for you to update PHP, you can comment out lines 173-175 in the class-mixed-content-fixer.php file by adding // in front of the lines, like this:

    //            $str = preg_replace_callback('/<img[^\>]*[^\>\S]+srcset=[\'"]\K((?:[^"\'\s,]+\s*(?:\s+\d+[wx])(?:,\s*)?)+)["\']/', function ($matches) {
    //                return str_replace("http://", "https://", $matches[0]);
    //            }, $str);

    Do note that updating Really Simple SSL will undo these changes, so we do recommend to update PHP.

    Mark

    #113496 Reply

    Robert Hays

    When I activate the new (this morning) release of Really Simple SSL I get this error for all pages:

    Parse error: syntax error, unexpected T_FUNCTION in /home/content/58/8611758/html/Blog/wp-content/plugins/really-simple-ssl/class-mixed-content-fixer.php on line 173

    I’m also a Pro subscriber so I’d like some help please 🙂 Right now I’ve removed both plugins.

    Thanks! – Bob

    #113499 Reply

    Mark Wolters
    Keymaster

    Hi Bob,

    can you check which PHP version your site uses? Anonymous functions have been added in PHP 5.3.0, it could be the site is using a lower PHP version and therefore fails. If so, updating PHP to a version higher than 5.3.0 should resolve the issue.

    Mark

    #113507 Reply

    Robert Hays

    Thanks! I learned how to update PHP on my hosted account and with 5.6 it works. Including the Pro plugin.

    #113520 Reply

    Mark Wolters
    Keymaster

    Great, glad to hear updating PHP solved the issue.

    #130276 Reply

    Jake

    Hi after following up on the above threads i cant seem to get a solution.
    So i didnt back up the site as it stated. i did however delete the plugin from my plugin database. but still cant access my wordpress dashboard

    #130282 Reply

    Mark Wolters
    Keymaster

    Hi Jake,

    what error are you getting exactly? Does the site work on the front-end? Often when the dashboard isn’t available WordPress fails to detect the site is on SSL. This can be fixed by adding the $_SERVER["HTTPS"] = "on"; line to your wp-config.php file.

    Mark

    #140824 Reply

    John

    Hello,

    I installed the plugin and I am getting a 502 gateway error and I can not access the WordPress admin to disable the plugin. Please help! http://www.fullshotmedia.com is fully down right now due to this plugin.

    John

    #140902 Reply

    Mark Wolters
    Keymaster

    Hi John,

    On certain hosting environments it appears the function used to check the certificate, the wp_remote_get() function is very slow, which might cause a timeout. To counter this, we have implemented caching in the plugin so these functions run only once. You can find the the version that contains this here: https://github.com/rlankhorst/really-simple-ssl/tree/transients-test-htaccess-mixedcontent-test-page. The class-certificate.php and class-admin.php files have been changed, you can download these and upload them via FTP to the /wp-content/plugins/really-simple-ssl/ directory.

    You can always deactivate the plugin using the force deactivate script: https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

Viewing 27 posts - 1 through 27 (of 27 total)
Reply To: Activating plugin breaks site
Your information: