[Support request] 503 errors

Home Forums Really Simple SSL pro 503 errors

This topic contains 1 reply, has 2 voices, and was last updated by  Rogier Lankhorst 4 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #163248 Reply

    Nathan Yokoyama

    Hello,

    I have been receiving 503 errors reported by users of my site. It seems to have coincided when I installed a SSL cert and ran Really Simple SSL Premium.

    I’ve read the few suggestions here and am at a loss. While I use WordPress when it comes to this I am at a loss. I do not know if just disabling the plugin really does anything as the site’s internal links were updated from http: to https:.

    I’m desperate for help. I can’t reproduce the error -it is reported to me. So the suggestion of removing all plugins and enabling them one at a time is of no use to me since I can’t reproduce the error on my own.

    Thanks,

    Nathan

    #163356 Reply

    I have had a similar issue in the past with iThemes security. Deactivating iThemes resolved the issue in that case. I discovered the cause with a combination of error logging, and patience: I had to wait until I had this error myself, then checked the logs: fatal memory error. Then I tried the site in a different browser: no issues. Back to the original browser: memory error. After deactivating iThemes the error was gone. Activating the plugin again brought it back. It was quite consistent, but tied to a specific browser session.

    It is quite possible this is not caused by iThemes on your site, but by another plugin, or by generic memory issues.

    I would enable error logging so you can at least check the nature of the error. you can do this by adding to your wp-config.php:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);
    define(‘WP_DEBUG_LOG’, true);

    Then, as soon as you get the error yourself (which should happen sooner or later) you can do the same checks I did, and do some tests.

    When deactivating Really Simple SSL, please always use the “deactivate but keep https” option in settings/ssl.

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: 503 errors
Your information: